Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сортировка таблицы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка таблицы (Формулы/Formulas)
Сортировка таблицы
AnnaKha Дата: Среда, 19.10.2022, 15:44 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 20% ±

Привет!
Помогите пожалуйста сделать динамически генерируемую таблицу по отношению к полям на первом листе.
Смысл следующий:
на первом листе в таблице есть столбец Роль, необходимо на втором листе в упрощенной версии таблицы переносить часть полей из первой, но только те строки, которые содержат слово «Клиент» в столбце Роль.

Есть еще один нюанс, необходимо, чтобы Статистика втором листе включала в себя еще и скрытые строки, содержащие слово «Клиент». В файле-примере оно выглядит как группировка.
К сообщению приложен файл: 9656292.xlsx(88.1 Kb)
 
Ответить
СообщениеПривет!
Помогите пожалуйста сделать динамически генерируемую таблицу по отношению к полям на первом листе.
Смысл следующий:
на первом листе в таблице есть столбец Роль, необходимо на втором листе в упрощенной версии таблицы переносить часть полей из первой, но только те строки, которые содержат слово «Клиент» в столбце Роль.

Есть еще один нюанс, необходимо, чтобы Статистика втором листе включала в себя еще и скрытые строки, содержащие слово «Клиент». В файле-примере оно выглядит как группировка.

Автор - AnnaKha
Дата добавления - 19.10.2022 в 15:44
Nic70y Дата: Среда, 19.10.2022, 16:09 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7878
Репутация: 1894 ±
Замечаний: 0% ±

Excel 2010
доп.столбец
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ("Клиент";ИНДЕКС(МОНИТОРЩИЦА!C:C;A1+1):МОНИТОРЩИЦА!C$9999;)+A1;"ю")
далее
Код
=ИНДЕКС()
К сообщению приложен файл: 59.xlsx(96.4 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениедоп.столбец
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ("Клиент";ИНДЕКС(МОНИТОРЩИЦА!C:C;A1+1):МОНИТОРЩИЦА!C$9999;)+A1;"ю")
далее
Код
=ИНДЕКС()

Автор - Nic70y
Дата добавления - 19.10.2022 в 16:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!