Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выставление оценок через формулы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выставление оценок через формулы (Формулы/Formulas)
Выставление оценок через формулы
Admnis Дата: Среда, 02.11.2022, 11:31 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Добрый день, форумчане!

Подскажите, Необходимо чтоб в столбце F отображалось "Отл" если в столбцах C,D,E, при наличии одной "Хор"
А если уже две и более "Хор", то отображалось бы "Хор"
Пример прилагаю. Нужно именно чтоб формулой, макросы не работают.
Пробовал сам но не получилось Формулой
Код
=ЕСЛИ(ЕОШИБКА(НАЙТИ("Неуд";C2&D2&E2));ЕСЛИ(ЕОШИБКА(НАЙТИ("Уд";C2&D2&E2));ЕСЛИ(ЕОШИБКА(НАЙТИ("Хор";C2&D2&E2));"Отл";"Хор");"Уд");"Неуд")


Сообщение отредактировал Serge_007 - Среда, 02.11.2022, 11:46
 
Ответить
СообщениеДобрый день, форумчане!

Подскажите, Необходимо чтоб в столбце F отображалось "Отл" если в столбцах C,D,E, при наличии одной "Хор"
А если уже две и более "Хор", то отображалось бы "Хор"
Пример прилагаю. Нужно именно чтоб формулой, макросы не работают.
Пробовал сам но не получилось Формулой
Код
=ЕСЛИ(ЕОШИБКА(НАЙТИ("Неуд";C2&D2&E2));ЕСЛИ(ЕОШИБКА(НАЙТИ("Уд";C2&D2&E2));ЕСЛИ(ЕОШИБКА(НАЙТИ("Хор";C2&D2&E2));"Отл";"Хор");"Уд");"Неуд")

Автор - Admnis
Дата добавления - 02.11.2022 в 11:31
Serge_007 Дата: Среда, 02.11.2022, 11:49 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15538
Репутация: 2558 ±
Замечаний: ±

Excel 2016
"Отл" если в столбцах C,D,E, при наличии одной "Хор"
А если уже две и более "Хор", то отображалось бы "Хор"
Вы не ошибаетесь?
За одну "Хор" ставить "Отл", а за две и более "Хор" ставить "Хор"?

Пример прилагаю
Куда прилагаете?


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
"Отл" если в столбцах C,D,E, при наличии одной "Хор"
А если уже две и более "Хор", то отображалось бы "Хор"
Вы не ошибаетесь?
За одну "Хор" ставить "Отл", а за две и более "Хор" ставить "Хор"?

Пример прилагаю
Куда прилагаете?

Автор - Serge_007
Дата добавления - 02.11.2022 в 11:49
cmivadwot Дата: Среда, 02.11.2022, 23:35 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 85
Репутация: 5 ±
Замечаний: 0% ±

Admnis, непонятные критерии... а 2 и 3 не может быть?
К сообщению приложен файл: 7096776.xlsx(13.6 Kb)
 
Ответить
СообщениеAdmnis, непонятные критерии... а 2 и 3 не может быть?

Автор - cmivadwot
Дата добавления - 02.11.2022 в 23:35
Gustav Дата: Четверг, 03.11.2022, 02:03 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2211
Репутация: 893 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Если правильно понял, то как-то так, наверное:
Код
=ЕСЛИ(СЧЁТЕСЛИ(C2:E2;"Неуд");"Неуд";ЕСЛИ(СЧЁТЕСЛИ(C2:E2;"Уд");"Уд";ЕСЛИ(СЧЁТЕСЛИ(C2:E2;"Хор")>1;"Хор";"Отл")))

или вид а-ля Beautifier
[vba]
Код
=ЕСЛИ(
    СЧЁТЕСЛИ(C2:E2;"Неуд");
    "Неуд";
    ЕСЛИ(
        СЧЁТЕСЛИ(C2:E2;"Уд");
        "Уд";
        ЕСЛИ(
            СЧЁТЕСЛИ(C2:E2;"Хор")>1;
            "Хор";
            "Отл"
        )
    )
)
[/vba]
Разумеется, это при условии, что все три ячейки в C2:E2 заполнены оценками (т.е. ячейки не пусты).

[p.s.]А на случай несмежных ячеек можно так:[/p.s.]
[vba]
Код
=ЕСЛИ(
    ЕЧИСЛО(ПОИСК("Неуд";C2&E2&H2));
    "Неуд";
    ЕСЛИ(
        ЕЧИСЛО(ПОИСК("Уд";C2&E2&H2));
        "Уд";
        ЕСЛИ(
            СУММ(C2="Хор";E2="Хор";H2="Хор")>1;
            "Хор";
            "Отл"
        )
    )
)
[/vba]


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Четверг, 03.11.2022, 11:45
 
Ответить
СообщениеЕсли правильно понял, то как-то так, наверное:
Код
=ЕСЛИ(СЧЁТЕСЛИ(C2:E2;"Неуд");"Неуд";ЕСЛИ(СЧЁТЕСЛИ(C2:E2;"Уд");"Уд";ЕСЛИ(СЧЁТЕСЛИ(C2:E2;"Хор")>1;"Хор";"Отл")))

или вид а-ля Beautifier
[vba]
Код
=ЕСЛИ(
    СЧЁТЕСЛИ(C2:E2;"Неуд");
    "Неуд";
    ЕСЛИ(
        СЧЁТЕСЛИ(C2:E2;"Уд");
        "Уд";
        ЕСЛИ(
            СЧЁТЕСЛИ(C2:E2;"Хор")>1;
            "Хор";
            "Отл"
        )
    )
)
[/vba]
Разумеется, это при условии, что все три ячейки в C2:E2 заполнены оценками (т.е. ячейки не пусты).

[p.s.]А на случай несмежных ячеек можно так:[/p.s.]
[vba]
Код
=ЕСЛИ(
    ЕЧИСЛО(ПОИСК("Неуд";C2&E2&H2));
    "Неуд";
    ЕСЛИ(
        ЕЧИСЛО(ПОИСК("Уд";C2&E2&H2));
        "Уд";
        ЕСЛИ(
            СУММ(C2="Хор";E2="Хор";H2="Хор")>1;
            "Хор";
            "Отл"
        )
    )
)
[/vba]

Автор - Gustav
Дата добавления - 03.11.2022 в 02:03
msi2102 Дата: Четверг, 03.11.2022, 08:56 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 246
Репутация: 89 ±
Замечаний: 0% ±

Excel 2007
Куда прилагаете?

СЮДА
 
Ответить
Сообщение
Куда прилагаете?

СЮДА

Автор - msi2102
Дата добавления - 03.11.2022 в 08:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выставление оценок через формулы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!