Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать числа в строке по определенному условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать числа в строке по определенному условию (Формулы/Formulas)
Посчитать числа в строке по определенному условию
muratzh81 Дата: Вторник, 08.11.2022, 09:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 60% ±

Доброе время суток! Помогите пожалуйста с формулой подсчета суммы чисел в строке по условию например "р/п"? Данный критерий может как и присутсnвовать так и отсутствовать за период.
К сообщению приложен файл: 1296423.xls(34.5 Kb)
 
Ответить
СообщениеДоброе время суток! Помогите пожалуйста с формулой подсчета суммы чисел в строке по условию например "р/п"? Данный критерий может как и присутсnвовать так и отсутствовать за период.

Автор - muratzh81
Дата добавления - 08.11.2022 в 09:50
Nic70y Дата: Вторник, 08.11.2022, 10:01 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7875
Репутация: 1894 ±
Замечаний: 0% ±

Excel 2010
формула массива
Код
=СУММ(ЕСЛИ(A2:O2="р/п";--ЛЕВБ(A3:O3;ПОИСК("/";A3:O3)-1)))
К сообщению приложен файл: 2372196.xls(35.0 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеформула массива
Код
=СУММ(ЕСЛИ(A2:O2="р/п";--ЛЕВБ(A3:O3;ПОИСК("/";A3:O3)-1)))

Автор - Nic70y
Дата добавления - 08.11.2022 в 10:01
muratzh81 Дата: Вторник, 08.11.2022, 10:23 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 60% ±

Спасибо, а если суммировать несколько строк, прилагаю файл
К сообщению приложен файл: 3562720.xlsx(11.7 Kb)


Сообщение отредактировал muratzh81 - Вторник, 08.11.2022, 10:24
 
Ответить
СообщениеСпасибо, а если суммировать несколько строк, прилагаю файл

Автор - muratzh81
Дата добавления - 08.11.2022 в 10:23
Serge_007 Дата: Вторник, 08.11.2022, 10:48 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15571
Репутация: 2559 ±
Замечаний: ±

Excel 2016
muratzh81, чем Ваш второй файл принципиально отличается от первого?


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщениеmuratzh81, чем Ваш второй файл принципиально отличается от первого?

Автор - Serge_007
Дата добавления - 08.11.2022 в 10:48
muratzh81 Дата: Вторник, 08.11.2022, 10:59 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 60% ±

Разницы нет, просто не могу заставить складывать

Скрин


Сообщение отредактировал muratzh81 - Вторник, 08.11.2022, 11:00
 
Ответить
СообщениеРазницы нет, просто не могу заставить складывать

Скрин

Автор - muratzh81
Дата добавления - 08.11.2022 в 10:59
DrMini Дата: Вторник, 08.11.2022, 11:33 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 885
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
просто не могу заставить складывать

Просто измените в формуле диапазоны подсчёта
К сообщению приложен файл: 3562720-1-.xlsx(11.8 Kb)


Сообщение отредактировал DrMini - Вторник, 08.11.2022, 11:34
 
Ответить
Сообщение
просто не могу заставить складывать

Просто измените в формуле диапазоны подсчёта

Автор - DrMini
Дата добавления - 08.11.2022 в 11:33
muratzh81 Дата: Четверг, 10.11.2022, 08:26 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 60% ±

Всем спасибо! Извините за нарушения правил.
 
Ответить
СообщениеВсем спасибо! Извините за нарушения правил.

Автор - muratzh81
Дата добавления - 10.11.2022 в 08:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать числа в строке по определенному условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!