Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула поиска и вставки данных - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула поиска и вставки данных (Формулы/Formulas)
Формула поиска и вставки данных
vanchoyz1997 Дата: Пятница, 11.11.2022, 15:00 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 40% ±

Нужно из таблицы "А1:Е30" выбрать данные по ЛС "Столбец А" в "стобец J" к примеру нужно имена по ЛС а100 и из таблицы "А1:Е30" они перенесутся в строчку ("J2"K2"L2"M2"N2"O2" и тд)
По типу формулы ВПР только для множества повторяющихся значений "как то искал что то подобное и это была новая формула в офисе 2021 если не ошибаюсь но сейчас не могу найти"
пытался использовать ПОИСКПОЗ вместе с ИНДЕКС в итоге он проглатывал некоторые строки да и выводил не так как нужно
К сообщению приложен файл: 3470639.xlsx(11.1 Kb)


Сообщение отредактировал vanchoyz1997 - Пятница, 11.11.2022, 15:01
 
Ответить
СообщениеНужно из таблицы "А1:Е30" выбрать данные по ЛС "Столбец А" в "стобец J" к примеру нужно имена по ЛС а100 и из таблицы "А1:Е30" они перенесутся в строчку ("J2"K2"L2"M2"N2"O2" и тд)
По типу формулы ВПР только для множества повторяющихся значений "как то искал что то подобное и это была новая формула в офисе 2021 если не ошибаюсь но сейчас не могу найти"
пытался использовать ПОИСКПОЗ вместе с ИНДЕКС в итоге он проглатывал некоторые строки да и выводил не так как нужно

Автор - vanchoyz1997
Дата добавления - 11.11.2022 в 15:00
китин Дата: Пятница, 11.11.2022, 15:28 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6907
Репутация: 1057 ±
Замечаний: 0% ±

Excel 2007;2010;2016
Код
=ЕСЛИОШИБКА(ИНДЕКС($D$2:$D$30;НАИМЕНЬШИЙ(ЕСЛИ($I2=$A$2:$A$30;СТРОКА($A$2:$A$30)-1);СТОЛБЕЦ(A1)));"")

формула массива.
К сообщению приложен файл: 9705822.xlsx(14.3 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС($D$2:$D$30;НАИМЕНЬШИЙ(ЕСЛИ($I2=$A$2:$A$30;СТРОКА($A$2:$A$30)-1);СТОЛБЕЦ(A1)));"")

формула массива.

Автор - китин
Дата добавления - 11.11.2022 в 15:28
vanchoyz1997 Дата: Пятница, 11.11.2022, 15:31 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 40% ±

китин, Благодарю
 
Ответить
Сообщениекитин, Благодарю

Автор - vanchoyz1997
Дата добавления - 11.11.2022 в 15:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула поиска и вставки данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!