Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула поиска по дате, для определенного значения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула поиска по дате, для определенного значения (Формулы/Formulas)
Формула поиска по дате, для определенного значения
Lehani12 Дата: Пятница, 11.11.2022, 17:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Помогите пожалуйста создать формулу что бы при написании в ячейку даты начиная с 01.01.1960 и т.д. выдавал определенное значение, всего значений 7 и они циклично повторяются, последние даты 01.01.2050
К сообщению приложен файл: 8581831.xls(46.5 Kb)


Сообщение отредактировал Lehani12 - Пятница, 11.11.2022, 17:39
 
Ответить
СообщениеПомогите пожалуйста создать формулу что бы при написании в ячейку даты начиная с 01.01.1960 и т.д. выдавал определенное значение, всего значений 7 и они циклично повторяются, последние даты 01.01.2050

Автор - Lehani12
Дата добавления - 11.11.2022 в 17:14
Serge_007 Дата: Пятница, 11.11.2022, 17:26 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15571
Репутация: 2559 ±
Замечаний: ±

Excel 2016
Создать формулу
Можно приступать к выполнению приказа?


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Создать формулу
Можно приступать к выполнению приказа?

Автор - Serge_007
Дата добавления - 11.11.2022 в 17:26
Gustav Дата: Пятница, 11.11.2022, 17:44 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2211
Репутация: 893 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Можно приступать

Ага, типа "время пошло" %)

Такая формула (для B1):
Код
=ИНДЕКС({"♃";"♀";"♄";"☉";"☽";"♂";"☿"};ДЕНЬНЕД(A1;14))

либо:
Код
=ВЫБОР(ДЕНЬНЕД(A1;14);"♃";"♀";"♄";"☉";"☽";"♂";"☿")

либо совсем короткая:
Код
=ПСТР("♃♀♄☉☽♂☿";ДЕНЬНЕД(A1;14);1)

для таблиц Google можно дополнительно еще так извратиться - через код символа:
Код
=CHAR(9790+CHOOSE(WEEKDAY(A1;14);5;2;6;-53;-1;4;1))


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Пятница, 11.11.2022, 18:09
 
Ответить
Сообщение
Можно приступать

Ага, типа "время пошло" %)

Такая формула (для B1):
Код
=ИНДЕКС({"♃";"♀";"♄";"☉";"☽";"♂";"☿"};ДЕНЬНЕД(A1;14))

либо:
Код
=ВЫБОР(ДЕНЬНЕД(A1;14);"♃";"♀";"♄";"☉";"☽";"♂";"☿")

либо совсем короткая:
Код
=ПСТР("♃♀♄☉☽♂☿";ДЕНЬНЕД(A1;14);1)

для таблиц Google можно дополнительно еще так извратиться - через код символа:
Код
=CHAR(9790+CHOOSE(WEEKDAY(A1;14);5;2;6;-53;-1;4;1))

Автор - Gustav
Дата добавления - 11.11.2022 в 17:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула поиска по дате, для определенного значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!