Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/вычисление среднего значения каждых n ячеек столбца - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вычисление среднего значения каждых n ячеек столбца (Формулы/Formulas)
вычисление среднего значения каждых n ячеек столбца
Zing Дата: Воскресенье, 13.11.2022, 13:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте, подскажите, пожалуйста есть ли какая-то формула для решения моей задачи.
Имеется столбец много тысяч строк с данными (числа), нужно чтобы брались n ячеек этого столбца по ним считалось среднее значение, затем брались следующие после этих ячеек n ячеек и опять считалось их среднее. В результате хотелось бы получить другой столбец с усредненными значениями каждых n ячеек исходного столбца.
Формула найденная в интернете и представленная на скрине не работает.
также прилагаю файл с примерным набором данных
К сообщению приложен файл: 7413827.xlsx(216.4 Kb) · 6129667.png(32.0 Kb)
 
Ответить
СообщениеЗдравствуйте, подскажите, пожалуйста есть ли какая-то формула для решения моей задачи.
Имеется столбец много тысяч строк с данными (числа), нужно чтобы брались n ячеек этого столбца по ним считалось среднее значение, затем брались следующие после этих ячеек n ячеек и опять считалось их среднее. В результате хотелось бы получить другой столбец с усредненными значениями каждых n ячеек исходного столбца.
Формула найденная в интернете и представленная на скрине не работает.
также прилагаю файл с примерным набором данных

Автор - Zing
Дата добавления - 13.11.2022 в 13:07
bmv98rus Дата: Воскресенье, 13.11.2022, 14:02 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3954
Репутация: 732 ±
Замечаний: 0% ±

Excel 2013/2016
а не кросc ли это?


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениеа не кросc ли это?

Автор - bmv98rus
Дата добавления - 13.11.2022 в 14:02
прохожий2019 Дата: Воскресенье, 13.11.2022, 14:03 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 955
Репутация: 262 ±
Замечаний: 0% ±

365 Beta Channel
Код
=СРЗНАЧ(СМЕЩ($A$1;1+(СТРОКА(A1)-1)*5;;5))

хотя лучше конечно
Код
=СРЗНАЧ(ИНДЕКС(A:A;2+(СТРОКА(A1)-1)*5):ИНДЕКС(A:A;6+(СТРОКА(A1)-1)*5))
К сообщению приложен файл: 1015584.xlsx(217.6 Kb)


Сообщение отредактировал прохожий2019 - Воскресенье, 13.11.2022, 14:06
 
Ответить
Сообщение
Код
=СРЗНАЧ(СМЕЩ($A$1;1+(СТРОКА(A1)-1)*5;;5))

хотя лучше конечно
Код
=СРЗНАЧ(ИНДЕКС(A:A;2+(СТРОКА(A1)-1)*5):ИНДЕКС(A:A;6+(СТРОКА(A1)-1)*5))

Автор - прохожий2019
Дата добавления - 13.11.2022 в 14:03
Gustav Дата: Воскресенье, 13.11.2022, 15:59 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2211
Репутация: 893 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Мои экзотические "5 копеек" для ячейки C2 и протягивания ниже:
Код
=СРЗНАЧ(A:A ДВССЫЛ(5*СТРОКА()-8 & ":" & 5*СТРОКА()-4))

(используется пересечение диапазонов - колонки A и пяти последовательных строк)


МОИ: Ник, Tip box: 41001663842605
 
Ответить
СообщениеМои экзотические "5 копеек" для ячейки C2 и протягивания ниже:
Код
=СРЗНАЧ(A:A ДВССЫЛ(5*СТРОКА()-8 & ":" & 5*СТРОКА()-4))

(используется пересечение диапазонов - колонки A и пяти последовательных строк)

Автор - Gustav
Дата добавления - 13.11.2022 в 15:59
прохожий2019 Дата: Воскресенье, 13.11.2022, 16:06 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 955
Репутация: 262 ±
Замечаний: 0% ±

365 Beta Channel
ну если забыть про волатильность - СМЕЩ самой шустрой оказывается

хотя она же шустрее с полным синтаксисом )))
К сообщению приложен файл: 4722760.png(60.6 Kb) · 0841774.png(16.3 Kb)


Сообщение отредактировал прохожий2019 - Воскресенье, 13.11.2022, 17:15
 
Ответить
Сообщениену если забыть про волатильность - СМЕЩ самой шустрой оказывается

хотя она же шустрее с полным синтаксисом )))

Автор - прохожий2019
Дата добавления - 13.11.2022 в 16:06
Zing Дата: Воскресенье, 13.11.2022, 23:31 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Превелико благодарю всех за оказанную помощь
 
Ответить
СообщениеПревелико благодарю всех за оказанную помощь

Автор - Zing
Дата добавления - 13.11.2022 в 23:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вычисление среднего значения каждых n ячеек столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!