Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммировать значения из листа2 в лист1 по условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать значения из листа2 в лист1 по условию (Формулы/Formulas)
Суммировать значения из листа2 в лист1 по условию
ziminigor1981 Дата: Среда, 16.11.2022, 11:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте.
Есть документ с 2-мя таблицами, на 1-м листе список имен, на 2-м список имен и значения, Имена могут повторяться и иметь разные окончания.
Требуется, в 1-й лист проставить сумму значений из 2-го при совпадении имени по первым четырем буквам имени, без учета региста.
Помогите, уже третий день сижу.
К сообщению приложен файл: Empl.xls(7.0 Kb)
 
Ответить
СообщениеЗдравствуйте.
Есть документ с 2-мя таблицами, на 1-м листе список имен, на 2-м список имен и значения, Имена могут повторяться и иметь разные окончания.
Требуется, в 1-й лист проставить сумму значений из 2-го при совпадении имени по первым четырем буквам имени, без учета региста.
Помогите, уже третий день сижу.

Автор - ziminigor1981
Дата добавления - 16.11.2022 в 11:19
_Boroda_ Дата: Среда, 16.11.2022, 11:21 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16470
Репутация: 6418 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИ(Лист2!A:A;ЛЕВБ(A2;4)&"*";Лист2!B:B)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИ(Лист2!A:A;ЛЕВБ(A2;4)&"*";Лист2!B:B)

Автор - _Boroda_
Дата добавления - 16.11.2022 в 11:21
bigor Дата: Среда, 16.11.2022, 11:25 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 699
Репутация: 143 ±
Замечаний: 0% ±

нет
или так
Код
=SUMPRODUCT((LEFT(Лист2!$A$2:$A$6;3)=A2)*$Лист2!B2:B6)


Сообщение отредактировал bigor - Среда, 16.11.2022, 11:45
 
Ответить
Сообщениеили так
Код
=SUMPRODUCT((LEFT(Лист2!$A$2:$A$6;3)=A2)*$Лист2!B2:B6)

Автор - bigor
Дата добавления - 16.11.2022 в 11:25
ziminigor1981 Дата: Среда, 16.11.2022, 11:39 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_, Да спасибо. Дальше буду корректировать.
Ещё раз СПАСИБО hands
 
Ответить
Сообщение_Boroda_, Да спасибо. Дальше буду корректировать.
Ещё раз СПАСИБО hands

Автор - ziminigor1981
Дата добавления - 16.11.2022 в 11:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать значения из листа2 в лист1 по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!