Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать сумму по сотруднику исходя из % по условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сумму по сотруднику исходя из % по условию (Формулы/Formulas)
Посчитать сумму по сотруднику исходя из % по условию
Tutum5045 Дата: Вторник, 22.11.2022, 20:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый день, знатоки! Помогите, пожалуйста, составить формулу. Есть массив данных, массив лист данные A2:H17. Необходимо в сводной таблице посчитать по сотрудникам их суммы, исходя из % за условия. Условия в столбце D на листе Данные. % по условиям с привязкой к сотрудникам в таблице на листе условия. Считать, если выполняется дополнительное условие, "з"="" в колонке C на листе условия, на листе Данные это колонка E.
К сообщению приложен файл: 3722952.xlsx(13.3 Kb)


Сообщение отредактировал Tutum5045 - Вторник, 22.11.2022, 20:35
 
Ответить
СообщениеДобрый день, знатоки! Помогите, пожалуйста, составить формулу. Есть массив данных, массив лист данные A2:H17. Необходимо в сводной таблице посчитать по сотрудникам их суммы, исходя из % за условия. Условия в столбце D на листе Данные. % по условиям с привязкой к сотрудникам в таблице на листе условия. Считать, если выполняется дополнительное условие, "з"="" в колонке C на листе условия, на листе Данные это колонка E.

Автор - Tutum5045
Дата добавления - 22.11.2022 в 20:20
gling Дата: Вторник, 22.11.2022, 21:58 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2389
Репутация: 625 ±
Замечаний: 0% ±

2010
А может быть покажете какой должен получиться результат? Не понятны условия, ведь на листе "Условия" в столбце С "з"="" только для строк женщина и девочки, значит для мужчин не считать и мальчиков результат равен 0? Ведь там "з"=1, а следовательно условие не выполнено.


ЯД-41001506838083

Сообщение отредактировал gling - Вторник, 22.11.2022, 21:59
 
Ответить
СообщениеА может быть покажете какой должен получиться результат? Не понятны условия, ведь на листе "Условия" в столбце С "з"="" только для строк женщина и девочки, значит для мужчин не считать и мальчиков результат равен 0? Ведь там "з"=1, а следовательно условие не выполнено.

Автор - gling
Дата добавления - 22.11.2022 в 21:58
Tutum5045 Дата: Вторник, 22.11.2022, 22:50 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

значит для мужчин не считать и мальчиков результат равен 0?

Да, абсолютно верно, если "з"=1, значит не считать. Считать только где "з"="". Т.е считаем и заполняем значение для Женщина и Девочка. Т.е. по Женщине должно быть 850*55%(условие 17)+2000*65%(условие 6)+500*55%(условие 18)+1100*17%(условие 8)=2229,5
 
Ответить
Сообщение
значит для мужчин не считать и мальчиков результат равен 0?

Да, абсолютно верно, если "з"=1, значит не считать. Считать только где "з"="". Т.е считаем и заполняем значение для Женщина и Девочка. Т.е. по Женщине должно быть 850*55%(условие 17)+2000*65%(условие 6)+500*55%(условие 18)+1100*17%(условие 8)=2229,5

Автор - Tutum5045
Дата добавления - 22.11.2022 в 22:50
_Boroda_ Дата: Среда, 23.11.2022, 09:46 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16499
Репутация: 6422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вроде вот
Код
=ЕСЛИ(ВПР(A24;Условия!A$3:C$6;3;);;СУММПРОИЗВ((G$3:G$17=A24)*H$3:H$17*СУММЕСЛИ(Условия!D$2:AK$2;D$3:D$17;ИНДЕКС(Условия!D$3:AK$6;ПОИСКПОЗ(A24;Условия!A$3:A$6;);))))

Как остальное считать - не понял )))
К сообщению приложен файл: 3722952_1.xlsx(12.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВроде вот
Код
=ЕСЛИ(ВПР(A24;Условия!A$3:C$6;3;);;СУММПРОИЗВ((G$3:G$17=A24)*H$3:H$17*СУММЕСЛИ(Условия!D$2:AK$2;D$3:D$17;ИНДЕКС(Условия!D$3:AK$6;ПОИСКПОЗ(A24;Условия!A$3:A$6;);))))

Как остальное считать - не понял )))

Автор - _Boroda_
Дата добавления - 23.11.2022 в 09:46
Tutum5045 Дата: Среда, 23.11.2022, 13:14 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Как остальное считать - не понял )))
Спасибо БОЛЬШОЕ!!! С остальным разберусь. Сдвинусь с мёртвой точки!
 
Ответить
Сообщение
Как остальное считать - не понял )))
Спасибо БОЛЬШОЕ!!! С остальным разберусь. Сдвинусь с мёртвой точки!

Автор - Tutum5045
Дата добавления - 23.11.2022 в 13:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сумму по сотруднику исходя из % по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!