Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт верхних цифр в ячейке до Alt+Enter - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт верхних цифр в ячейке до Alt+Enter (Формулы/Formulas)
Подсчёт верхних цифр в ячейке до Alt+Enter
DrMini Дата: Среда, 23.11.2022, 10:24 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 886
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Доброго времени суток форумчане и гости форума.
В файл из программы выгрузили данные видимо разделённые в ячейке на "уровни" Alt+Enter.
Подскажите, как (если это возможно) произвести вычисления только с цифрами в первом ряду.
К сообщению приложен файл: 5159456.jpg(10.8 Kb) · AltEnter.xlsx(12.0 Kb)
 
Ответить
СообщениеДоброго времени суток форумчане и гости форума.
В файл из программы выгрузили данные видимо разделённые в ячейке на "уровни" Alt+Enter.
Подскажите, как (если это возможно) произвести вычисления только с цифрами в первом ряду.

Автор - DrMini
Дата добавления - 23.11.2022 в 10:24
_Boroda_ Дата: Среда, 23.11.2022, 10:28 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16510
Репутация: 6426 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=СУММПРОИЗВ(ЛЕВБ(A2:C2;ПОИСК(СИМВОЛ(10);A2:C2)-1)*{1;1;-1})

Код
=СУММПРОИЗВ(ЗАМЕНИТЬ(A2:C2;ПОИСК(СИМВОЛ(10);A2:C2);999;)*{1;1;-1})


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(ЛЕВБ(A2:C2;ПОИСК(СИМВОЛ(10);A2:C2)-1)*{1;1;-1})

Код
=СУММПРОИЗВ(ЗАМЕНИТЬ(A2:C2;ПОИСК(СИМВОЛ(10);A2:C2);999;)*{1;1;-1})

Автор - _Boroda_
Дата добавления - 23.11.2022 в 10:28
DrMini Дата: Среда, 23.11.2022, 10:49 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 886
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
_Александр_, огромное спасибо.
Под свой файл сделал. Работает.
Позже посмотрю и вторую формулу. Но у верен, что и с ней проблем не будет.
 
Ответить
Сообщение_Александр_, огромное спасибо.
Под свой файл сделал. Работает.
Позже посмотрю и вторую формулу. Но у верен, что и с ней проблем не будет.

Автор - DrMini
Дата добавления - 23.11.2022 в 10:49
DrMini Дата: Среда, 23.11.2022, 11:05 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 886
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
СИМВОЛ(10);A2:C2);999;)*{1;1;-1})

Подскажите пожалуйста — вот этот кусок в формуле не понял на что влияет число 999:
Код
;999;

отвечает за количество просматриваемых символов?
 
Ответить
Сообщение
СИМВОЛ(10);A2:C2);999;)*{1;1;-1})

Подскажите пожалуйста — вот этот кусок в формуле не понял на что влияет число 999:
Код
;999;

отвечает за количество просматриваемых символов?

Автор - DrMini
Дата добавления - 23.11.2022 в 11:05
_Boroda_ Дата: Среда, 23.11.2022, 11:18 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16510
Репутация: 6426 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
ПОИСК(СИМВОЛ(10) находит номер позиции первого переноса и от него с помощью ЗАМЕНИТЬ меняем 999 символов на ничего. Остается все то, что до первого переноса


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПОИСК(СИМВОЛ(10) находит номер позиции первого переноса и от него с помощью ЗАМЕНИТЬ меняем 999 символов на ничего. Остается все то, что до первого переноса

Автор - _Boroda_
Дата добавления - 23.11.2022 в 11:18
DrMini Дата: Среда, 23.11.2022, 11:28 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 886
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
меняем 999 символов на ничего

Спасибо. Понял.
[p.s.]формула работает[/p.s.]
 
Ответить
Сообщение
меняем 999 символов на ничего

Спасибо. Понял.
[p.s.]формула работает[/p.s.]

Автор - DrMini
Дата добавления - 23.11.2022 в 11:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт верхних цифр в ячейке до Alt+Enter (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!