Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/СУММПРОИЗВ с расширенным диапазоном суммирования - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММПРОИЗВ с расширенным диапазоном суммирования (Формулы/Formulas)
СУММПРОИЗВ с расширенным диапазоном суммирования
Anis625 Дата: Среда, 23.11.2022, 23:08 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 653
Репутация: 30 ±
Замечаний: 0% ±

Excel 2013
Добрый вечер, всем участникам форума!
Прошу оказать содействие докрутить одну формулу или направить в нужном направлении. Своих знаний не хватает.
Пытаюсь расширить диапазон выполнения функции СУММПРОИЗВ, но не получается вкрутить суммирование массива. Более подробно описал в файле с ручным результатом расчета. Буду признателен за любой совет/помощь.
К сообщению приложен файл: 7491551.xlsx(12.2 Kb)


Сообщение отредактировал Anis625 - Среда, 23.11.2022, 23:09
 
Ответить
СообщениеДобрый вечер, всем участникам форума!
Прошу оказать содействие докрутить одну формулу или направить в нужном направлении. Своих знаний не хватает.
Пытаюсь расширить диапазон выполнения функции СУММПРОИЗВ, но не получается вкрутить суммирование массива. Более подробно описал в файле с ручным результатом расчета. Буду признателен за любой совет/помощь.

Автор - Anis625
Дата добавления - 23.11.2022 в 23:08
ShAM Дата: Четверг, 24.11.2022, 08:13 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1343
Репутация: 249 ±
Замечаний: 0% ±

Excel 2010
Может так:
Код
=СУММПРОИЗВ(ИНДЕКС($D$8:$V$15;ПОИСКПОЗ($A3;$A$8:$A$15;0);)*($A$19:$A$23=B3)*($D$19:$V$23))
 
Ответить
СообщениеМожет так:
Код
=СУММПРОИЗВ(ИНДЕКС($D$8:$V$15;ПОИСКПОЗ($A3;$A$8:$A$15;0);)*($A$19:$A$23=B3)*($D$19:$V$23))

Автор - ShAM
Дата добавления - 24.11.2022 в 08:13
Nic70y Дата: Четверг, 24.11.2022, 08:13 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 7875
Репутация: 1894 ±
Замечаний: 0% ±

Excel 2010
Anis625, вся проблема в том, что 31 ноября не бывает :(
если правильно понял
Код
=СУММ(ИНДЕКС(D$8:M$15;МИН(ЕСЛИ((A$8:A$15=A2)*(B$8:B$15<=B2)*(C$8:C$15>=B2);СТРОКА(A$8:A$15)))-7;)*ИНДЕКС(D$19:M$23;ПОИСКПОЗ(B2;A$19:A$23;);))
массивная
К сообщению приложен файл: 17.xlsx(12.3 Kb)


ЮMoney 41001841029809
 
Ответить
СообщениеAnis625, вся проблема в том, что 31 ноября не бывает :(
если правильно понял
Код
=СУММ(ИНДЕКС(D$8:M$15;МИН(ЕСЛИ((A$8:A$15=A2)*(B$8:B$15<=B2)*(C$8:C$15>=B2);СТРОКА(A$8:A$15)))-7;)*ИНДЕКС(D$19:M$23;ПОИСКПОЗ(B2;A$19:A$23;);))
массивная

Автор - Nic70y
Дата добавления - 24.11.2022 в 08:13
Anis625 Дата: Четверг, 24.11.2022, 11:08 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 653
Репутация: 30 ±
Замечаний: 0% ±

Excel 2013
ShAM, Ваш вариант почти правильно отработал. Почти - потому что для одной даты он правильно посчитал, а для другой ровно уполовинил (файл приложил)

Nic70y, с 31 ноября косяк =) но увы с 30 ноября тоже не работает. Ваш подход считает только по первому вхождению даты, т.е. не суммирует несколько строк
К сообщению приложен файл: 9143135.xlsx(12.5 Kb)


Сообщение отредактировал Anis625 - Четверг, 24.11.2022, 11:08
 
Ответить
СообщениеShAM, Ваш вариант почти правильно отработал. Почти - потому что для одной даты он правильно посчитал, а для другой ровно уполовинил (файл приложил)

Nic70y, с 31 ноября косяк =) но увы с 30 ноября тоже не работает. Ваш подход считает только по первому вхождению даты, т.е. не суммирует несколько строк

Автор - Anis625
Дата добавления - 24.11.2022 в 11:08
Anis625 Дата: Четверг, 24.11.2022, 11:14 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 653
Репутация: 30 ±
Замечаний: 0% ±

Excel 2013
ShAM, sorry ваш вариант правильно считает, он взял первую строку верхней таблицы, попробую по вашему подходу учесть фактор дат (период действия из диапазона B8:C8), чтобы взял ниже строку в диапазоне дат декабря. Спасибо Вам огромное за предложенное решение


Сообщение отредактировал Anis625 - Четверг, 24.11.2022, 11:14
 
Ответить
СообщениеShAM, sorry ваш вариант правильно считает, он взял первую строку верхней таблицы, попробую по вашему подходу учесть фактор дат (период действия из диапазона B8:C8), чтобы взял ниже строку в диапазоне дат декабря. Спасибо Вам огромное за предложенное решение

Автор - Anis625
Дата добавления - 24.11.2022 в 11:14
Anis625 Дата: Четверг, 24.11.2022, 11:27 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 653
Репутация: 30 ±
Замечаний: 0% ±

Excel 2013
ShAM, допилил с учетом диапазона дат действия конкретного ингредиента Спасибо ВАМ ОГРОМНОЕ. Возможности СУММПРОИЗВ расширились в моих знаниях.
Код
=СУММПРОИЗВ(ИНДЕКС(D9:V16;ПОИСКПОЗ(1;(B6>=B9:B16)*(B6<=C9:C16)*(A6=A9:A16);0);)*($A$20:$A$24=B6)*($D$20:$V$24))
К сообщению приложен файл: 6685093.xlsx(12.3 Kb)


Сообщение отредактировал Anis625 - Четверг, 24.11.2022, 11:27
 
Ответить
СообщениеShAM, допилил с учетом диапазона дат действия конкретного ингредиента Спасибо ВАМ ОГРОМНОЕ. Возможности СУММПРОИЗВ расширились в моих знаниях.
Код
=СУММПРОИЗВ(ИНДЕКС(D9:V16;ПОИСКПОЗ(1;(B6>=B9:B16)*(B6<=C9:C16)*(A6=A9:A16);0);)*($A$20:$A$24=B6)*($D$20:$V$24))

Автор - Anis625
Дата добавления - 24.11.2022 в 11:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММПРОИЗВ с расширенным диапазоном суммирования (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!