Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет цены на товар по 3м условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет цены на товар по 3м условиям (Формулы/Formulas)
Расчет цены на товар по 3м условиям
Слоник Дата: Пятница, 02.12.2022, 21:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер!
Подскажите, пожалуйста. Нужно рассчитать цену на товар от определенного поставщика не выше, чем у конкурента, но и не ниже определенной наценки.
т.е. если в столбце В указан "Поставщик1", и значение в столбце D выше, чем в столбцах E или F, то нужно в столбец G подставить такое значение, чтобы оно было не выше, чем в E или F, но и не ниже, чем С*1,1.
Если в столбце В указаны Поставщик2 или Поставщик3, то цена в прайс будет С4 (к примеру)*1,3 без всяких условий.
Нужна общая формула протянуть по всей таблице.
Если нужно добавить какие-то столбцы для расчета - это не критично.
К сообщению приложен файл: 2772718.xls(26.0 Kb)


Сообщение отредактировал Слоник - Пятница, 02.12.2022, 21:47
 
Ответить
СообщениеДобрый вечер!
Подскажите, пожалуйста. Нужно рассчитать цену на товар от определенного поставщика не выше, чем у конкурента, но и не ниже определенной наценки.
т.е. если в столбце В указан "Поставщик1", и значение в столбце D выше, чем в столбцах E или F, то нужно в столбец G подставить такое значение, чтобы оно было не выше, чем в E или F, но и не ниже, чем С*1,1.
Если в столбце В указаны Поставщик2 или Поставщик3, то цена в прайс будет С4 (к примеру)*1,3 без всяких условий.
Нужна общая формула протянуть по всей таблице.
Если нужно добавить какие-то столбцы для расчета - это не критично.

Автор - Слоник
Дата добавления - 02.12.2022 в 21:27
gling Дата: Суббота, 03.12.2022, 14:39 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2435
Репутация: 644 ±
Замечаний: 0% ±

2010
Здравствуйте.
Так?
Код
=ЕСЛИ(B3="Поставщик1";ЕСЛИ(C3>МИН(E3:F3);C3*1,1;МИН(E3:F3));C3*1,3)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
Так?
Код
=ЕСЛИ(B3="Поставщик1";ЕСЛИ(C3>МИН(E3:F3);C3*1,1;МИН(E3:F3));C3*1,3)

Автор - gling
Дата добавления - 03.12.2022 в 14:39
Слоник Дата: Воскресенье, 04.12.2022, 15:57 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

gling, Да, все работает, спасибо))
 
Ответить
Сообщениеgling, Да, все работает, спасибо))

Автор - Слоник
Дата добавления - 04.12.2022 в 15:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет цены на товар по 3м условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!