Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск данных с исключением - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск данных с исключением (Формулы/Formulas)
Поиск данных с исключением
AndreySanich Дата: Вторник, 13.12.2022, 15:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.
Просмотрел похожие темы - не смог сам сделать.

Задумка такая: на листе РАСЧЕТЫ Район берется из листа ОСНОВНОЕ. Но есть определенные договоры, которые на листе ИСКЛ - у них район должен быть "личный".
Надо чтобы была проверка: если договор из ИСКЛ (их будет много) - то район берется оттуда, если там нет такого договора - то район берется из ОСНОВНОЕ (так как он считается сейчас) %)
Надеюсь объяснил что хочу получить :D

Офис 2019
К сообщению приложен файл: 3470127.xlsx(13.0 Kb)


Сообщение отредактировал AndreySanich - Вторник, 13.12.2022, 15:24
 
Ответить
СообщениеДобрый день.
Просмотрел похожие темы - не смог сам сделать.

Задумка такая: на листе РАСЧЕТЫ Район берется из листа ОСНОВНОЕ. Но есть определенные договоры, которые на листе ИСКЛ - у них район должен быть "личный".
Надо чтобы была проверка: если договор из ИСКЛ (их будет много) - то район берется оттуда, если там нет такого договора - то район берется из ОСНОВНОЕ (так как он считается сейчас) %)
Надеюсь объяснил что хочу получить :D

Офис 2019

Автор - AndreySanich
Дата добавления - 13.12.2022 в 15:22
Nic70y Дата: Вторник, 13.12.2022, 15:55 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8005
Репутация: 1949 ±
Замечаний: 0% ±

Excel 2010
вдруг правильно
Код
=ЕСЛИОШИБКА(ВПР(C2;искл!A:B;2;);ВПР(B2;основное!A:B;2;0))
К сообщению приложен файл: 25.xlsx(12.5 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениевдруг правильно
Код
=ЕСЛИОШИБКА(ВПР(C2;искл!A:B;2;);ВПР(B2;основное!A:B;2;0))

Автор - Nic70y
Дата добавления - 13.12.2022 в 15:55
AndreySanich Дата: Среда, 14.12.2022, 07:42 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, спасибо.
Так просто.
А я полез в дебри массивов :'( %)
 
Ответить
СообщениеNic70y, спасибо.
Так просто.
А я полез в дебри массивов :'( %)

Автор - AndreySanich
Дата добавления - 14.12.2022 в 07:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск данных с исключением (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!