Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подставление информации по заданным данным - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставление информации по заданным данным (Формулы/Formulas)
Подставление информации по заданным данным
malish6062233 Дата: Вторник, 13.12.2022, 23:29 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Всем привет! Великие умы, нужна ваша помощь!!!
Если исходные данные характеристики по товару, необходимо вывести данные в отдельный лист по заданным артикулам.
Необходимо что бы во вкладке "печать" отображались данные по товару тех артикулов, которые будут введены во вкладке "Список для печати" (список может быть как из одного артикула, так и из 20), нужно что вы во вкладке "Печать" подтягивались только заданные артикула, в ячейки подряд заполняя лист, из вкладки "Свод"

p.s. Готов отблагодарить
К сообщению приложен файл: 1835282.xlsx(31.9 Kb)


Сообщение отредактировал malish6062233 - Вторник, 13.12.2022, 23:48
 
Ответить
СообщениеВсем привет! Великие умы, нужна ваша помощь!!!
Если исходные данные характеристики по товару, необходимо вывести данные в отдельный лист по заданным артикулам.
Необходимо что бы во вкладке "печать" отображались данные по товару тех артикулов, которые будут введены во вкладке "Список для печати" (список может быть как из одного артикула, так и из 20), нужно что вы во вкладке "Печать" подтягивались только заданные артикула, в ячейки подряд заполняя лист, из вкладки "Свод"

p.s. Готов отблагодарить

Автор - malish6062233
Дата добавления - 13.12.2022 в 23:29
Egyptian Дата: Среда, 14.12.2022, 01:13 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 442
Репутация: 146 ±
Замечаний: 0% ±

Excel 2013/2016
Взгляните. Заполнил формулу левую и частично правую сторону для печати (стр. 1, 2 и 3). Соответственно список можно заполнять от А1 до А63. Четвертую страницу оставляю на ваше попечение. Принцип переноса формул очень простой - копируете формулу (в формульной строке), вставляете в левую начальную ячейку нужного квадрата, последовательно правите ссылки на ячейки на листе "список для печати", вводите как формлу массива через CTRL+SHIFT_ENTER и в пределах квадрата тянете вправо и вниз. Все.
К сообщению приложен файл: 1222902.xlsx(50.7 Kb)


Сообщение отредактировал Egyptian - Среда, 14.12.2022, 01:41
 
Ответить
СообщениеВзгляните. Заполнил формулу левую и частично правую сторону для печати (стр. 1, 2 и 3). Соответственно список можно заполнять от А1 до А63. Четвертую страницу оставляю на ваше попечение. Принцип переноса формул очень простой - копируете формулу (в формульной строке), вставляете в левую начальную ячейку нужного квадрата, последовательно правите ссылки на ячейки на листе "список для печати", вводите как формлу массива через CTRL+SHIFT_ENTER и в пределах квадрата тянете вправо и вниз. Все.

Автор - Egyptian
Дата добавления - 14.12.2022 в 01:13
malish6062233 Дата: Пятница, 23.12.2022, 01:28 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Egyptian, Нашел в формуле небольшие огрехи - был сдвиг по ячейкам и не считывало первые две колонки, малость подправил формулу

Код
{=ЕСЛИ('Список для печати'!$A$1<>"";ИНДЕКС(Свод!A$1:L$500;НАИМЕНЬШИЙ(ЕСЛИ(Свод!$B$1:$L$500='Список для печати'!$A$1;СТРОКА(Свод!$A$1:$A$500));1)+СТРОКА(A1)-1;НАИМЕНЬШИЙ(ЕСЛИ(Свод!$B$1:$L$500='Список для печати'!$A$1;СТОЛБЕЦ(Свод!$B$1:$L$1)-СТОЛБЕЦ(Свод!$A$1)-1);1)+1);"")}


Вроде заработало, но если не трудно - глянь пожалуйста
К сообщению приложен файл: 0528430.xlsx(60.3 Kb)


Сообщение отредактировал malish6062233 - Пятница, 23.12.2022, 20:47
 
Ответить
СообщениеEgyptian, Нашел в формуле небольшие огрехи - был сдвиг по ячейкам и не считывало первые две колонки, малость подправил формулу

Код
{=ЕСЛИ('Список для печати'!$A$1<>"";ИНДЕКС(Свод!A$1:L$500;НАИМЕНЬШИЙ(ЕСЛИ(Свод!$B$1:$L$500='Список для печати'!$A$1;СТРОКА(Свод!$A$1:$A$500));1)+СТРОКА(A1)-1;НАИМЕНЬШИЙ(ЕСЛИ(Свод!$B$1:$L$500='Список для печати'!$A$1;СТОЛБЕЦ(Свод!$B$1:$L$1)-СТОЛБЕЦ(Свод!$A$1)-1);1)+1);"")}


Вроде заработало, но если не трудно - глянь пожалуйста

Автор - malish6062233
Дата добавления - 23.12.2022 в 01:28
китин Дата: Пятница, 23.12.2022, 07:36 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 6941
Репутация: 1059 ±
Замечаний: 0% ±

Excel 2007;2010;2016
malish6062233, оформите формулу тэгами, согласно Правил форума


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениеmalish6062233, оформите формулу тэгами, согласно Правил форума

Автор - китин
Дата добавления - 23.12.2022 в 07:36
malish6062233 Дата: Четверг, 12.01.2023, 18:54 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Egyptian, приветствую Вас - взгляните пожалуйста на исправленную Вашу формулу - может есть какие-то ошибки? Сообщение чуть выше
 
Ответить
СообщениеEgyptian, приветствую Вас - взгляните пожалуйста на исправленную Вашу формулу - может есть какие-то ошибки? Сообщение чуть выше

Автор - malish6062233
Дата добавления - 12.01.2023 в 18:54
Egyptian Дата: Пятница, 13.01.2023, 01:05 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 442
Репутация: 146 ±
Замечаний: 0% ±

Excel 2013/2016
malish6062233, Да, особенно не вникал, но вроде все ок. Там лишь копипаст надо делать и все.
 
Ответить
Сообщениеmalish6062233, Да, особенно не вникал, но вроде все ок. Там лишь копипаст надо делать и все.

Автор - Egyptian
Дата добавления - 13.01.2023 в 01:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставление информации по заданным данным (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!