Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Кратность остатков - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Кратность остатков (Формулы/Formulas)
Кратность остатков
kilundik Дата: Пятница, 16.12.2022, 15:22 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Всем привет

Проблема такая.

Исходящий остаток от поставщика 9 штук, кратность продажи этого товара 5 штук, то есть мы не можем продавать 4 штуки, а остаток 9.
Нужно чтобы если остаток 9, а кратность 5, то остаток был 5
Или, остаток 14, кратность 5, то остаток должен быть 10
Или, остаток 10, кратность 3, остаток должен быть 9

Прилагаю листик с формулой которую сейчас используем
Код
=ЕСЛИ(B2<C2;0;B2)
, но, эта формула только скрывает в 0, если на остатке товара меньше кратности, а вот как сделать чтобы получить результат, который описан выше?
К сообщению приложен файл: 5652813.xlsx(8.8 Kb)
 
Ответить
СообщениеВсем привет

Проблема такая.

Исходящий остаток от поставщика 9 штук, кратность продажи этого товара 5 штук, то есть мы не можем продавать 4 штуки, а остаток 9.
Нужно чтобы если остаток 9, а кратность 5, то остаток был 5
Или, остаток 14, кратность 5, то остаток должен быть 10
Или, остаток 10, кратность 3, остаток должен быть 9

Прилагаю листик с формулой которую сейчас используем
Код
=ЕСЛИ(B2<C2;0;B2)
, но, эта формула только скрывает в 0, если на остатке товара меньше кратности, а вот как сделать чтобы получить результат, который описан выше?

Автор - kilundik
Дата добавления - 16.12.2022 в 15:22
Паштет Дата: Пятница, 16.12.2022, 15:36 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 147
Репутация: 5 ±
Замечаний: 0% ±

Excel 2010
Попробуйте так:
Код
=ОКРУГЛВНИЗ(B2/C2;0)*C2


Сообщение отредактировал Паштет - Пятница, 16.12.2022, 15:58
 
Ответить
СообщениеПопробуйте так:
Код
=ОКРУГЛВНИЗ(B2/C2;0)*C2

Автор - Паштет
Дата добавления - 16.12.2022 в 15:36
китин Дата: Пятница, 16.12.2022, 15:38 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6941
Репутация: 1059 ±
Замечаний: 0% ±

Excel 2007;2010;2016
Код
=ЦЕЛОЕ(B2/C2)*C2

может правильно?


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщение
Код
=ЦЕЛОЕ(B2/C2)*C2

может правильно?

Автор - китин
Дата добавления - 16.12.2022 в 15:38
DrMini Дата: Пятница, 16.12.2022, 15:54 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 912
Репутация: 79 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
=ОКРУГЛВНИЗ(B2/C2;0)*B2

Паштет, Вы чуть ошиблись.
Наверное так надо:
Код
=ОКРУГЛВНИЗ(B2/C2;0)*C2
 
Ответить
Сообщение
=ОКРУГЛВНИЗ(B2/C2;0)*B2

Паштет, Вы чуть ошиблись.
Наверное так надо:
Код
=ОКРУГЛВНИЗ(B2/C2;0)*C2

Автор - DrMini
Дата добавления - 16.12.2022 в 15:54
Паштет Дата: Пятница, 16.12.2022, 15:57 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 147
Репутация: 5 ±
Замечаний: 0% ±

Excel 2010
=ОКРУГЛВНИЗ(B2/C2;0)*C2
Да, ошибся, писал из головы. Спасибо
 
Ответить
Сообщение
=ОКРУГЛВНИЗ(B2/C2;0)*C2
Да, ошибся, писал из головы. Спасибо

Автор - Паштет
Дата добавления - 16.12.2022 в 15:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Кратность остатков (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!