Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выпадающий зависимый список со строчными данными - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выпадающий зависимый список со строчными данными (Формулы/Formulas)
Выпадающий зависимый список со строчными данными
albertikhsanov00 Дата: Среда, 21.12.2022, 19:58 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 20% ±

Здравствуйте, помогите с решением, как сделать зависимый выпадающий список у которого данные записаны ГОРИЗОНТАЛЬНО, знаю как делать с данными по столбцу, но нужно сделать именно по строчно и чтобы было несколько выпадающих списков. Файл для примера прикладываю. Заранее спасибо!!!
К сообщению приложен файл: 6308954.xlsx(9.8 Kb)
 
Ответить
СообщениеЗдравствуйте, помогите с решением, как сделать зависимый выпадающий список у которого данные записаны ГОРИЗОНТАЛЬНО, знаю как делать с данными по столбцу, но нужно сделать именно по строчно и чтобы было несколько выпадающих списков. Файл для примера прикладываю. Заранее спасибо!!!

Автор - albertikhsanov00
Дата добавления - 21.12.2022 в 19:58
gling Дата: Среда, 21.12.2022, 20:20 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2435
Репутация: 644 ±
Замечаний: 0% ±

2010
По простому можно как в файле, в проверку данных вставить формулу
Код
=ИНДЕКС($B$1:$F$4;ПОИСКПОЗ($H1;Список1;);)
А если убирать пустые строки в выпадающем списке, то нужно чуток заморочиться.
К сообщению приложен файл: 6675083.xlsx(9.6 Kb)


ЯД-41001506838083
 
Ответить
СообщениеПо простому можно как в файле, в проверку данных вставить формулу
Код
=ИНДЕКС($B$1:$F$4;ПОИСКПОЗ($H1;Список1;);)
А если убирать пустые строки в выпадающем списке, то нужно чуток заморочиться.

Автор - gling
Дата добавления - 21.12.2022 в 20:20
albertikhsanov00 Дата: Четверг, 22.12.2022, 07:11 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 20% ±

Спасибо, все работает, но как убрать пустые строки? Так как для моей задачи слишком много пустых строк
 
Ответить
СообщениеСпасибо, все работает, но как убрать пустые строки? Так как для моей задачи слишком много пустых строк

Автор - albertikhsanov00
Дата добавления - 22.12.2022 в 07:11
Gustav Дата: Четверг, 22.12.2022, 14:45 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2303
Репутация: 918 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Цитата albertikhsanov00, 22.12.2022 в 07:11, в сообщении № 3 ()
как убрать пустые строки?
Например, вот так (формула для поля "Источник" диалога "Проверка данных"):
Код
=ИНДЕКС(СМЕЩ($B$1:$F$4;;;;СЧЁТЗ(ИНДЕКС($B$1:$F$4; ПОИСКПОЗ($H1;Список1;);))); ПОИСКПОЗ($H1;Список1;);)
К сообщению приложен файл: NoEmpty.xlsx(9.7 Kb)


МОИ: Ник, Tip box: 41001663842605
 
Ответить
Сообщение
Цитата albertikhsanov00, 22.12.2022 в 07:11, в сообщении № 3 ()
как убрать пустые строки?
Например, вот так (формула для поля "Источник" диалога "Проверка данных"):
Код
=ИНДЕКС(СМЕЩ($B$1:$F$4;;;;СЧЁТЗ(ИНДЕКС($B$1:$F$4; ПОИСКПОЗ($H1;Список1;);))); ПОИСКПОЗ($H1;Список1;);)

Автор - Gustav
Дата добавления - 22.12.2022 в 14:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выпадающий зависимый список со строчными данными (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!