Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ИНДЕКС+ПОИСКПОЗ не до конца видимо разобрался - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ИНДЕКС+ПОИСКПОЗ не до конца видимо разобрался (Формулы/Formulas)
ИНДЕКС+ПОИСКПОЗ не до конца видимо разобрался
elovkov Дата: Четверг, 22.12.2022, 11:04 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 2 ±
Замечаний: 0% ±

Добрый день

Есть значения диаметров и для них коэффициент
Есть искомый диаметр, надо найти для него коэффициент по типовым диаметрам для минимального данного диаметра превышающего искомый
Что я не так сделал?
К сообщению приложен файл: 112233.xlsx(10.0 Kb)
 
Ответить
СообщениеДобрый день

Есть значения диаметров и для них коэффициент
Есть искомый диаметр, надо найти для него коэффициент по типовым диаметрам для минимального данного диаметра превышающего искомый
Что я не так сделал?

Автор - elovkov
Дата добавления - 22.12.2022 в 11:04
Serge_007 Дата: Четверг, 22.12.2022, 11:18 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15647
Репутация: 2575 ±
Замечаний: ±

Excel 2016
Здравствуйте

Код
=ВПР(C3;{0;3:300;4:400;5:500;6:600;7:800;8};2)


Что я не так сделал?
Не указали индекс для диапазона 0-300
К сообщению приложен файл: 20221222_elovko.xls(31.0 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ВПР(C3;{0;3:300;4:400;5:500;6:600;7:800;8};2)


Что я не так сделал?
Не указали индекс для диапазона 0-300

Автор - Serge_007
Дата добавления - 22.12.2022 в 11:18
elovkov Дата: Четверг, 22.12.2022, 11:25 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 2 ±
Замечаний: 0% ±

Не указали индекс для диапазона 0-300
Код
ПОИСКПОЗ(C3;H2:H7;-1)
тут "-1" вроде ищет "наименьшее значение превышающее искомое или равное ему"

3:300;4:400;5:500;6:600;7:800
таблица как пример, значений может быть намного больше, все не пропишешь


Сообщение отредактировал Serge_007 - Четверг, 22.12.2022, 11:36
 
Ответить
Сообщение
Не указали индекс для диапазона 0-300
Код
ПОИСКПОЗ(C3;H2:H7;-1)
тут "-1" вроде ищет "наименьшее значение превышающее искомое или равное ему"

3:300;4:400;5:500;6:600;7:800
таблица как пример, значений может быть намного больше, все не пропишешь

Автор - elovkov
Дата добавления - 22.12.2022 в 11:25
NikitaDvorets Дата: Четверг, 22.12.2022, 11:27 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 399
Репутация: 81 ±
Замечаний: 0% ±

Excel 2019
elovkov, добрый день.

Аналог
Код
=ВПР(C3;{0;3:300;4:400;5:500;6:600;7:800;8};2)

в приложении.
К сообщению приложен файл: ___22-12-2022.xlsx(12.4 Kb)
 
Ответить
Сообщениеelovkov, добрый день.

Аналог
Код
=ВПР(C3;{0;3:300;4:400;5:500;6:600;7:800;8};2)

в приложении.

Автор - NikitaDvorets
Дата добавления - 22.12.2022 в 11:27
Serge_007 Дата: Четверг, 22.12.2022, 11:34 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 15647
Репутация: 2575 ±
Замечаний: ±

Excel 2016
"-1" вроде ищет "наименьшее значение превышающее искомое или равное ему"
Да, но при этом массив должен быть упорядочен по убыванию
У Вас не так - массив упорядочен по возрастанию, значит надо применять не "-1", а "1" (или пусто)

таблица как пример
Формула тоже как пример

значений может быть намного больше, все не пропишешь
Придется прописать, иначе как Вы считать собираетесь?
Либо в таблице надо будет прописывать, либо в формуле
Принципиальной разницы для расчета нет


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
"-1" вроде ищет "наименьшее значение превышающее искомое или равное ему"
Да, но при этом массив должен быть упорядочен по убыванию
У Вас не так - массив упорядочен по возрастанию, значит надо применять не "-1", а "1" (или пусто)

таблица как пример
Формула тоже как пример

значений может быть намного больше, все не пропишешь
Придется прописать, иначе как Вы считать собираетесь?
Либо в таблице надо будет прописывать, либо в формуле
Принципиальной разницы для расчета нет

Автор - Serge_007
Дата добавления - 22.12.2022 в 11:34
elovkov Дата: Четверг, 22.12.2022, 11:39 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 2 ±
Замечаний: 0% ±

массив должен быть упорядочен по убыванию

ВОТ!!! Это все решило))) Я понял, спасибо

Цитата NikitaDvorets, 22.12.2022 в 11:27, в сообщении № 4 ()
в приложении.

Спасибо, тоже пригодится
 
Ответить
Сообщение
массив должен быть упорядочен по убыванию

ВОТ!!! Это все решило))) Я понял, спасибо

Цитата NikitaDvorets, 22.12.2022 в 11:27, в сообщении № 4 ()
в приложении.

Спасибо, тоже пригодится

Автор - elovkov
Дата добавления - 22.12.2022 в 11:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ИНДЕКС+ПОИСКПОЗ не до конца видимо разобрался (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!