Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Несколько условий ЕСЛИ(И( для одной ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Несколько условий ЕСЛИ(И( для одной ячейки (Формулы/Formulas)
Несколько условий ЕСЛИ(И( для одной ячейки
checkerroad Дата: Суббота, 24.12.2022, 12:52 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2013
Доброго времени.
Подскажите, как вбросить в ячейку несколько условий ЕСЛИ И. По разным другим решениям всё есть в сети, а по этому вопросу как-то не нашел...
Спасибо.
К сообщению приложен файл: 4017751.xlsx(10.5 Kb)
 
Ответить
СообщениеДоброго времени.
Подскажите, как вбросить в ячейку несколько условий ЕСЛИ И. По разным другим решениям всё есть в сети, а по этому вопросу как-то не нашел...
Спасибо.

Автор - checkerroad
Дата добавления - 24.12.2022 в 12:52
Nic70y Дата: Суббота, 24.12.2022, 13:11 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8005
Репутация: 1949 ±
Замечаний: 0% ±

Excel 2010
вдруг правильно
Код
=СИМВОЛ(B3+64)&ВПР(C3;{1;"05":6;510:11;1015:16;1520:21;2023};2)
К сообщению приложен файл: 700.xlsx(10.6 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениевдруг правильно
Код
=СИМВОЛ(B3+64)&ВПР(C3;{1;"05":6;510:11;1015:16;1520:21;2023};2)

Автор - Nic70y
Дата добавления - 24.12.2022 в 13:11
gling Дата: Суббота, 24.12.2022, 13:14 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2435
Репутация: 644 ±
Замечаний: 0% ±

2010
Здравствуйте.
Попробуйте вариант
Код
=ЕСЛИ(B4=1;ПРОСМОТР(C4;{0;5;10;15;20;23};{"А05":"А510":"А1015":"А1520":"А2023"});ПРОСМОТР(C4;{0;5;10;15;20;23};{"В05":"В510":"В1015":"В1520":"В2023"}))


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
Попробуйте вариант
Код
=ЕСЛИ(B4=1;ПРОСМОТР(C4;{0;5;10;15;20;23};{"А05":"А510":"А1015":"А1520":"А2023"});ПРОСМОТР(C4;{0;5;10;15;20;23};{"В05":"В510":"В1015":"В1520":"В2023"}))

Автор - gling
Дата добавления - 24.12.2022 в 13:14
bigorq Дата: Суббота, 24.12.2022, 13:18 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 155
Репутация: 31 ±
Замечаний: 0% ±

Нет
Доброго.
Ну если искали как объясняете, то не удивительно, что ничего не нашли :)
 
Ответить
СообщениеДоброго.
Ну если искали как объясняете, то не удивительно, что ничего не нашли :)

Автор - bigorq
Дата добавления - 24.12.2022 в 13:18
checkerroad Дата: Суббота, 24.12.2022, 14:06 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2013
Nic70y, gling, Спасибо. Все заиграло )
Где почитать про эти вычисления?
 
Ответить
СообщениеNic70y, gling, Спасибо. Все заиграло )
Где почитать про эти вычисления?

Автор - checkerroad
Дата добавления - 24.12.2022 в 14:06
checkerroad Дата: Суббота, 24.12.2022, 18:27 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2013
Форумчане, я опять за помощью... Ну ни как не могу толку дать с несколькими условиями в одной ячейке. Направьте на путь истинный.
Спасибо.
К сообщению приложен файл: 5774665.xlsx(12.8 Kb)
 
Ответить
СообщениеФорумчане, я опять за помощью... Ну ни как не могу толку дать с несколькими условиями в одной ячейке. Направьте на путь истинный.
Спасибо.

Автор - checkerroad
Дата добавления - 24.12.2022 в 18:27
Gustav Дата: Суббота, 24.12.2022, 19:20 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2303
Репутация: 918 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Ну, так, наверное (формула для E18):
Код
=ИНДЕКС($I$18:$R$29; ПОИСКПОЗ(A18;$H$18:$H$29;0); ПОИСКПОЗ(D18;$I$13:$R$13;0))


МОИ: Ник, Tip box: 41001663842605
 
Ответить
СообщениеНу, так, наверное (формула для E18):
Код
=ИНДЕКС($I$18:$R$29; ПОИСКПОЗ(A18;$H$18:$H$29;0); ПОИСКПОЗ(D18;$I$13:$R$13;0))

Автор - Gustav
Дата добавления - 24.12.2022 в 19:20
checkerroad Дата: Суббота, 24.12.2022, 19:29 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2013
Ну, так, наверное (формула для E18):

Да Gustav, всё верно и всё гораздо проще чем я себе рисовал. Еще вопрос... Можно для некоторой оптимизации, условия А05, А510 и т.д. те что вверху убрать во внутрь формулы?
Спасибо.
 
Ответить
Сообщение
Ну, так, наверное (формула для E18):

Да Gustav, всё верно и всё гораздо проще чем я себе рисовал. Еще вопрос... Можно для некоторой оптимизации, условия А05, А510 и т.д. те что вверху убрать во внутрь формулы?
Спасибо.

Автор - checkerroad
Дата добавления - 24.12.2022 в 19:29
Gustav Дата: Суббота, 24.12.2022, 22:14 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2303
Репутация: 918 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
условия А05, А510 и т.д. те что вверху убрать во внутрь формулы

Можно. Для этого заходим в формулу в режиме редактирования (по F2), выделяем второй параметр второго ПОИСКПОЗ, т.е. адрес диапазона $I$13:$R$13, жмём F9 и затем Enter:
Код
=ИНДЕКС($I$18:$R$29; ПОИСКПОЗ(A18;$H$18:$H$29;0); ПОИСКПОЗ(D18;{"А05";"А510";"А1015";"А1520";"А2023";"В05";"В510";"В1015";"В1520";"В2023"};0))


МОИ: Ник, Tip box: 41001663842605
 
Ответить
Сообщение
условия А05, А510 и т.д. те что вверху убрать во внутрь формулы

Можно. Для этого заходим в формулу в режиме редактирования (по F2), выделяем второй параметр второго ПОИСКПОЗ, т.е. адрес диапазона $I$13:$R$13, жмём F9 и затем Enter:
Код
=ИНДЕКС($I$18:$R$29; ПОИСКПОЗ(A18;$H$18:$H$29;0); ПОИСКПОЗ(D18;{"А05";"А510";"А1015";"А1520";"А2023";"В05";"В510";"В1015";"В1520";"В2023"};0))

Автор - Gustav
Дата добавления - 24.12.2022 в 22:14
checkerroad Дата: Суббота, 24.12.2022, 22:48 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2013
Можно. Для этого заходим в формулу в режиме редактирования (по F2)

Спасибо Gustav. Я все варианты пробовал через ЕСЛИ... Не скоро бы до такого развернутого решения добрался бы.
Посоветуйте литературу или ресурс, чтоб расти над собой ; )
Еще раз спасибо.
 
Ответить
Сообщение
Можно. Для этого заходим в формулу в режиме редактирования (по F2)

Спасибо Gustav. Я все варианты пробовал через ЕСЛИ... Не скоро бы до такого развернутого решения добрался бы.
Посоветуйте литературу или ресурс, чтоб расти над собой ; )
Еще раз спасибо.

Автор - checkerroad
Дата добавления - 24.12.2022 в 22:48
Gustav Дата: Воскресенье, 25.12.2022, 00:36 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 2303
Репутация: 918 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Посоветуйте ресурс
Вы на нём находитесь! yes

Почитайте ленту новых сообщений, хотя бы регулярно месяц-другой, просто все подряд новые топики - благо, их количество не захлестывает, чтобы захлебнуться в этом потоке. Ну, или через один, если не будете успевать. Темы самые разнообразные, но через какое-то время всё повторяется. Т.е. как газету ежедневную читайте. Через пару месяцев можно "ослабиться" - скажем, до "еженедельника" и до выбора уже только интересных, близких по духу тем, но реже не надо. Через полгодика увидите собственное возмужание.

Это всё для общего эксельного развития. Разумеется, если будет нужно "глубокое сверление" по конкретному вопросу, по поиск по Форуму никто не отменял. И далее по Гуглу тоже. До прихода на Форум (более 10 лет назад), я был (лет 15) в основном книжно-литературным одиночкой. Сейчас в моей библиотеки самые "свежие" книги - по версии 2003, всё остальное развитие происходило на Форуме практически он-лайн, среди людей, среди друзей.


МОИ: Ник, Tip box: 41001663842605
 
Ответить
Сообщение
Посоветуйте ресурс
Вы на нём находитесь! yes

Почитайте ленту новых сообщений, хотя бы регулярно месяц-другой, просто все подряд новые топики - благо, их количество не захлестывает, чтобы захлебнуться в этом потоке. Ну, или через один, если не будете успевать. Темы самые разнообразные, но через какое-то время всё повторяется. Т.е. как газету ежедневную читайте. Через пару месяцев можно "ослабиться" - скажем, до "еженедельника" и до выбора уже только интересных, близких по духу тем, но реже не надо. Через полгодика увидите собственное возмужание.

Это всё для общего эксельного развития. Разумеется, если будет нужно "глубокое сверление" по конкретному вопросу, по поиск по Форуму никто не отменял. И далее по Гуглу тоже. До прихода на Форум (более 10 лет назад), я был (лет 15) в основном книжно-литературным одиночкой. Сейчас в моей библиотеки самые "свежие" книги - по версии 2003, всё остальное развитие происходило на Форуме практически он-лайн, среди людей, среди друзей.

Автор - Gustav
Дата добавления - 25.12.2022 в 00:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Несколько условий ЕСЛИ(И( для одной ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!