Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества четных столбцов по условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества четных столбцов по условию (Формулы/Formulas)
Подсчет количества четных столбцов по условию
alexdmitry210976 Дата: Суббота, 24.12.2022, 15:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Добрый день! Помогите, пожалуйста решить проблему: есть файл, в котором в строке , в заданном интервале (А2:К2) нужно посчитать количество четных и нечетных столбцов, для которых значение в ячейке равно "Да". За ранее благодарен!!
К сообщению приложен файл: 2204407.xlsx(9.4 Kb)
 
Ответить
СообщениеДобрый день! Помогите, пожалуйста решить проблему: есть файл, в котором в строке , в заданном интервале (А2:К2) нужно посчитать количество четных и нечетных столбцов, для которых значение в ячейке равно "Да". За ранее благодарен!!

Автор - alexdmitry210976
Дата добавления - 24.12.2022 в 15:23
Egyptian Дата: Суббота, 24.12.2022, 16:18 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 442
Репутация: 146 ±
Замечаний: 0% ±

Excel 2013/2016
Вариант.
Код
=SUMPRODUCT(MOD(COLUMN($A:$K)+COLUMN(A1)-1;2)*($A$2:$K$2="Да"))

или так:
Код
=SUMPRODUCT(ISODD(COLUMN($A:$K))*($A$2:$K$2="Да"))

Код
=SUMPRODUCT(ISEVEN(COLUMN($A:$K))*($A$2:$K$2="Да"))
К сообщению приложен файл: 2158805.xlsx(9.7 Kb)


Сообщение отредактировал Egyptian - Суббота, 24.12.2022, 16:23
 
Ответить
СообщениеВариант.
Код
=SUMPRODUCT(MOD(COLUMN($A:$K)+COLUMN(A1)-1;2)*($A$2:$K$2="Да"))

или так:
Код
=SUMPRODUCT(ISODD(COLUMN($A:$K))*($A$2:$K$2="Да"))

Код
=SUMPRODUCT(ISEVEN(COLUMN($A:$K))*($A$2:$K$2="Да"))

Автор - Egyptian
Дата добавления - 24.12.2022 в 16:18
прохожий2019 Дата: Суббота, 24.12.2022, 17:03 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 980
Репутация: 271 ±
Замечаний: 0% ±

365 Beta Channel
Код
=СУММ(ОСТАТ(СТОЛБЕЦ(A2:K2);2)*(A2:K2="Да"))

Код
=СУММ(ОСТАТ(СТОЛБЕЦ(A2:K2)+1;2)*(A2:K2="Да"))
 
Ответить
Сообщение
Код
=СУММ(ОСТАТ(СТОЛБЕЦ(A2:K2);2)*(A2:K2="Да"))

Код
=СУММ(ОСТАТ(СТОЛБЕЦ(A2:K2)+1;2)*(A2:K2="Да"))

Автор - прохожий2019
Дата добавления - 24.12.2022 в 17:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества четных столбцов по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!