Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Объединение данных при совпадении - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение данных при совпадении (Формулы/Formulas)
Объединение данных при совпадении
zaspeg Дата: Среда, 28.12.2022, 09:29 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 40% ±

Добрый день. Необходимо на Лист1 сравнить столбец "Номер заказа" (самый первый столбец) со столбцом "Номер заказа" на Лист2. Если значения совпадают, то с Листа2 добавить строки на Лист1.
Спасибо.
К сообщению приложен файл: 2081065.xlsx(23.9 Kb)
 
Ответить
СообщениеДобрый день. Необходимо на Лист1 сравнить столбец "Номер заказа" (самый первый столбец) со столбцом "Номер заказа" на Лист2. Если значения совпадают, то с Листа2 добавить строки на Лист1.
Спасибо.

Автор - zaspeg
Дата добавления - 28.12.2022 в 09:29
Nic70y Дата: Среда, 28.12.2022, 09:35 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8005
Репутация: 1949 ±
Замечаний: 0% ±

Excel 2010
zaspeg, структура листов различается.
нарисуйте 3-й лист - как должно получиться.


ЮMoney 41001841029809
 
Ответить
Сообщениеzaspeg, структура листов различается.
нарисуйте 3-й лист - как должно получиться.

Автор - Nic70y
Дата добавления - 28.12.2022 в 09:35
zaspeg Дата: Среда, 28.12.2022, 09:41 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 40% ±

Сделал. На Лист1 как должно получиться.
К сообщению приложен файл: 9380276.xlsx(24.0 Kb)


Сообщение отредактировал zaspeg - Среда, 28.12.2022, 09:43
 
Ответить
СообщениеСделал. На Лист1 как должно получиться.

Автор - zaspeg
Дата добавления - 28.12.2022 в 09:41
Nic70y Дата: Среда, 28.12.2022, 09:52 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8005
Репутация: 1949 ±
Замечаний: 0% ±

Excel 2010
проверяйте
[vba]
Код
Sub u_759()
    Application.ScreenUpdating = False
    u = Cells(Rows.Count, "a").End(xlUp).Row
    For a = 2 To u
        b = Application.Match(Range("a" & a), Sheets("Лист2").Range("a:a"), 0)
        If IsNumeric(b) Then Sheets("Лист2").Range("b" & b & ":g" & b).Copy Range("l" & a)
    Next
    Application.ScreenUpdating = True
End Sub
[/vba]так надо?
К сообщению приложен файл: 2081065.xlsm(33.0 Kb)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Среда, 28.12.2022, 09:53
 
Ответить
Сообщениепроверяйте
[vba]
Код
Sub u_759()
    Application.ScreenUpdating = False
    u = Cells(Rows.Count, "a").End(xlUp).Row
    For a = 2 To u
        b = Application.Match(Range("a" & a), Sheets("Лист2").Range("a:a"), 0)
        If IsNumeric(b) Then Sheets("Лист2").Range("b" & b & ":g" & b).Copy Range("l" & a)
    Next
    Application.ScreenUpdating = True
End Sub
[/vba]так надо?

Автор - Nic70y
Дата добавления - 28.12.2022 в 09:52
_Boroda_ Дата: Среда, 28.12.2022, 09:55 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16550
Репутация: 6441 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!B$2:B$99;ПОИСКПОЗ($A2;Лист2!$A$2:$A$99;));"--")
К сообщению приложен файл: 9380276_1.xlsx(25.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!B$2:B$99;ПОИСКПОЗ($A2;Лист2!$A$2:$A$99;));"--")

Автор - _Boroda_
Дата добавления - 28.12.2022 в 09:55
zaspeg Дата: Среда, 28.12.2022, 10:00 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 40% ±

Да, результат тот что нужно. Только я теперь не понимаю как мне это самому применить к большему массиву %) :haha:
 
Ответить
СообщениеДа, результат тот что нужно. Только я теперь не понимаю как мне это самому применить к большему массиву %) :haha:

Автор - zaspeg
Дата добавления - 28.12.2022 в 10:00
zaspeg Дата: Среда, 28.12.2022, 10:02 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 40% ±

Так нужно?

=ЕСЛИОШИБКА(ИНДЕКС(Лист2!B$2:B$99;ПОИСКПОЗ($A2;Лист2!$A$2:$A$99;));"--")


Да, так понятно, спасибо. Отблагодарил!


Сообщение отредактировал zaspeg - Среда, 28.12.2022, 10:45
 
Ответить
Сообщение
Так нужно?

=ЕСЛИОШИБКА(ИНДЕКС(Лист2!B$2:B$99;ПОИСКПОЗ($A2;Лист2!$A$2:$A$99;));"--")


Да, так понятно, спасибо. Отблагодарил!

Автор - zaspeg
Дата добавления - 28.12.2022 в 10:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение данных при совпадении (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!