Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Цикл с суммированием - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Цикл с суммированием (Формулы/Formulas)
Цикл с суммированием
tlekmendybayev Дата: Среда, 28.12.2022, 11:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Краткое описание практического значения применения эксель:Есть Вращающиеся оборудование, которое периодически необходимо ремонтировать. Хочу проследить статистику, сколько оборотов совершает оборудование перед поломкой, для своевременного планирования.

Что делаю в Эксель:
1. Ежедневно записываю количество оборотов оборудования.
2. В случае если в этот день его ремонтируют ставлю 0, т.к. оборудование не работало.

Что хочу автоматизировать:
Необходимо чтобы в ячейке В2 отображалась сумма значений в колонке В ( В3:В100. т.к данные ежедневно дополняются), но чтобы в случае появления значения 0, моя сумма обнулялась, и следующие значения после 0 опять суммировались и отображались в колонке В2 без учета значений до 0. Другими словами у меня есть неизвестное количество циклов суммирования, при появления 0, первый цикл заканчивается и начинаются следующий.

Я средний пользователь Эксель, пробывал логически решить эту задачу без помочи VBA, не получилось. Начал изучать статьи по vba и ролики, но пока не понял как мне прописать правильный код, и уходит много времени.

Прошу подсказать мне с планом, что должно быть в моем коде, чтобы я мог точечно посмотреть примеры. Если у Вас есть какие то примеры кодов с похожей задачей - мне это сильно поможет. Спасибо !
К сообщению приложен файл: 9060751.xlsx (9.4 Kb)
 
Ответить
СообщениеКраткое описание практического значения применения эксель:Есть Вращающиеся оборудование, которое периодически необходимо ремонтировать. Хочу проследить статистику, сколько оборотов совершает оборудование перед поломкой, для своевременного планирования.

Что делаю в Эксель:
1. Ежедневно записываю количество оборотов оборудования.
2. В случае если в этот день его ремонтируют ставлю 0, т.к. оборудование не работало.

Что хочу автоматизировать:
Необходимо чтобы в ячейке В2 отображалась сумма значений в колонке В ( В3:В100. т.к данные ежедневно дополняются), но чтобы в случае появления значения 0, моя сумма обнулялась, и следующие значения после 0 опять суммировались и отображались в колонке В2 без учета значений до 0. Другими словами у меня есть неизвестное количество циклов суммирования, при появления 0, первый цикл заканчивается и начинаются следующий.

Я средний пользователь Эксель, пробывал логически решить эту задачу без помочи VBA, не получилось. Начал изучать статьи по vba и ролики, но пока не понял как мне прописать правильный код, и уходит много времени.

Прошу подсказать мне с планом, что должно быть в моем коде, чтобы я мог точечно посмотреть примеры. Если у Вас есть какие то примеры кодов с похожей задачей - мне это сильно поможет. Спасибо !

Автор - tlekmendybayev
Дата добавления - 28.12.2022 в 11:27
Pelena Дата: Среда, 28.12.2022, 11:55 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18721
Репутация: 4265 ±
Замечаний: ±

Excel 2016 & Mac Excel
И Вам здравствуйте.
Варианты формулой
Код
=СУММ(ИНДЕКС($B$3:$B$100;ПРОСМОТР(;-1/($B$3:$B$100=0)/($B$3:$B$100<>"");СТРОКА($B$3:$B$100)-2)):$B$100)

Код
=СУММ(ИНДЕКС($B$3:$B$100;МАКС(($B$3:$B$100=0)*($B$3:$B$100<>"")*(СТРОКА($B$3:$B$100)-2))):$B$100)
К сообщению приложен файл: 9962820.xlsx (10.4 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеИ Вам здравствуйте.
Варианты формулой
Код
=СУММ(ИНДЕКС($B$3:$B$100;ПРОСМОТР(;-1/($B$3:$B$100=0)/($B$3:$B$100<>"");СТРОКА($B$3:$B$100)-2)):$B$100)

Код
=СУММ(ИНДЕКС($B$3:$B$100;МАКС(($B$3:$B$100=0)*($B$3:$B$100<>"")*(СТРОКА($B$3:$B$100)-2))):$B$100)

Автор - Pelena
Дата добавления - 28.12.2022 в 11:55
_Boroda_ Дата: Среда, 28.12.2022, 12:08 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16560
Репутация: 6446 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=СУММ(B99:ИНДЕКС(B:B;ЕСЛИОШИБКА(ПРОСМОТР(;-1/(B3:B99&1="01");СТРОКА(B3:B99));3)))


Кросс
По мотивам формулы Лены

Код
=СУММ(ИНДЕКС(B:B;МАКС(3;(B3:B99&1="01")*СТРОКА(3:99))):B99)
К сообщению приложен файл: ___2.xlsx (9.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=СУММ(B99:ИНДЕКС(B:B;ЕСЛИОШИБКА(ПРОСМОТР(;-1/(B3:B99&1="01");СТРОКА(B3:B99));3)))


Кросс
По мотивам формулы Лены

Код
=СУММ(ИНДЕКС(B:B;МАКС(3;(B3:B99&1="01")*СТРОКА(3:99))):B99)

Автор - _Boroda_
Дата добавления - 28.12.2022 в 12:08
Nic70y Дата: Среда, 28.12.2022, 14:02 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8027
Репутация: 1953 ±
Замечаний: 0% ±

Excel 2010
для разнообразия
Код
=СУММЕСЛИ(A3:A100;">"&СУММПРОИЗВ(МАКС((B3:B100&""="0")*A3:A100));B3:B100)
К сообщению приложен файл: 712.xlsx (9.4 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениедля разнообразия
Код
=СУММЕСЛИ(A3:A100;">"&СУММПРОИЗВ(МАКС((B3:B100&""="0")*A3:A100));B3:B100)

Автор - Nic70y
Дата добавления - 28.12.2022 в 14:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Цикл с суммированием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!