Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автозаполнение ячеек - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозаполнение ячеек (Формулы/Formulas)
Автозаполнение ячеек
zaspeg Дата: Четверг, 29.12.2022, 15:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 40% ±

Добрый день.
Подскажите, в чем ошибка в формуле?
Смысл в том, чтобы на листе "Накладная" в ячейку B1 я внёс номер заказа, а все остальные ячейки на этом листе заполнились автоматически, взяв данные из массива с листа "База данных". Формула вбита на листе "Накладная" в ячейке B3.
Спасибо.
К сообщению приложен файл: 9921822.xlsx(25.3 Kb)
 
Ответить
СообщениеДобрый день.
Подскажите, в чем ошибка в формуле?
Смысл в том, чтобы на листе "Накладная" в ячейку B1 я внёс номер заказа, а все остальные ячейки на этом листе заполнились автоматически, взяв данные из массива с листа "База данных". Формула вбита на листе "Накладная" в ячейке B3.
Спасибо.

Автор - zaspeg
Дата добавления - 29.12.2022 в 15:43
Russel Дата: Четверг, 29.12.2022, 15:56 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1388
Репутация: 318 ±
Замечаний: 0% ±

Excel 2010
Для ячейки В2, остальные по тому же принципу:
Код
=ВПР(B1;'База данных'!$A$2:$R$5;10;0)


QIWI 9173973973
 
Ответить
СообщениеДля ячейки В2, остальные по тому же принципу:
Код
=ВПР(B1;'База данных'!$A$2:$R$5;10;0)

Автор - Russel
Дата добавления - 29.12.2022 в 15:56
zaspeg Дата: Четверг, 29.12.2022, 16:05 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 40% ±

Спасибо большое! Оказалось всё намного проще :)
 
Ответить
СообщениеСпасибо большое! Оказалось всё намного проще :)

Автор - zaspeg
Дата добавления - 29.12.2022 в 16:05
zaspeg Дата: Четверг, 29.12.2022, 16:18 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 40% ±

А там у такого номера заказа несколько разных позиций (строк), по формуле выводится только одна строка (первая по алфавиту)
 
Ответить
СообщениеА там у такого номера заказа несколько разных позиций (строк), по формуле выводится только одна строка (первая по алфавиту)

Автор - zaspeg
Дата добавления - 29.12.2022 в 16:18
_Boroda_ Дата: Четверг, 29.12.2022, 16:28 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16550
Репутация: 6441 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Код
=ЕСЛИОШИБКА(ИНДЕКС('База данных'!C$2:C$99;НАИМЕНЬШИЙ(ЕСЛИ('База данных'!$A$2:$A$99=$B$1;СТРОКА('База данных'!$2:$99));СТРОКА(B1)));"")
К сообщению приложен файл: 9921822_1.xlsx(26.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеФормула массива, вводится одновременным нажатием Контрл Шифт Ентер
Код
=ЕСЛИОШИБКА(ИНДЕКС('База данных'!C$2:C$99;НАИМЕНЬШИЙ(ЕСЛИ('База данных'!$A$2:$A$99=$B$1;СТРОКА('База данных'!$2:$99));СТРОКА(B1)));"")

Автор - _Boroda_
Дата добавления - 29.12.2022 в 16:28
zaspeg Дата: Четверг, 29.12.2022, 17:45 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 40% ±

Пытаюсь изменить диапазон на
Код
=ЕСЛИОШИБКА(ИНДЕКС('База данных'!C$2:C$9999;НАИМЕНЬШИЙ(ЕСЛИ('База данных'!$A$2:$A$9999=$B$1;СТРОКА('База данных'!$2:$9999));СТРОКА(B1)));"")

у меня сразу перестает работать


Сообщение отредактировал Serge_007 - Четверг, 29.12.2022, 17:58
 
Ответить
СообщениеПытаюсь изменить диапазон на
Код
=ЕСЛИОШИБКА(ИНДЕКС('База данных'!C$2:C$9999;НАИМЕНЬШИЙ(ЕСЛИ('База данных'!$A$2:$A$9999=$B$1;СТРОКА('База данных'!$2:$9999));СТРОКА(B1)));"")

у меня сразу перестает работать

Автор - zaspeg
Дата добавления - 29.12.2022 в 17:45
_Boroda_ Дата: Четверг, 29.12.2022, 17:48 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16550
Репутация: 6441 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
вводится одновременным нажатием Контрл Шифт Ентер

Это делаете?
Кстати, на 9999 строк тормозить должно.
Если номера по порядку идут, то можно гораздо более легкую формулу написать. Но я уже до завтра убегаю, кто-нибудь другой, надеюсь, поможет


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
вводится одновременным нажатием Контрл Шифт Ентер

Это делаете?
Кстати, на 9999 строк тормозить должно.
Если номера по порядку идут, то можно гораздо более легкую формулу написать. Но я уже до завтра убегаю, кто-нибудь другой, надеюсь, поможет

Автор - _Boroda_
Дата добавления - 29.12.2022 в 17:48
zaspeg Дата: Четверг, 29.12.2022, 17:50 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 40% ±

Спасибо, помогли, нашел в интернете, править формулу массива нужно было через F2
 
Ответить
СообщениеСпасибо, помогли, нашел в интернете, править формулу массива нужно было через F2

Автор - zaspeg
Дата добавления - 29.12.2022 в 17:50
_Boroda_ Дата: Четверг, 29.12.2022, 17:55 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16550
Репутация: 6441 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
править формулу массива нужно было через F2

Я Вас умоляю, покажите мне это! Что, прям так и написано? Какой кошмар!!!


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
править формулу массива нужно было через F2

Я Вас умоляю, покажите мне это! Что, прям так и написано? Какой кошмар!!!

Автор - _Boroda_
Дата добавления - 29.12.2022 в 17:55
Serge_007 Дата: Четверг, 29.12.2022, 18:02 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 15647
Репутация: 2575 ±
Замечаний: ±

Excel 2016
править формулу массива нужно было через F2
Можно
Но нажатие F2 при правке формул массива - просто лишнее действие
Проще и быстрее править напрямую


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
править формулу массива нужно было через F2
Можно
Но нажатие F2 при правке формул массива - просто лишнее действие
Проще и быстрее править напрямую

Автор - Serge_007
Дата добавления - 29.12.2022 в 18:02
zaspeg Дата: Пятница, 30.12.2022, 10:14 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 40% ±

В ходе работы с файлом выяснилось что формула не совсем рабочая, она подставляет значения, соответствующие не данной строке, а следующей.
К сообщению приложен файл: 3607144.xlsx(170.0 Kb)


Сообщение отредактировал zaspeg - Пятница, 30.12.2022, 10:14
 
Ответить
СообщениеВ ходе работы с файлом выяснилось что формула не совсем рабочая, она подставляет значения, соответствующие не данной строке, а следующей.

Автор - zaspeg
Дата добавления - 30.12.2022 в 10:14
_Boroda_ Дата: Пятница, 30.12.2022, 10:17 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16550
Репутация: 6441 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Точно, вот так нужно
Код
=ЕСЛИОШИБКА(ИНДЕКС('База данных'!C:C;НАИМЕНЬШИЙ(ЕСЛИ('База данных'!$A$2:$A$99=$B$1;СТРОКА('База данных'!$2:$99));СТРОКА(B1)));"")
К сообщению приложен файл: 3607144_1.xlsx(167.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТочно, вот так нужно
Код
=ЕСЛИОШИБКА(ИНДЕКС('База данных'!C:C;НАИМЕНЬШИЙ(ЕСЛИ('База данных'!$A$2:$A$99=$B$1;СТРОКА('База данных'!$2:$99));СТРОКА(B1)));"")

Автор - _Boroda_
Дата добавления - 30.12.2022 в 10:17
zaspeg Дата: Пятница, 30.12.2022, 10:30 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 40% ±

Всё отлично! Спасибо!
 
Ответить
СообщениеВсё отлично! Спасибо!

Автор - zaspeg
Дата добавления - 30.12.2022 в 10:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозаполнение ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!