Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/график с автоматическим подсчетом ячеек по цвету - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » график с автоматическим подсчетом ячеек по цвету (Формулы/Formulas)
график с автоматическим подсчетом ячеек по цвету
bizon84k Дата: Среда, 04.01.2023, 15:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

2019
Всем доброго дня! Помогите пожалуйста в создании таблицы с графиком дежурств на кассе, с автоматическим подсчетом часов на кассе за день и за месяц. К примеру, я составляю график на завтра-и смены на каждого сотрудника автоматически считаются и вносятся в отдельный столбец "Кол-во часов на кассе" и также вносятся на отдельный лист как в дневную графу, так и в графу за месяц "Итого". Как подсчитать ячейки желтого цвета с помощью VBA я нашел, но вот с автоматическим подсчетом беда( Возможно задача не сложная, но не могу справиться с ней( выручайте
К сообщению приложен файл: 0086318.xlsm (16.0 Kb)
 
Ответить
СообщениеВсем доброго дня! Помогите пожалуйста в создании таблицы с графиком дежурств на кассе, с автоматическим подсчетом часов на кассе за день и за месяц. К примеру, я составляю график на завтра-и смены на каждого сотрудника автоматически считаются и вносятся в отдельный столбец "Кол-во часов на кассе" и также вносятся на отдельный лист как в дневную графу, так и в графу за месяц "Итого". Как подсчитать ячейки желтого цвета с помощью VBA я нашел, но вот с автоматическим подсчетом беда( Возможно задача не сложная, но не могу справиться с ней( выручайте

Автор - bizon84k
Дата добавления - 04.01.2023 в 15:24
gling Дата: Среда, 04.01.2023, 17:03 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2435
Репутация: 644 ±
Замечаний: 0% ±

2010
Как подсчитать ячейки желтого цвета с помощью VBA я нашел
Если это на каждом листе посчитаете, то для каждого дня, на листе "Месяц" воспользуйтесь формулой
Код
=ЕСЛИОШИБКА(ВПР($A2;ДВССЫЛ("'"&ТЕКСТ(B$1;"Д")&"'!A1:M20");13;);)
К сообщению приложен файл: 4246892.xlsm (16.5 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Среда, 04.01.2023, 17:29
 
Ответить
Сообщение
Как подсчитать ячейки желтого цвета с помощью VBA я нашел
Если это на каждом листе посчитаете, то для каждого дня, на листе "Месяц" воспользуйтесь формулой
Код
=ЕСЛИОШИБКА(ВПР($A2;ДВССЫЛ("'"&ТЕКСТ(B$1;"Д")&"'!A1:M20");13;);)

Автор - gling
Дата добавления - 04.01.2023 в 17:03
Gustav Дата: Среда, 04.01.2023, 17:17 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2305
Репутация: 918 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
bizon84k, что Вам мешает не просто красить ячейку жёлтым, а вводить туда какой-нибудь осязаемый символ, например, 1? Тогда не надо писать функции на VBA и преодолевать их способность не всегда пересчитываться.

Можно сделать жёлтыми и шрифт, и заливку, чтобы внешне была видна только заливка. В идеале нужно просто настроить условное форматирование (УФ) - делаете для условия "значение = 1", как уже сказано, шрифт и заливку одним цветом (жёлтым). И дальше вводите только единички в нужные клетки, и они автоматически становятся жёлтыми, не отображая саму единичку. Зато кол-во часов на кассе подсчитывается с помощью элементарной функции СУММ, без какого-либо VBA.

Умеете с УФ работать?
К сообщению приложен файл: 00863cf.xlsm (19.5 Kb)


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Среда, 04.01.2023, 17:27
 
Ответить
Сообщениеbizon84k, что Вам мешает не просто красить ячейку жёлтым, а вводить туда какой-нибудь осязаемый символ, например, 1? Тогда не надо писать функции на VBA и преодолевать их способность не всегда пересчитываться.

Можно сделать жёлтыми и шрифт, и заливку, чтобы внешне была видна только заливка. В идеале нужно просто настроить условное форматирование (УФ) - делаете для условия "значение = 1", как уже сказано, шрифт и заливку одним цветом (жёлтым). И дальше вводите только единички в нужные клетки, и они автоматически становятся жёлтыми, не отображая саму единичку. Зато кол-во часов на кассе подсчитывается с помощью элементарной функции СУММ, без какого-либо VBA.

Умеете с УФ работать?

Автор - Gustav
Дата добавления - 04.01.2023 в 17:17
bizon84k Дата: Среда, 04.01.2023, 17:20 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

2019
gling, Спасибо
 
Ответить
Сообщениеgling, Спасибо

Автор - bizon84k
Дата добавления - 04.01.2023 в 17:20
bizon84k Дата: Среда, 04.01.2023, 17:20 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

2019
Gustav, Да,буду пробовать, так действительно проще! Спасибо большое за помощь
 
Ответить
СообщениеGustav, Да,буду пробовать, так действительно проще! Спасибо большое за помощь

Автор - bizon84k
Дата добавления - 04.01.2023 в 17:20
Gustav Дата: Среда, 04.01.2023, 17:29 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2305
Репутация: 918 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
буду пробовать

Я прикрепил файл примера выше в сообщении №3. На листе "1" настроено УФ. Изучайте!


МОИ: Ник, Tip box: 41001663842605
 
Ответить
Сообщение
буду пробовать

Я прикрепил файл примера выше в сообщении №3. На листе "1" настроено УФ. Изучайте!

Автор - Gustav
Дата добавления - 04.01.2023 в 17:29
bizon84k Дата: Среда, 04.01.2023, 17:54 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

2019
Gustav, разобрался! еще раз спасибо!
 
Ответить
СообщениеGustav, разобрался! еще раз спасибо!

Автор - bizon84k
Дата добавления - 04.01.2023 в 17:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » график с автоматическим подсчетом ячеек по цвету (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!