Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ссылка на другой лист - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ссылка на другой лист (Формулы/Formulas)
Ссылка на другой лист
Sergey_Syakoy Дата: Четверг, 05.01.2023, 12:59 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте. У меня возник вопрос. Вопрос заключается в замене ссылки на листы. Например, есть несколько листов - Лист1; Лист2; Лист3; Лист4; Лист5, а
на листе Лист1, в ячейке A5 имеется формула
Код
=ЕСЛИ(ИЛИ(Лист2!B1=1;Лист2!B2=2);A;"")
. Вот, как сделать так, чтобы задавав в ячейке A4 название (ссылку) нужного мне листа, формула понимала ссылку, а не воспринимала его как текст.
Код
=ЕСЛИ(ИЛИ(A4&"!"&"B1"=1;A4&"!"&"B2"=2);A;"")
, где в A4 можно выбирать название листов (Лист2; Лист3; Лист4; Лист5).
Код
=ЕСЛИ(ИЛИ(A4=1;A4=2);A;"")
, ну или в ячейке A4 уже будет находится нужная ссылка на ячейку, с названием листа (A4=Лист2!B1).
Когда искал решение, пробовал эти варианты, но формула понимает их как текст – A4&"!"&"B1" –> "Лист2"&"!"&"B1" –> "Лист2!B1"
Как видно, это все из-за кавычек. Почему так происходит? И какое есть решение?
 
Ответить
СообщениеЗдравствуйте. У меня возник вопрос. Вопрос заключается в замене ссылки на листы. Например, есть несколько листов - Лист1; Лист2; Лист3; Лист4; Лист5, а
на листе Лист1, в ячейке A5 имеется формула
Код
=ЕСЛИ(ИЛИ(Лист2!B1=1;Лист2!B2=2);A;"")
. Вот, как сделать так, чтобы задавав в ячейке A4 название (ссылку) нужного мне листа, формула понимала ссылку, а не воспринимала его как текст.
Код
=ЕСЛИ(ИЛИ(A4&"!"&"B1"=1;A4&"!"&"B2"=2);A;"")
, где в A4 можно выбирать название листов (Лист2; Лист3; Лист4; Лист5).
Код
=ЕСЛИ(ИЛИ(A4=1;A4=2);A;"")
, ну или в ячейке A4 уже будет находится нужная ссылка на ячейку, с названием листа (A4=Лист2!B1).
Когда искал решение, пробовал эти варианты, но формула понимает их как текст – A4&"!"&"B1" –> "Лист2"&"!"&"B1" –> "Лист2!B1"
Как видно, это все из-за кавычек. Почему так происходит? И какое есть решение?

Автор - Sergey_Syakoy
Дата добавления - 05.01.2023 в 12:59
Pelena Дата: Четверг, 05.01.2023, 13:40 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18721
Репутация: 4264 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Не совсем понятно, что значит А, предположим, что это А1. Тогда
Код
=ЕСЛИ(ИЛИ(ДВССЫЛ("'"&A4&"'!B1")=1;ДВССЫЛ("'"&A4&"'!B2")=2);A1;"")


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Не совсем понятно, что значит А, предположим, что это А1. Тогда
Код
=ЕСЛИ(ИЛИ(ДВССЫЛ("'"&A4&"'!B1")=1;ДВССЫЛ("'"&A4&"'!B2")=2);A1;"")

Автор - Pelena
Дата добавления - 05.01.2023 в 13:40
gling Дата: Четверг, 05.01.2023, 13:56 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2435
Репутация: 644 ±
Замечаний: 0% ±

2010
Здравствуйте.
А с файлом примером было бы лучше, там и А4 с названиями листов есть.


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
А с файлом примером было бы лучше, там и А4 с названиями листов есть.

Автор - gling
Дата добавления - 05.01.2023 в 13:56
Sergey_Syakoy Дата: Четверг, 05.01.2023, 18:54 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Значение А, там где истина, это просто значение, оно не важно, надо было мне его в кавычки закрыть. Моя ошибка.
Получается, что программа будет воспринимать текст ссылки из ячейки, как ссылку, если его записать только через ДВССЫЛ?
Или можно записать это попроще? Через какие-то знаки например.


Сообщение отредактировал Sergey_Syakoy - Четверг, 05.01.2023, 19:15
 
Ответить
СообщениеЗначение А, там где истина, это просто значение, оно не важно, надо было мне его в кавычки закрыть. Моя ошибка.
Получается, что программа будет воспринимать текст ссылки из ячейки, как ссылку, если его записать только через ДВССЫЛ?
Или можно записать это попроще? Через какие-то знаки например.

Автор - Sergey_Syakoy
Дата добавления - 05.01.2023 в 18:54
Gustav Дата: Пятница, 06.01.2023, 14:04 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2305
Репутация: 918 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Цитата Sergey_Syakoy, 05.01.2023 в 18:54, в сообщении № 4 ()
Или можно записать это попроще? Через какие-то знаки например.

Можно попробовать, если понравится, создать имя-формулу через "Диспетчер имен". Для этого, стоя на ячейке A5 на Лист1, жмёте Ctrl+F3, "Создать" и далее заполняете форму:
[vba]
Код
Имя: дс
Область: Книга
Диапазон: =ДВССЫЛ(!A4)
[/vba]И теперь в любой ячейке любого листа можете использовать идентификатор "дс" для ссылки на ячейку, полный адрес которой указан в соседней ячейке сверху. Тогда формула для A5 приобретает такой вид:
Код
=ЕСЛИ(ИЛИ(дс=1;дс=2);"A";"")

Но стоит чуть поменять дизайн таблицы, например, вставить новую строку между 4 и 5, как формула, к сожалению, перестанет работать. Но тут уж каждый выбирает по себе. По мне так и просто ДВССЫЛ внутри формулы - отличный выбор, в конце концов, именно для этого она и существует в списке функций.


МОИ: Ник, Tip box: 41001663842605
 
Ответить
Сообщение
Цитата Sergey_Syakoy, 05.01.2023 в 18:54, в сообщении № 4 ()
Или можно записать это попроще? Через какие-то знаки например.

Можно попробовать, если понравится, создать имя-формулу через "Диспетчер имен". Для этого, стоя на ячейке A5 на Лист1, жмёте Ctrl+F3, "Создать" и далее заполняете форму:
[vba]
Код
Имя: дс
Область: Книга
Диапазон: =ДВССЫЛ(!A4)
[/vba]И теперь в любой ячейке любого листа можете использовать идентификатор "дс" для ссылки на ячейку, полный адрес которой указан в соседней ячейке сверху. Тогда формула для A5 приобретает такой вид:
Код
=ЕСЛИ(ИЛИ(дс=1;дс=2);"A";"")

Но стоит чуть поменять дизайн таблицы, например, вставить новую строку между 4 и 5, как формула, к сожалению, перестанет работать. Но тут уж каждый выбирает по себе. По мне так и просто ДВССЫЛ внутри формулы - отличный выбор, в конце концов, именно для этого она и существует в списке функций.

Автор - Gustav
Дата добавления - 06.01.2023 в 14:04
Sergey_Syakoy Дата: Пятница, 06.01.2023, 15:15 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Понял, большое спасибо всем.
 
Ответить
СообщениеПонял, большое спасибо всем.

Автор - Sergey_Syakoy
Дата добавления - 06.01.2023 в 15:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ссылка на другой лист (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!