Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск текста условно и выводить текст на другой лист - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск текста условно и выводить текст на другой лист (Формулы/Formulas)
Поиск текста условно и выводить текст на другой лист
mudvys Дата: Воскресенье, 08.01.2023, 11:32 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!

Коллеги, прошу оказать помощь в решении следующей задачи.

Имеется данные ГТД со списком сопроводительных документов.
Требуется вывести в другой лист (ОПИСЬ) эти списки документов.
У каждого документа есть свой номер (202, 220, 404 и т.д.)
Никак не мог подобрать формулу для поиска текста, чтоб находил и вставил в таблицу.
Документов много слишком и уйма времени уходит на copy/paste.

В прикрепленном файле выделил красным.

Заранее всем большое спасибо!
К сообщению приложен файл: 26003.xlsx(15.5 Kb)


Сообщение отредактировал mudvys - Воскресенье, 08.01.2023, 12:41
 
Ответить
СообщениеДобрый день!

Коллеги, прошу оказать помощь в решении следующей задачи.

Имеется данные ГТД со списком сопроводительных документов.
Требуется вывести в другой лист (ОПИСЬ) эти списки документов.
У каждого документа есть свой номер (202, 220, 404 и т.д.)
Никак не мог подобрать формулу для поиска текста, чтоб находил и вставил в таблицу.
Документов много слишком и уйма времени уходит на copy/paste.

В прикрепленном файле выделил красным.

Заранее всем большое спасибо!

Автор - mudvys
Дата добавления - 08.01.2023 в 11:32
gling Дата: Воскресенье, 08.01.2023, 12:48 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2435
Репутация: 644 ±
Замечаний: 0% ±

2010
Здравствуйте.
Может быть формула массива поможет дальше развить мысль.
Код
=ИНДЕКС(ГТД!$A$1:$A$61;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ЕСЛИ(ТРАНСП($D$5:$D$14)=ЛЕВБ(ГТД!$A$1:$A$61;4);СТРОКА(ГТД!$A$1:$A$61);"");"");СТРОКА(G1)))
К сообщению приложен файл: 1228456.xlsx(16.3 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
Может быть формула массива поможет дальше развить мысль.
Код
=ИНДЕКС(ГТД!$A$1:$A$61;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ЕСЛИ(ТРАНСП($D$5:$D$14)=ЛЕВБ(ГТД!$A$1:$A$61;4);СТРОКА(ГТД!$A$1:$A$61);"");"");СТРОКА(G1)))

Автор - gling
Дата добавления - 08.01.2023 в 12:48
mudvys Дата: Воскресенье, 08.01.2023, 12:55 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

gling,

Спасибо большое.
Дальше чтоб нормально выглядело в таблице смогу убрать номера (202., 220., и т.д.) с формулой.
 
Ответить
Сообщениеgling,

Спасибо большое.
Дальше чтоб нормально выглядело в таблице смогу убрать номера (202., 220., и т.д.) с формулой.

Автор - mudvys
Дата добавления - 08.01.2023 в 12:55
mudvys Дата: Воскресенье, 08.01.2023, 13:19 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

gling,

Не могли подсказать что связано в конце формулы СТРОКА(G1) ?
и еще вопрос - в листе ГТД ячейку с текстом "301." формула не находит или причина в другом?
 
Ответить
Сообщениеgling,

Не могли подсказать что связано в конце формулы СТРОКА(G1) ?
и еще вопрос - в листе ГТД ячейку с текстом "301." формула не находит или причина в другом?

Автор - mudvys
Дата добавления - 08.01.2023 в 13:19
mudvys Дата: Воскресенье, 08.01.2023, 13:32 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

gling,

Ой извините, не рассмотрел)

Еще раз спасибо
 
Ответить
Сообщениеgling,

Ой извините, не рассмотрел)

Еще раз спасибо

Автор - mudvys
Дата добавления - 08.01.2023 в 13:32
mudvys Дата: Воскресенье, 08.01.2023, 13:49 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

gling,

А нельзя так чтобы выводились результаты на своей строке?
 
Ответить
Сообщениеgling,

А нельзя так чтобы выводились результаты на своей строке?

Автор - mudvys
Дата добавления - 08.01.2023 в 13:49
gling Дата: Воскресенье, 08.01.2023, 14:21 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2435
Репутация: 644 ±
Замечаний: 0% ±

2010
Вариант распределения по своим строкам в файле. Сначала формируйте перечень этих строк на скрытом листе, а потом из этого перечня расставляйте по строкам.
Немного изменил формулу, заменил файл.
К сообщению приложен файл: 3807846.xlsx(16.8 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Воскресенье, 08.01.2023, 14:39
 
Ответить
СообщениеВариант распределения по своим строкам в файле. Сначала формируйте перечень этих строк на скрытом листе, а потом из этого перечня расставляйте по строкам.
Немного изменил формулу, заменил файл.

Автор - gling
Дата добавления - 08.01.2023 в 14:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск текста условно и выводить текст на другой лист (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!