Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Кол-во знаков после запятой слишком большое при расчете сум - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Кол-во знаков после запятой слишком большое при расчете сум (Формулы/Formulas)
Кол-во знаков после запятой слишком большое при расчете сум
Таша81 Дата: Понедельник, 09.01.2023, 00:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.
Поиском похожую проблему не нашла, т.к., возможно, неверно формулирую.

Есть таблица, простая, две колонки: приход и расход. Итоговая сумма = сумма приходов минус сумма расходов. Все цифры введены с количеством знаков после запятой не более двух. Все значения в колонках введены без формул, только цифры. Сумма считается правильно. Но если попытаться скопировать получившуюся сумму и вставить ее в новую ячейку как "Вставить значение", то в строке формул будет видно, что эта сумма вставилась с 11 знаками после запятой, то есть вместо 1796,72 получилось 1796,71999999999.

Я понимаю, как установить отображение правильно, с двумя знаками после запятой. Но мне нужно, чтобы она изначально копировалась именно так, ведь в числах, которые участвуют в операции, нет ни одной с кол-вом знаков после запятой более двух.
Подскажите, пожалуйста, в чем проблема.
К сообщению приложен файл: 4020953.xlsx(9.4 Kb)


Сообщение отредактировал Таша81 - Понедельник, 09.01.2023, 00:14
 
Ответить
СообщениеДобрый день.
Поиском похожую проблему не нашла, т.к., возможно, неверно формулирую.

Есть таблица, простая, две колонки: приход и расход. Итоговая сумма = сумма приходов минус сумма расходов. Все цифры введены с количеством знаков после запятой не более двух. Все значения в колонках введены без формул, только цифры. Сумма считается правильно. Но если попытаться скопировать получившуюся сумму и вставить ее в новую ячейку как "Вставить значение", то в строке формул будет видно, что эта сумма вставилась с 11 знаками после запятой, то есть вместо 1796,72 получилось 1796,71999999999.

Я понимаю, как установить отображение правильно, с двумя знаками после запятой. Но мне нужно, чтобы она изначально копировалась именно так, ведь в числах, которые участвуют в операции, нет ни одной с кол-вом знаков после запятой более двух.
Подскажите, пожалуйста, в чем проблема.

Автор - Таша81
Дата добавления - 09.01.2023 в 00:13
DrMini Дата: Понедельник, 09.01.2023, 04:43 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 912
Репутация: 79 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Доброго времени суток Таша81,
Может так подойдёт?
Код
=ОКРУГЛ(СУММ(B2:B98)-СУММ(C2:C98);2)
 
Ответить
СообщениеДоброго времени суток Таша81,
Может так подойдёт?
Код
=ОКРУГЛ(СУММ(B2:B98)-СУММ(C2:C98);2)

Автор - DrMini
Дата добавления - 09.01.2023 в 04:43
Таша81 Дата: Понедельник, 09.01.2023, 12:55 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.

Спасибо, эту функцию я знаю.
Но таких таблиц много, формул много, иногда делаю срез результатов с копированием итогов на конкретную дату, не хочется каждый раз думать о том, что 2+2=3,9999999999...
 
Ответить
СообщениеДобрый день.

Спасибо, эту функцию я знаю.
Но таких таблиц много, формул много, иногда делаю срез результатов с копированием итогов на конкретную дату, не хочется каждый раз думать о том, что 2+2=3,9999999999...

Автор - Таша81
Дата добавления - 09.01.2023 в 12:55
and_evg Дата: Понедельник, 09.01.2023, 13:02 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 414
Репутация: 72 ±
Замечаний: 0% ±

Excel 2007
Таша81, Добрый день
не хочется каждый раз думать

Может быть выставить "Точность как на экране" ?
 
Ответить
СообщениеТаша81, Добрый день
не хочется каждый раз думать

Может быть выставить "Точность как на экране" ?

Автор - and_evg
Дата добавления - 09.01.2023 в 13:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Кол-во знаков после запятой слишком большое при расчете сум (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!