Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматизация отчета - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматизация отчета (Формулы/Formulas)
Автоматизация отчета
florallandmusic Дата: Вторник, 10.01.2023, 20:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день. Очень ищу профессионалов, которые помогут мне подобрать формулу для решения моей проблемы.
Предыстория: Посчитал средний KPI (СТОЛБ K) сотрудников за месяц, формулой =наибольш нашел топ 3. Собственно вопрос:
Как мне в столбце M2,M3,M4 приписать фамилии, которые принадлежат данным числам?


Сообщение отредактировал florallandmusic - Вторник, 10.01.2023, 23:02
 
Ответить
СообщениеДобрый день. Очень ищу профессионалов, которые помогут мне подобрать формулу для решения моей проблемы.
Предыстория: Посчитал средний KPI (СТОЛБ K) сотрудников за месяц, формулой =наибольш нашел топ 3. Собственно вопрос:
Как мне в столбце M2,M3,M4 приписать фамилии, которые принадлежат данным числам?

Автор - florallandmusic
Дата добавления - 10.01.2023 в 20:23
Gustav Дата: Вторник, 10.01.2023, 20:44 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2304
Репутация: 918 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
С помощью функций ИНДЕКС и ПОИСКПОЗ. А вообще немного неправильно подошли. Нужно было применить функцию РАНГ и сразу определить "места" - целые числа.

А так у в Вас теперь ПОИСКПОЗ надо делать по вещественным числам с кучей знаков после запятой - не айс, и не факт, что сойдётся. Возможно, придется округлять сначала до какого-то разумного кол-ва знаков.

P.S. И по фотографиям здесь обычно не лечат. Был бы файл с примером приложен - уже бы получили его обратно с формулами. А так теперь сами с функциями разбирайтесь, читайте мануалы.


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Вторник, 10.01.2023, 20:55
 
Ответить
СообщениеС помощью функций ИНДЕКС и ПОИСКПОЗ. А вообще немного неправильно подошли. Нужно было применить функцию РАНГ и сразу определить "места" - целые числа.

А так у в Вас теперь ПОИСКПОЗ надо делать по вещественным числам с кучей знаков после запятой - не айс, и не факт, что сойдётся. Возможно, придется округлять сначала до какого-то разумного кол-ва знаков.

P.S. И по фотографиям здесь обычно не лечат. Был бы файл с примером приложен - уже бы получили его обратно с формулами. А так теперь сами с функциями разбирайтесь, читайте мануалы.

Автор - Gustav
Дата добавления - 10.01.2023 в 20:44
Gustav Дата: Вторник, 10.01.2023, 21:54 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2304
Репутация: 918 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Для ячейки M2 - формула массива (ввод закончить комбинацией Ctrl+Shift+Enter)
Код
=ИНДЕКС($J$1:$J$1000;ПОИСКПОЗ(ОКРУГЛ(L2;6);ОКРУГЛ($K$1:$K$1000;6);0))

И далее в ячейки ниже M2 просто скопировать из M2. Ответ будет такой:
[vba]
Код
1    Одинцов Андрей Андреевич
0,990286092    Прокуроров Евгений Александрович
0,988583652    Плугатырь Артём Юрьевич
[/vba]


МОИ: Ник, Tip box: 41001663842605
 
Ответить
СообщениеДля ячейки M2 - формула массива (ввод закончить комбинацией Ctrl+Shift+Enter)
Код
=ИНДЕКС($J$1:$J$1000;ПОИСКПОЗ(ОКРУГЛ(L2;6);ОКРУГЛ($K$1:$K$1000;6);0))

И далее в ячейки ниже M2 просто скопировать из M2. Ответ будет такой:
[vba]
Код
1    Одинцов Андрей Андреевич
0,990286092    Прокуроров Евгений Александрович
0,988583652    Плугатырь Артём Юрьевич
[/vba]

Автор - Gustav
Дата добавления - 10.01.2023 в 21:54
florallandmusic Дата: Вторник, 10.01.2023, 23:03 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Огромное СПАСИБО
 
Ответить
СообщениеОгромное СПАСИБО

Автор - florallandmusic
Дата добавления - 10.01.2023 в 23:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматизация отчета (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!