Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР с пробелами и форматом ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР с пробелами и форматом ячейки (Формулы/Formulas)
ВПР с пробелами и форматом ячейки
Snow Дата: Среда, 11.01.2023, 13:47 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 97
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007,2010
Всем привет!)
Помогите, пжл, формулой побороться с пробелами и форматами :'(
СЖПРОБЕЛЫ не работает
Никак не получается
К сообщению приложен файл: 4542932.xlsx (9.2 Kb)
 
Ответить
СообщениеВсем привет!)
Помогите, пжл, формулой побороться с пробелами и форматами :'(
СЖПРОБЕЛЫ не работает
Никак не получается

Автор - Snow
Дата добавления - 11.01.2023 в 13:47
Gustav Дата: Среда, 11.01.2023, 14:04 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2305
Репутация: 918 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
СЖПРОБЕЛЫ не работает

СЖПРОБЕЛЫ в середине строки удаляет лишние пробелы там, где их больше одного, оставляя при этом только один. У Вас ж как раз только один пробел, поэтому СЖПРОБЕЛЫ на него никак не влияет. Вам надо пробелы - либо удалить во всей "справочной" части справа (проще), либо добавить их в "запросы" слева (сложнее).


МОИ: Ник, Tip box: 41001663842605
 
Ответить
Сообщение
СЖПРОБЕЛЫ не работает

СЖПРОБЕЛЫ в середине строки удаляет лишние пробелы там, где их больше одного, оставляя при этом только один. У Вас ж как раз только один пробел, поэтому СЖПРОБЕЛЫ на него никак не влияет. Вам надо пробелы - либо удалить во всей "справочной" части справа (проще), либо добавить их в "запросы" слева (сложнее).

Автор - Gustav
Дата добавления - 11.01.2023 в 14:04
Snow Дата: Среда, 11.01.2023, 14:06 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 97
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007,2010
Если пробелы удалять через Нати и Заменить, то не работает ВПР, т.е. надо как-то и формат поменять. Работает только если оба столбца (правый и левый) вставить в ворд, а потом обратно. А перед этим убрать пробел. %)


Сообщение отредактировал Snow - Среда, 11.01.2023, 14:10
 
Ответить
СообщениеЕсли пробелы удалять через Нати и Заменить, то не работает ВПР, т.е. надо как-то и формат поменять. Работает только если оба столбца (правый и левый) вставить в ворд, а потом обратно. А перед этим убрать пробел. %)

Автор - Snow
Дата добавления - 11.01.2023 в 14:06
Gustav Дата: Среда, 11.01.2023, 14:10 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2305
Репутация: 918 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Либо искать не через ВПР, а через ИНДЕКС+ПОИСКПОЗ. Для ячейки C2 формула массива (завершение ввода по Ctrl+Shift+Enter):
Код
=ИНДЕКС($G$2:$G$7;ПОИСКПОЗ(B2;ПОДСТАВИТЬ($F$2:$F$7;" ";"");0))

И после ввода в C2 просто скопировать ячейку C2 в ячейки ниже (уже без Ctrl+Shift+Enter).


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Среда, 11.01.2023, 14:11
 
Ответить
СообщениеЛибо искать не через ВПР, а через ИНДЕКС+ПОИСКПОЗ. Для ячейки C2 формула массива (завершение ввода по Ctrl+Shift+Enter):
Код
=ИНДЕКС($G$2:$G$7;ПОИСКПОЗ(B2;ПОДСТАВИТЬ($F$2:$F$7;" ";"");0))

И после ввода в C2 просто скопировать ячейку C2 в ячейки ниже (уже без Ctrl+Shift+Enter).

Автор - Gustav
Дата добавления - 11.01.2023 в 14:10
_Boroda_ Дата: Среда, 11.01.2023, 14:11 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16559
Репутация: 6445 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ловите
Код
=ВПР(ТЕКСТ(B2;"# ##0");F:G;2;)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЛовите
Код
=ВПР(ТЕКСТ(B2;"# ##0");F:G;2;)

Автор - _Boroda_
Дата добавления - 11.01.2023 в 14:11
Snow Дата: Среда, 11.01.2023, 14:17 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 97
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007,2010
Ловите


Вы мой герой

 
Ответить
Сообщение
Ловите


Вы мой герой


Автор - Snow
Дата добавления - 11.01.2023 в 14:17
bigor Дата: Среда, 11.01.2023, 14:21 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 722
Репутация: 151 ±
Замечаний: 0% ±

нет
Попробуйте такую
Код
=INDEX($G$2:$G$7;MATCH(--B2;VALUE($F$2:$F$7);0))
 
Ответить
СообщениеПопробуйте такую
Код
=INDEX($G$2:$G$7;MATCH(--B2;VALUE($F$2:$F$7);0))

Автор - bigor
Дата добавления - 11.01.2023 в 14:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР с пробелами и форматом ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!