Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сократить кол-во студентов с баллом ниже 4 до 10% - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сократить кол-во студентов с баллом ниже 4 до 10% (Формулы/Formulas)
Сократить кол-во студентов с баллом ниже 4 до 10%
Феникс7140 Дата: Пятница, 13.01.2023, 21:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Имеем: 50% студентов имеют балл ниже 4
Нужна формула которая переведет баллы таким образом, чтоб студентов с баллом ниже 4 оказалось 10%, а не 50%
Максимальный бал должен остаться 5
Есть ли такая возможность?
К сообщению приложен файл: 2990028.xlsx(14.0 Kb)
 
Ответить
СообщениеИмеем: 50% студентов имеют балл ниже 4
Нужна формула которая переведет баллы таким образом, чтоб студентов с баллом ниже 4 оказалось 10%, а не 50%
Максимальный бал должен остаться 5
Есть ли такая возможность?

Автор - Феникс7140
Дата добавления - 13.01.2023 в 21:07
Gustav Дата: Суббота, 14.01.2023, 00:36 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2303
Репутация: 918 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
В ячейке D5 формула (минимальный балл выше нижних 10%):
Код
=НАИМЕНЬШИЙ($B$7:$B$26; 1+СЧЁТЕСЛИ($B$7:$B$26;"<="&ПЕРСЕНТИЛЬ($B$7:$B$26;10%)))

В ячейке D6 текст:
Код
Новый итоговый балл

В ячейке D7 формула (протягиваемая затем в ячейки ниже):
Код
=ЕСЛИ(B7<$D$5; B7; ОКРУГЛ(B7 + (1-(B7-$D$5)/(5-$D$5))*(4-$D$5); 2))
К сообщению приложен файл: Studen.xlsx(15.6 Kb)


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Суббота, 14.01.2023, 00:52
 
Ответить
СообщениеВ ячейке D5 формула (минимальный балл выше нижних 10%):
Код
=НАИМЕНЬШИЙ($B$7:$B$26; 1+СЧЁТЕСЛИ($B$7:$B$26;"<="&ПЕРСЕНТИЛЬ($B$7:$B$26;10%)))

В ячейке D6 текст:
Код
Новый итоговый балл

В ячейке D7 формула (протягиваемая затем в ячейки ниже):
Код
=ЕСЛИ(B7<$D$5; B7; ОКРУГЛ(B7 + (1-(B7-$D$5)/(5-$D$5))*(4-$D$5); 2))

Автор - Gustav
Дата добавления - 14.01.2023 в 00:36
Феникс7140 Дата: Суббота, 14.01.2023, 12:13 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый день
Круто посчитано, только получается не уверсальная.
Допустим необходимо не 10% сделать а 70%.
И уже не работает
Возможно необходимо что то исправить?
 
Ответить
СообщениеДобрый день
Круто посчитано, только получается не уверсальная.
Допустим необходимо не 10% сделать а 70%.
И уже не работает
Возможно необходимо что то исправить?

Автор - Феникс7140
Дата добавления - 14.01.2023 в 12:13
Gustav Дата: Суббота, 14.01.2023, 15:42 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2303
Репутация: 918 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Цитата Феникс7140, 14.01.2023 в 12:13, в сообщении № 3 ()
только получается не уверсальная.
Допустим необходимо не 10% сделать а 70%.
И уже не работает

Так сразу бы об этом сказали, можно было бы сразу и на эту тему лоб наморщить. А то квест, понимаешь, устраиваете - "один тайник нашли, а в нём записочка, где найти следующий".

Тогда уж делаем параметрическое решение с визуализацией коррекции, и меняйте, что хотите. Формулы теперь такие:

в ячейке B5 константа (пограничный балл): 4
в ячейке C5 константа (процент нижней части): 70%
в ячейке D5 формула (минимальный балл выше нижних процентов):
Код
=НАИМЕНЬШИЙ($B$7:$B$26; 1+СЧЁТЕСЛИ($B$7:$B$26;"<="&ПЕРСЕНТИЛЬ($B$7:$B$26;$C$5)))

в ячейке D6 текст: Поправка
в ячейке D7 формула (протягиваемая затем в ячейки ниже):
Код
=ОКРУГЛ((1-(B7-$D$5)/((B7>=$D$5)*5-$D$5))*($B$5-$D$5);2)

в ячейке E6 текст: Новый итоговый балл
в ячейке E7 формула (протягиваемая затем в ячейки ниже):
Код
=B7+D7
К сообщению приложен файл: Stude2.xlsx(16.0 Kb)


МОИ: Ник, Tip box: 41001663842605
 
Ответить
Сообщение
Цитата Феникс7140, 14.01.2023 в 12:13, в сообщении № 3 ()
только получается не уверсальная.
Допустим необходимо не 10% сделать а 70%.
И уже не работает

Так сразу бы об этом сказали, можно было бы сразу и на эту тему лоб наморщить. А то квест, понимаешь, устраиваете - "один тайник нашли, а в нём записочка, где найти следующий".

Тогда уж делаем параметрическое решение с визуализацией коррекции, и меняйте, что хотите. Формулы теперь такие:

в ячейке B5 константа (пограничный балл): 4
в ячейке C5 константа (процент нижней части): 70%
в ячейке D5 формула (минимальный балл выше нижних процентов):
Код
=НАИМЕНЬШИЙ($B$7:$B$26; 1+СЧЁТЕСЛИ($B$7:$B$26;"<="&ПЕРСЕНТИЛЬ($B$7:$B$26;$C$5)))

в ячейке D6 текст: Поправка
в ячейке D7 формула (протягиваемая затем в ячейки ниже):
Код
=ОКРУГЛ((1-(B7-$D$5)/((B7>=$D$5)*5-$D$5))*($B$5-$D$5);2)

в ячейке E6 текст: Новый итоговый балл
в ячейке E7 формула (протягиваемая затем в ячейки ниже):
Код
=B7+D7

Автор - Gustav
Дата добавления - 14.01.2023 в 15:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сократить кол-во студентов с баллом ниже 4 до 10% (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!