Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проверка на ноебходимое значение в ячейке - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка на ноебходимое значение в ячейке (Формулы/Formulas)
Проверка на ноебходимое значение в ячейке
ki5real5ki Дата: Воскресенье, 22.01.2023, 22:18 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Приветствую! Подскажите, пожалуйста, решая задачу столкнулся с проблемой - не могу подобрать формулу. Суть задачи - из ячеек вытащить нужные значения(имя файла, время и т.д.), а если имени файла нет - игнорировать всю строку, то есть вся строка будет пустая.

Значения я вытащил, пусть и не очень красиво, теперь какое условие поставить для имени файла(в виде формулы excel), чтобы игнорировать четыре строки(выделены зеленым)? Пытался через ЕСЛИ, ЕТЕКСТ, ЕЧИСЛО.
Заранее спасибо.
К сообщению приложен файл: 8104220.xlsx(9.8 Kb)
 
Ответить
СообщениеПриветствую! Подскажите, пожалуйста, решая задачу столкнулся с проблемой - не могу подобрать формулу. Суть задачи - из ячеек вытащить нужные значения(имя файла, время и т.д.), а если имени файла нет - игнорировать всю строку, то есть вся строка будет пустая.

Значения я вытащил, пусть и не очень красиво, теперь какое условие поставить для имени файла(в виде формулы excel), чтобы игнорировать четыре строки(выделены зеленым)? Пытался через ЕСЛИ, ЕТЕКСТ, ЕЧИСЛО.
Заранее спасибо.

Автор - ki5real5ki
Дата добавления - 22.01.2023 в 22:18
gling Дата: Воскресенье, 22.01.2023, 22:47 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2435
Репутация: 644 ±
Замечаний: 0% ±

2010
Здравствуйте.
Если расширение всегда одно, то можно так
Код
=ЕСЛИ(СЧЁТЕСЛИ(A11;"*.exe");"Формула";"")
если расширения разные, то необходимо создать базу этих расширений и использовать такую формулу
Код
=ЕСЛИ(СУММПРОИЗВ(СЧЁТЕСЛИ(A11;"*"&$J$1:$J$3));"Формула";"")
в J1:J3 база расширений.


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
Если расширение всегда одно, то можно так
Код
=ЕСЛИ(СЧЁТЕСЛИ(A11;"*.exe");"Формула";"")
если расширения разные, то необходимо создать базу этих расширений и использовать такую формулу
Код
=ЕСЛИ(СУММПРОИЗВ(СЧЁТЕСЛИ(A11;"*"&$J$1:$J$3));"Формула";"")
в J1:J3 база расширений.

Автор - gling
Дата добавления - 22.01.2023 в 22:47
ki5real5ki Дата: Понедельник, 23.01.2023, 07:16 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

gling, Спасибо, буду вникать.
 
Ответить
Сообщениеgling, Спасибо, буду вникать.

Автор - ki5real5ki
Дата добавления - 23.01.2023 в 07:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка на ноебходимое значение в ячейке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!