Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Работа с функцией СУММПРОИЗВ более чем с двумя значениями - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Работа с функцией СУММПРОИЗВ более чем с двумя значениями (Формулы/Formulas)
Работа с функцией СУММПРОИЗВ более чем с двумя значениями
OopsSorry Дата: Четверг, 16.02.2023, 17:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

Добрый день!
Нужно к уже действующей формуле добавить еще дополнительное значение которое будет учитываться при суммировании
Код
=СУММПРОИЗВ((ДЛСТР('1С'!F2:F319)-ДЛСТР(ПОДСТАВИТЬ('1С'!F2:F319;F3;"")))/ДЛСТР(F3))
по данной формуле у меня функция считает сколько раз в указанном столбце встречается заданное значение, теперь нужно добавить еще одно значение для отображения суммы из уже имеющегося значения.
К сообщению приложен файл: kopija_rabota_mastera_v02_002.xlsx (143.9 Kb)


Сообщение отредактировал OopsSorry - Четверг, 16.02.2023, 17:22
 
Ответить
СообщениеДобрый день!
Нужно к уже действующей формуле добавить еще дополнительное значение которое будет учитываться при суммировании
Код
=СУММПРОИЗВ((ДЛСТР('1С'!F2:F319)-ДЛСТР(ПОДСТАВИТЬ('1С'!F2:F319;F3;"")))/ДЛСТР(F3))
по данной формуле у меня функция считает сколько раз в указанном столбце встречается заданное значение, теперь нужно добавить еще одно значение для отображения суммы из уже имеющегося значения.

Автор - OopsSorry
Дата добавления - 16.02.2023 в 17:03
i691198 Дата: Четверг, 16.02.2023, 20:25 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 218
Репутация: 85 ±
Замечаний: 0% ±

OopsSorry, Формулу можно записать проще
Код
=СУММПРОИЗВ(--ЕЧИСЛО(НАЙТИ(F3;'1С'!$F$2:$F$377)))
Вы не пояснили что за значение нужно добавить.
 
Ответить
СообщениеOopsSorry, Формулу можно записать проще
Код
=СУММПРОИЗВ(--ЕЧИСЛО(НАЙТИ(F3;'1С'!$F$2:$F$377)))
Вы не пояснили что за значение нужно добавить.

Автор - i691198
Дата добавления - 16.02.2023 в 20:25
OopsSorry Дата: Пятница, 17.02.2023, 06:31 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

i691198, Действительно проще, думал что данная функция не сможет определить значение имеющиеся в строке "1С"F так как там имеется несколько значений. Мне нужно чтобы теперь определило сколько у Азнабакиева Ш.Н имеется граф со значением "Отменена".
 
Ответить
Сообщениеi691198, Действительно проще, думал что данная функция не сможет определить значение имеющиеся в строке "1С"F так как там имеется несколько значений. Мне нужно чтобы теперь определило сколько у Азнабакиева Ш.Н имеется граф со значением "Отменена".

Автор - OopsSorry
Дата добавления - 17.02.2023 в 06:31
gling Дата: Пятница, 17.02.2023, 07:17 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2521
Репутация: 675 ±
Замечаний: 0% ±

2010
сколько у Азнабакиева Ш.Н имеется граф со значением "Отменена".
Код
=СЧЁТЕСЛИМН('1С'!$F$1:$F$377;"*"&KPI!F3&"*";'1С'!$B$1:$B$377;"Отмена")
Переносы
Код
=СЧЁТЕСЛИМН('1С'!$F$1:$F$377;"*"&KPI!F3&"*";'1С'!$H$1:$H$377;"<>")
Гарантия
Код
=СЧЁТЕСЛИМН('1С'!$F$1:$F$377;"*"&KPI!F3&"*";'1С'!$G$1:$G$377;"Да*")
Кол-во заявок
Код
=СЧЁТЕСЛИ('1С'!$F$1:$F$377;"*"&KPI!F3&"*")


ЯД-41001506838083

Сообщение отредактировал gling - Пятница, 17.02.2023, 07:18
 
Ответить
Сообщение
сколько у Азнабакиева Ш.Н имеется граф со значением "Отменена".
Код
=СЧЁТЕСЛИМН('1С'!$F$1:$F$377;"*"&KPI!F3&"*";'1С'!$B$1:$B$377;"Отмена")
Переносы
Код
=СЧЁТЕСЛИМН('1С'!$F$1:$F$377;"*"&KPI!F3&"*";'1С'!$H$1:$H$377;"<>")
Гарантия
Код
=СЧЁТЕСЛИМН('1С'!$F$1:$F$377;"*"&KPI!F3&"*";'1С'!$G$1:$G$377;"Да*")
Кол-во заявок
Код
=СЧЁТЕСЛИ('1С'!$F$1:$F$377;"*"&KPI!F3&"*")

Автор - gling
Дата добавления - 17.02.2023 в 07:17
OopsSorry Дата: Пятница, 17.02.2023, 09:07 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

gling, Благодарю, с количеством "Отмена" все идеально работает, но с остальными функциями поспешили. Мне мне нужно так что чтобы для когда буду выводить значения "Переносы и Гарантия" "Нет отметки" не учитывалось количество со значением "Отмена".
Так же функцию по подсчету количеств переносов, я изменил на суммирование чтобы выявить значение в столбце "Сумма наловых", но так же нужно чтобы эта функция не учитывало значение "Отмена"
К сообщению приложен файл: kopija_rabota_mastera_v02_002_.xlsx (138.8 Kb)
 
Ответить
Сообщениеgling, Благодарю, с количеством "Отмена" все идеально работает, но с остальными функциями поспешили. Мне мне нужно так что чтобы для когда буду выводить значения "Переносы и Гарантия" "Нет отметки" не учитывалось количество со значением "Отмена".
Так же функцию по подсчету количеств переносов, я изменил на суммирование чтобы выявить значение в столбце "Сумма наловых", но так же нужно чтобы эта функция не учитывало значение "Отмена"

Автор - OopsSorry
Дата добавления - 17.02.2023 в 09:07
Nic70y Дата: Пятница, 17.02.2023, 10:09 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
не учитывало значение "Отмена"
Код
;'1С'!$B$1:$B$377;"<>Отменена")


ЮMoney 41001841029809
 
Ответить
Сообщение
не учитывало значение "Отмена"
Код
;'1С'!$B$1:$B$377;"<>Отменена")

Автор - Nic70y
Дата добавления - 17.02.2023 в 10:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Работа с функцией СУММПРОИЗВ более чем с двумя значениями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!