Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Соединить все данные из выпадающих списков в ячейку - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Соединить все данные из выпадающих списков в ячейку
djonikage22 Дата: Суббота, 18.02.2023, 17:51 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

microsoft office ltsc 2021
Доброго времени суток

нужна функция

данные из выпадающих поместить в ячейку результат через запятую и пробел если ячейка пуста то не ставить запятую и пробел в полях ячеек с желтыми названии подставлять префикс который ниже (--seed) из ячейки с названием кластер в результате выводить значение справа от варианта из списка в листе Data .при нажатии на кнопку копировать копировать результат в буфер обмена при нажатии кнопки очистить очищают все ячейки

должно получится вроде этого promter

Ссылка на тему на другом форуме
К сообщению приложен файл: promter_test.xlsx (72.3 Kb)


Сообщение отредактировал djonikage22 - Суббота, 18.02.2023, 19:00
 
Ответить
СообщениеДоброго времени суток

нужна функция

данные из выпадающих поместить в ячейку результат через запятую и пробел если ячейка пуста то не ставить запятую и пробел в полях ячеек с желтыми названии подставлять префикс который ниже (--seed) из ячейки с названием кластер в результате выводить значение справа от варианта из списка в листе Data .при нажатии на кнопку копировать копировать результат в буфер обмена при нажатии кнопки очистить очищают все ячейки

должно получится вроде этого promter

Ссылка на тему на другом форуме

Автор - djonikage22
Дата добавления - 18.02.2023 в 17:51
bmv98rus Дата: Суббота, 18.02.2023, 18:10 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4111
Репутация: 769 ±
Замечаний: 0% ±

Excel 2013/2016
как бы еще все темы объединить на одном форуме. Кросс


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениекак бы еще все темы объединить на одном форуме. Кросс

Автор - bmv98rus
Дата добавления - 18.02.2023 в 18:10
djonikage22 Дата: Суббота, 18.02.2023, 18:18 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

microsoft office ltsc 2021
bmv98rus, не совсем понял ответ вроде разные форумы


Сообщение отредактировал djonikage22 - Суббота, 18.02.2023, 18:19
 
Ответить
Сообщениеbmv98rus, не совсем понял ответ вроде разные форумы

Автор - djonikage22
Дата добавления - 18.02.2023 в 18:18
bmv98rus Дата: Суббота, 18.02.2023, 18:41 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4111
Репутация: 769 ±
Замечаний: 0% ±

Excel 2013/2016
вроде разные форумы
не вроде а разные и в правилах есть про то что нужно об это сообщать.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
вроде разные форумы
не вроде а разные и в правилах есть про то что нужно об это сообщать.

Автор - bmv98rus
Дата добавления - 18.02.2023 в 18:41
djonikage22 Дата: Суббота, 18.02.2023, 19:00 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

microsoft office ltsc 2021
bmv98rus, исправил
 
Ответить
Сообщениеbmv98rus, исправил

Автор - djonikage22
Дата добавления - 18.02.2023 в 19:00
djonikage22 Дата: Суббота, 18.02.2023, 19:02 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

microsoft office ltsc 2021
bmv98rus, исправил
 
Ответить
Сообщениеbmv98rus, исправил

Автор - djonikage22
Дата добавления - 18.02.2023 в 19:02
djonikage22 Дата: Воскресенье, 19.02.2023, 02:24 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

microsoft office ltsc 2021
=ЕСЛИ(И(ЕПУСТО(B5);ЕПУСТО(B9);ЕПУСТО(F9);ЕПУСТО(J9);ЕПУСТО(N9);ЕПУСТО(B15);ЕПУСТО(F15);ЕПУСТО(J15);ЕПУСТО(N15);ЕПУСТО(N20);ЕПУСТО(B20);ЕПУСТО(E20);ЕПУСТО(H20);ЕПУСТО(K20);ЕПУСТО(J3));"";СЦЕПИТЬЕСЛИ(B5
<>"";B5&"; ";"")&СЦЕПИТЬЕСЛИ(B9<>"";B9&"; ";"")&СЦЕПИТЬЕСЛИ(F9<>"";F9&"; ";"")&СЦЕПИТЬЕСЛИ(J9<>"";J9&";
";"")&СЦЕПИТЬЕСЛИ(N9<>"";N9&"; ";"")&СЦЕПИТЬЕСЛИ(B15<>"";B15&"; ";"")&СЦЕПИТЬЕСЛИ(F15<>"";F15&";
";"")&СЦЕПИТЬЕСЛИ(J15<>"";J15&"; ";"")&СЦЕПИТЬЕСЛИ(N15<>"";N15&"; ";"")&СЦЕПИТЬЕСЛИ(N20<>"";N20&";
";"")&СЦЕПИТЬЕСЛИ(B20<>"";B20&"; ";"")&СЦЕПИТЬЕСЛИ(E20<>"";E20&"; ";"")&СЦЕПИТЬЕСЛИ(H20<>"";H20&";
";"")&СЦЕПИТЬЕСЛИ(K20<>"";K20&"; ";"")&СЦЕПИТЬЕСЛИ(J3<>"";J3&"; ";""))
 
Ответить
Сообщение=ЕСЛИ(И(ЕПУСТО(B5);ЕПУСТО(B9);ЕПУСТО(F9);ЕПУСТО(J9);ЕПУСТО(N9);ЕПУСТО(B15);ЕПУСТО(F15);ЕПУСТО(J15);ЕПУСТО(N15);ЕПУСТО(N20);ЕПУСТО(B20);ЕПУСТО(E20);ЕПУСТО(H20);ЕПУСТО(K20);ЕПУСТО(J3));"";СЦЕПИТЬЕСЛИ(B5
<>"";B5&"; ";"")&СЦЕПИТЬЕСЛИ(B9<>"";B9&"; ";"")&СЦЕПИТЬЕСЛИ(F9<>"";F9&"; ";"")&СЦЕПИТЬЕСЛИ(J9<>"";J9&";
";"")&СЦЕПИТЬЕСЛИ(N9<>"";N9&"; ";"")&СЦЕПИТЬЕСЛИ(B15<>"";B15&"; ";"")&СЦЕПИТЬЕСЛИ(F15<>"";F15&";
";"")&СЦЕПИТЬЕСЛИ(J15<>"";J15&"; ";"")&СЦЕПИТЬЕСЛИ(N15<>"";N15&"; ";"")&СЦЕПИТЬЕСЛИ(N20<>"";N20&";
";"")&СЦЕПИТЬЕСЛИ(B20<>"";B20&"; ";"")&СЦЕПИТЬЕСЛИ(E20<>"";E20&"; ";"")&СЦЕПИТЬЕСЛИ(H20<>"";H20&";
";"")&СЦЕПИТЬЕСЛИ(K20<>"";K20&"; ";"")&СЦЕПИТЬЕСЛИ(J3<>"";J3&"; ";""))

Автор - djonikage22
Дата добавления - 19.02.2023 в 02:24
djonikage22 Дата: Воскресенье, 19.02.2023, 02:25 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

microsoft office ltsc 2021
ChartGPT дал ответ но где то ошибка excel пишет недопустимое имя может кто поправит
 
Ответить
СообщениеChartGPT дал ответ но где то ошибка excel пишет недопустимое имя может кто поправит

Автор - djonikage22
Дата добавления - 19.02.2023 в 02:25
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!