Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определить оператора и регион по номеру телефона - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить оператора и регион по номеру телефона (Формулы/Formulas)
Определить оператора и регион по номеру телефона
micbr777 Дата: Вторник, 21.02.2023, 13:47 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 40% ±

Доброго времени суток всем ! Помогите с задачей, нужно определить какой где оператор и регион ( если это возможно) как то, по префиксам в номере
Кто делал может так? Информация ведь про операторы есть и по префиксам можно поняфть где какой оператор и скакого региона. Помогите плиз
К сообщению приложен файл: test_2.xlsx (8.7 Kb)
 
Ответить
СообщениеДоброго времени суток всем ! Помогите с задачей, нужно определить какой где оператор и регион ( если это возможно) как то, по префиксам в номере
Кто делал может так? Информация ведь про операторы есть и по префиксам можно поняфть где какой оператор и скакого региона. Помогите плиз

Автор - micbr777
Дата добавления - 21.02.2023 в 13:47
Serge_007 Дата: Вторник, 21.02.2023, 14:14 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Вы форумом не ошиблись?
Тут по Excel задачи решаются
Извлечь префикс:
Код
=ПСТР(A2;2;3)
, а вот дальше - делайте таблицу соответствий префиксов и операторов с регионами
Тогда поможем с формулами


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеВы форумом не ошиблись?
Тут по Excel задачи решаются
Извлечь префикс:
Код
=ПСТР(A2;2;3)
, а вот дальше - делайте таблицу соответствий префиксов и операторов с регионами
Тогда поможем с формулами

Автор - Serge_007
Дата добавления - 21.02.2023 в 14:14
micbr777 Дата: Понедельник, 06.03.2023, 18:00 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 40% ±

Serge_007, Вот сделал такой файл, незнаю или он поможет решить вопрос
К сообщению приложен файл: prefiksy.xlsx (12.5 Kb)
 
Ответить
СообщениеSerge_007, Вот сделал такой файл, незнаю или он поможет решить вопрос

Автор - micbr777
Дата добавления - 06.03.2023 в 18:00
micbr777 Дата: Понедельник, 06.03.2023, 18:10 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 40% ±

Помогите кто что знает, тема актуальная


Сообщение отредактировал micbr777 - Понедельник, 06.03.2023, 18:10
 
Ответить
СообщениеПомогите кто что знает, тема актуальная

Автор - micbr777
Дата добавления - 06.03.2023 в 18:10
Pelena Дата: Понедельник, 06.03.2023, 19:08 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 19179
Репутация: 4418 ±
Замечаний: ±

Excel 365 & Mac Excel
Код
=ЕСЛИОШИБКА(ВПР(--ПСТР(A2;2;3);Операторы!$A$1:$C$67;2;0);"не найден")
К сообщению приложен файл: 8636555.xlsx (16.0 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ВПР(--ПСТР(A2;2;3);Операторы!$A$1:$C$67;2;0);"не найден")

Автор - Pelena
Дата добавления - 06.03.2023 в 19:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить оператора и регион по номеру телефона (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!