Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как найти значание при нескольких таблиц и условиях? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как найти значание при нескольких таблиц и условиях? (Формулы/Formulas)
Как найти значание при нескольких таблиц и условиях?
irinasuhoveewa Дата: Вторник, 28.02.2023, 16:32 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте!
Подскажите формулу, как сделать, чтоб по слову "магазин" в тексте, формула его определяла, далее в зависимости от города Москва или любой другой выбирала данные из другой таблицы и считала значение? Если нет слова магазин, то было пусто.
Например МЦ Красная площадь (магазин) и город Москва1, то 4*2=8 или ТЦ Нижний Новгород (магазин) и город Н. Новгород 4*3=12.
К сообщению приложен файл: book3.xlsx (9.2 Kb)
 
Ответить
СообщениеЗдравствуйте!
Подскажите формулу, как сделать, чтоб по слову "магазин" в тексте, формула его определяла, далее в зависимости от города Москва или любой другой выбирала данные из другой таблицы и считала значение? Если нет слова магазин, то было пусто.
Например МЦ Красная площадь (магазин) и город Москва1, то 4*2=8 или ТЦ Нижний Новгород (магазин) и город Н. Новгород 4*3=12.

Автор - irinasuhoveewa
Дата добавления - 28.02.2023 в 16:32
Serge_007 Дата: Вторник, 28.02.2023, 16:44 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Здравствуйте
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("москва";B2));2;3)*ЕЧИСЛО(НАЙТИ("магазин";A2))*C2


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("москва";B2));2;3)*ЕЧИСЛО(НАЙТИ("магазин";A2))*C2

Автор - Serge_007
Дата добавления - 28.02.2023 в 16:44
bigor Дата: Вторник, 28.02.2023, 16:47 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1116
Репутация: 212 ±
Замечаний: 0% ±

нет
irinasuhoveewa, было похожее
 
Ответить
Сообщениеirinasuhoveewa, было похожее

Автор - bigor
Дата добавления - 28.02.2023 в 16:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как найти значание при нескольких таблиц и условиях? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!