Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор из двух разных таблиц - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор из двух разных таблиц (Формулы/Formulas)
Выбор из двух разных таблиц
ПАМ Дата: Вторник, 28.02.2023, 16:42 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 280
Репутация: 11 ±
Замечаний: 20% ±

Excel 2010, Excel 2016
Здравствуйте!
Уважаемые форумчане, помогите пожалуйста мне разобраться с такой задачей.

Имеется две таблицы исходных данных и часовые интервалы поделенные на дневные и ночные. Мне нужно, чтобы в таблице итог отображалось согласно распределению по часовым интервалам. То есть если интервал стоит в столбце день то значения брать из первых исходных данных, иначе из вторых. Сложность (для меня) в том, что интервалы могут идти подряд а могут в различном порядке как в примере.

Очень прошу помочь мне разобраться, пожалуйста. Спасибо всем!
К сообщению приложен файл: 1454738.xlsx (10.2 Kb)
 
Ответить
СообщениеЗдравствуйте!
Уважаемые форумчане, помогите пожалуйста мне разобраться с такой задачей.

Имеется две таблицы исходных данных и часовые интервалы поделенные на дневные и ночные. Мне нужно, чтобы в таблице итог отображалось согласно распределению по часовым интервалам. То есть если интервал стоит в столбце день то значения брать из первых исходных данных, иначе из вторых. Сложность (для меня) в том, что интервалы могут идти подряд а могут в различном порядке как в примере.

Очень прошу помочь мне разобраться, пожалуйста. Спасибо всем!

Автор - ПАМ
Дата добавления - 28.02.2023 в 16:42
Nic70y Дата: Вторник, 28.02.2023, 16:50 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8667
Репутация: 2221 ±
Замечаний: 0% ±

Excel 2010
так
Код
=ЕСЛИ(СУММПРОИЗВ(МАКС(($Z3:$AA26=A14)*СТОЛБЕЦ($Z3:$AA26)))-26;A9;A3)
надо?
К сообщению приложен файл: 14.xlsx (10.8 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениетак
Код
=ЕСЛИ(СУММПРОИЗВ(МАКС(($Z3:$AA26=A14)*СТОЛБЕЦ($Z3:$AA26)))-26;A9;A3)
надо?

Автор - Nic70y
Дата добавления - 28.02.2023 в 16:50
Serge_007 Дата: Вторник, 28.02.2023, 16:50 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16453
Репутация: 2746 ±
Замечаний: ±

Excel 2016
Здравствуйте

Код
=ЕСЛИОШИБКА(ИНДЕКС($A3:$X3;;ПОИСКПОЗ(A14;$Z3:$Z26;));ИНДЕКС($A9:$X9;;ПОИСКПОЗ(A14;$AA3:$AA26;)))


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ЕСЛИОШИБКА(ИНДЕКС($A3:$X3;;ПОИСКПОЗ(A14;$Z3:$Z26;));ИНДЕКС($A9:$X9;;ПОИСКПОЗ(A14;$AA3:$AA26;)))

Автор - Serge_007
Дата добавления - 28.02.2023 в 16:50
ПАМ Дата: Вторник, 28.02.2023, 16:52 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 280
Репутация: 11 ±
Замечаний: 20% ±

Excel 2010, Excel 2016
Nic70y, Спасибо огромное, очень похоже! Сейчас в большом файле проверю.
 
Ответить
СообщениеNic70y, Спасибо огромное, очень похоже! Сейчас в большом файле проверю.

Автор - ПАМ
Дата добавления - 28.02.2023 в 16:52
ПАМ Дата: Вторник, 28.02.2023, 16:53 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 280
Репутация: 11 ±
Замечаний: 20% ±

Excel 2010, Excel 2016
Serge_007, Ваш ответ чуть позже заметил. Вам тоже огромное Спасибо
 
Ответить
СообщениеSerge_007, Ваш ответ чуть позже заметил. Вам тоже огромное Спасибо

Автор - ПАМ
Дата добавления - 28.02.2023 в 16:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор из двух разных таблиц (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!