Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Префикс по максимальному значению - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Префикс по максимальному значению (Формулы/Formulas)
Префикс по максимальному значению
Gopronotmore Дата: Вторник, 28.02.2023, 21:38 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 199
Репутация: 3 ±
Замечаний: 0% ±

Excel 2007
Ребят, подскажите никогда не сталкивался, но думаю что решается просто

У меня есть значения числовые, как сделать так, что бы префикс ставился начиная с 1 и до максимального заданного значения.

Файл во вложении

Заранее спасибо
К сообщению приложен файл: zadachka.xlsx (9.0 Kb)
 
Ответить
СообщениеРебят, подскажите никогда не сталкивался, но думаю что решается просто

У меня есть значения числовые, как сделать так, что бы префикс ставился начиная с 1 и до максимального заданного значения.

Файл во вложении

Заранее спасибо

Автор - Gopronotmore
Дата добавления - 28.02.2023 в 21:38
Gopronotmore Дата: Вторник, 28.02.2023, 21:44 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 199
Репутация: 3 ±
Замечаний: 0% ±

Excel 2007
Вместо значений a1 a2 a3 a4 a5 и других они должны строиться начиная с 1 и до максимального значения
 
Ответить
СообщениеВместо значений a1 a2 a3 a4 a5 и других они должны строиться начиная с 1 и до максимального значения

Автор - Gopronotmore
Дата добавления - 28.02.2023 в 21:44
i691198 Дата: Вторник, 28.02.2023, 22:01 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 204
Репутация: 83 ±
Замечаний: 0% ±

Не уверен, что точно понял. Вариант с условным форматированием.
К сообщению приложен файл: zadachka_1.xlsx (9.8 Kb)
 
Ответить
СообщениеНе уверен, что точно понял. Вариант с условным форматированием.

Автор - i691198
Дата добавления - 28.02.2023 в 22:01
Gopronotmore Дата: Вторник, 28.02.2023, 22:07 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 199
Репутация: 3 ±
Замечаний: 0% ±

Excel 2007
Мне нужно что бы значения появлялись с 1 до 5, другими словами есть число максимально например 5, как выстроить по порядку значения что бы появились с 1 до 5, если максимальное 8 то с 1 до 8
 
Ответить
СообщениеМне нужно что бы значения появлялись с 1 до 5, другими словами есть число максимально например 5, как выстроить по порядку значения что бы появились с 1 до 5, если максимальное 8 то с 1 до 8

Автор - Gopronotmore
Дата добавления - 28.02.2023 в 22:07
Gopronotmore Дата: Вторник, 28.02.2023, 22:17 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 199
Репутация: 3 ±
Замечаний: 0% ±

Excel 2007
Вот может так понятнее будет, с буквами не надо, пока так бы выстроить, желательно без массива
К сообщению приложен файл: primer1.xlsx (9.0 Kb)
 
Ответить
СообщениеВот может так понятнее будет, с буквами не надо, пока так бы выстроить, желательно без массива

Автор - Gopronotmore
Дата добавления - 28.02.2023 в 22:17
прохожий2019 Дата: Вторник, 28.02.2023, 22:23 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1240
Репутация: 317 ±
Замечаний: 0% ±

365 Beta Channel
Код
=ЕСЛИ(E2<$C$3;E2+1;"")
К сообщению приложен файл: 5981847.xlsx (9.5 Kb)
 
Ответить
Сообщение
Код
=ЕСЛИ(E2<$C$3;E2+1;"")

Автор - прохожий2019
Дата добавления - 28.02.2023 в 22:23
китин Дата: Среда, 01.03.2023, 08:59 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 7011
Репутация: 1073 ±
Замечаний: 0% ±

Excel 2007;2010;2016
может так?
Код
=ЕСЛИ(СТРОКА(A1)>$C$2;0;$D$2&МИН(СТРОКА(A1);$C$2))
К сообщению приложен файл: zadachka33.xlsx (9.8 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениеможет так?
Код
=ЕСЛИ(СТРОКА(A1)>$C$2;0;$D$2&МИН(СТРОКА(A1);$C$2))

Автор - китин
Дата добавления - 01.03.2023 в 08:59
Egyptian Дата: Среда, 01.03.2023, 09:06 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 512
Репутация: 184 ±
Замечаний: 0% ±

Excel 2013/2016
Вариант.
Код
=IF((COLUMN()-5)<$C2;$D2&COLUMN()-4;"")
К сообщению приложен файл: 9743398.xlsx (10.1 Kb)
 
Ответить
СообщениеВариант.
Код
=IF((COLUMN()-5)<$C2;$D2&COLUMN()-4;"")

Автор - Egyptian
Дата добавления - 01.03.2023 в 09:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Префикс по максимальному значению (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!