Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение актуальности акции по дате старта - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение актуальности акции по дате старта (Формулы/Formulas)
Определение актуальности акции по дате старта
dobrodeeva1 Дата: Четверг, 02.03.2023, 17:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день. Есть некий массив данных с информацией про действующие акции. Одна и та же позиция может учувствовать в двух акциях одновременно, но одна акция актуальная а другая нет (актуальная - у которой позже дата старта). Подскажите, пожалуйста, какую формулу прописать, чтобы автоматически определялась актуальность или неактуальность позиции. Файл во вложении, заранее спасибо!
К сообщению приложен файл: forum.xlsx (9.2 Kb)
 
Ответить
СообщениеДобрый день. Есть некий массив данных с информацией про действующие акции. Одна и та же позиция может учувствовать в двух акциях одновременно, но одна акция актуальная а другая нет (актуальная - у которой позже дата старта). Подскажите, пожалуйста, какую формулу прописать, чтобы автоматически определялась актуальность или неактуальность позиции. Файл во вложении, заранее спасибо!

Автор - dobrodeeva1
Дата добавления - 02.03.2023 в 17:12
Nic70y Дата: Четверг, 02.03.2023, 17:19 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8748
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010
как-то так
Код
=ЕСЛИ(СУММПРОИЗВ(МАКС((B2=$B$2:$B$3)*("Действует"=$G$2:$G$3)*$E$2:$E$3))=E2;"Актуальная";"Неактульная ")
наверное
К сообщению приложен файл: 120.xlsx (9.3 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениекак-то так
Код
=ЕСЛИ(СУММПРОИЗВ(МАКС((B2=$B$2:$B$3)*("Действует"=$G$2:$G$3)*$E$2:$E$3))=E2;"Актуальная";"Неактульная ")
наверное

Автор - Nic70y
Дата добавления - 02.03.2023 в 17:19
Gustav Дата: Четверг, 02.03.2023, 17:22 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2726
Репутация: 1128 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Или как-то так изящненько (в лучших традициях Александра _Boroda_) для ячейки G2:
Код
=ЕСЛИ(МЕДИАНА(E2;F2;$J$1)=$J$1;"Действует";"НЕ действует")

P.S. Ааа, я, наверное, не про ту колонку подумал. Извиняюсь! Но формула все равно лучше, чем была :)


МОИ: Ник, Tip box: 41001663842605

Сообщение отредактировал Gustav - Четверг, 02.03.2023, 17:26
 
Ответить
СообщениеИли как-то так изящненько (в лучших традициях Александра _Boroda_) для ячейки G2:
Код
=ЕСЛИ(МЕДИАНА(E2;F2;$J$1)=$J$1;"Действует";"НЕ действует")

P.S. Ааа, я, наверное, не про ту колонку подумал. Извиняюсь! Но формула все равно лучше, чем была :)

Автор - Gustav
Дата добавления - 02.03.2023 в 17:22
dobrodeeva1 Дата: Четверг, 02.03.2023, 17:42 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Спасибо большое всем! Очень выручили :hello:
 
Ответить
СообщениеСпасибо большое всем! Очень выручили :hello:

Автор - dobrodeeva1
Дата добавления - 02.03.2023 в 17:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение актуальности акции по дате старта (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!