Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Исключение использованных значений при поиске через ПОИСКПОЗ - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Исключение использованных значений при поиске через ПОИСКПОЗ
tarasovgeorgij230 Дата: Пятница, 03.03.2023, 19:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!
Нужно отобрать пять дисциплин с наибольшим количеством неаттестованных студентов и вывести в в таблицу название дисциплины и количество неаттестованных студентов. Поиск названия дисциплины пытался сделать с помощью формулы
Код
=ИНДЕКС($C$3:$BD$3;ПОИСКПОЗ(O52;$C$48:$BB$48;-1))
. Но из-за наличия одинакового количества неаттестованных студентов на разных дисциплинах возникает ошибка и формула подставляет первое значение соответствующее заданным условиям. Как исключить название дисциплины с таким же количеством неаттестованных студентов, которая была найдена раньше? Количество неаттестованных студентов находится в строке "Нулей".
Буду очень благодарен за помощь!
К сообщению приложен файл: shablon_svodnoj_vedomosti_teku.xlsx (29.2 Kb)
 
Ответить
СообщениеДобрый день!
Нужно отобрать пять дисциплин с наибольшим количеством неаттестованных студентов и вывести в в таблицу название дисциплины и количество неаттестованных студентов. Поиск названия дисциплины пытался сделать с помощью формулы
Код
=ИНДЕКС($C$3:$BD$3;ПОИСКПОЗ(O52;$C$48:$BB$48;-1))
. Но из-за наличия одинакового количества неаттестованных студентов на разных дисциплинах возникает ошибка и формула подставляет первое значение соответствующее заданным условиям. Как исключить название дисциплины с таким же количеством неаттестованных студентов, которая была найдена раньше? Количество неаттестованных студентов находится в строке "Нулей".
Буду очень благодарен за помощь!

Автор - tarasovgeorgij230
Дата добавления - 03.03.2023 в 19:12
bmv98rus Дата: Пятница, 03.03.2023, 19:44 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4111
Репутация: 769 ±
Замечаний: 0% ±

Excel 2013/2016
Массивная
Код
=INDEX($3:$3;SMALL(IF(O51=$C$48:$BB$48;COLUMN($C$48:$BB$48));COUNTIF(O$50:O51;O51)))


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Пятница, 03.03.2023, 19:44
 
Ответить
СообщениеМассивная
Код
=INDEX($3:$3;SMALL(IF(O51=$C$48:$BB$48;COLUMN($C$48:$BB$48));COUNTIF(O$50:O51;O51)))

Автор - bmv98rus
Дата добавления - 03.03.2023 в 19:44
tarasovgeorgij230 Дата: Понедельник, 06.03.2023, 09:09 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

bmv98rus, Формула подставляет название дисциплины с наименьшим количеством неаттестованных студентов вне зависимости от количества неаттестованных студентов, указанных в следующем столбце. В конечном виде результат вычислений должен быть как в файле во вложении
К сообщению приложен файл: 7954149.xlsx (29.1 Kb)
 
Ответить
Сообщениеbmv98rus, Формула подставляет название дисциплины с наименьшим количеством неаттестованных студентов вне зависимости от количества неаттестованных студентов, указанных в следующем столбце. В конечном виде результат вычислений должен быть как в файле во вложении

Автор - tarasovgeorgij230
Дата добавления - 06.03.2023 в 09:09
Nic70y Дата: Понедельник, 06.03.2023, 09:30 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8831
Репутация: 2300 ±
Замечаний: 0% ±

Excel 2010
Код
=ИНДЕКС(C$3:BB$3;ЕСЛИ(O51<>O50;ПОИСКПОЗ(O51;C$48:BB$48;);ПОИСКПОЗ(O51;ИНДЕКС(C$48:BB$48;ПОИСКПОЗ(F50;C$3:BB$3;)+1):BB$48;)+ПОИСКПОЗ(F50;C$3:BB$3;)))
не массивная
К сообщению приложен файл: 216.xlsx (31.8 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС(C$3:BB$3;ЕСЛИ(O51<>O50;ПОИСКПОЗ(O51;C$48:BB$48;);ПОИСКПОЗ(O51;ИНДЕКС(C$48:BB$48;ПОИСКПОЗ(F50;C$3:BB$3;)+1):BB$48;)+ПОИСКПОЗ(F50;C$3:BB$3;)))
не массивная

Автор - Nic70y
Дата добавления - 06.03.2023 в 09:30
bigor Дата: Понедельник, 06.03.2023, 09:57 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1136
Репутация: 215 ±
Замечаний: 0% ±

нет
tarasovgeorgij230, а как вы это получили? Формула bmv98rus, выбирает по порядку следования дисциплины с одинаковым количеством неаттестованных студентов, а вы почему то Биологию почв проигнорировали
 
Ответить
Сообщениеtarasovgeorgij230, а как вы это получили? Формула bmv98rus, выбирает по порядку следования дисциплины с одинаковым количеством неаттестованных студентов, а вы почему то Биологию почв проигнорировали

Автор - bigor
Дата добавления - 06.03.2023 в 09:57
tarasovgeorgij230 Дата: Понедельник, 06.03.2023, 15:13 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, спасибо большое! Формула работает ка нужно!
 
Ответить
СообщениеNic70y, спасибо большое! Формула работает ка нужно!

Автор - tarasovgeorgij230
Дата добавления - 06.03.2023 в 15:13
tarasovgeorgij230 Дата: Понедельник, 06.03.2023, 15:14 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

bigor, Биологию почв пропустил, прошу прошения!
 
Ответить
Сообщениеbigor, Биологию почв пропустил, прошу прошения!

Автор - tarasovgeorgij230
Дата добавления - 06.03.2023 в 15:14
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!