Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор данных по двум критериям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор данных по двум критериям (Формулы/Formulas)
Выбор данных по двум критериям
DrMini Дата: Суббота, 04.03.2023, 10:50 | Сообщение № 1
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Доброго времени суток форумчане и гости форума.
Помогите пожалуйста уменьшить формулу. Моих знаний явно не хватает.
Требуется вывести данные расхода топлива в ячейке Расход топлива (выделил жёлтым) в зависимости от выбранной модели транспорта в ячейке Наименование и даты в ячейке Дата. Расход топлива будет разным в зависимости от того попадает или нет выбранная дата на диапазон листа ЛА G2:H2
К сообщению приложен файл: Test.xlsx (13.5 Kb)
 
Ответить
СообщениеДоброго времени суток форумчане и гости форума.
Помогите пожалуйста уменьшить формулу. Моих знаний явно не хватает.
Требуется вывести данные расхода топлива в ячейке Расход топлива (выделил жёлтым) в зависимости от выбранной модели транспорта в ячейке Наименование и даты в ячейке Дата. Расход топлива будет разным в зависимости от того попадает или нет выбранная дата на диапазон листа ЛА G2:H2

Автор - DrMini
Дата добавления - 04.03.2023 в 10:50
cmivadwot Дата: Суббота, 04.03.2023, 11:15 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 458
Репутация: 86 ±
Замечаний: 0% ±

365
DrMini, Доброго.. может так?
К сообщению приложен файл: 6722381.xlsx (13.6 Kb)
 
Ответить
СообщениеDrMini, Доброго.. может так?

Автор - cmivadwot
Дата добавления - 04.03.2023 в 11:15
DrMini Дата: Суббота, 04.03.2023, 11:34 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
может так?

Так.
Ваша формула работает.
Большое спасибо.


Сообщение отредактировал DrMini - Суббота, 04.03.2023, 11:45
 
Ответить
Сообщение
может так?

Так.
Ваша формула работает.
Большое спасибо.

Автор - DrMini
Дата добавления - 04.03.2023 в 11:34
bmv98rus Дата: Суббота, 04.03.2023, 15:23 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4111
Репутация: 768 ±
Замечаний: 0% ±

Excel 2013/2016
Ну тогда и эта подойдет
Код
=VLOOKUP(B2;ЛА!A2:F6;6-AND(A2>=ЛА!G2;A2<=ЛА!H2);)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Суббота, 04.03.2023, 19:33
 
Ответить
СообщениеНу тогда и эта подойдет
Код
=VLOOKUP(B2;ЛА!A2:F6;6-AND(A2>=ЛА!G2;A2<=ЛА!H2);)

Автор - bmv98rus
Дата добавления - 04.03.2023 в 15:23
DrMini Дата: Суббота, 04.03.2023, 18:40 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
тогда и эта подойдет

Не. не подошла.
Если выбрать аварийная служба 3035GE, выдаёт #Н/Д. И скобку подправил и... не пойму, как работает. Почему отнимаем
Код
-И(A2>=ЛА!G2;A2<=ЛА!H2)
 
Ответить
Сообщение
тогда и эта подойдет

Не. не подошла.
Если выбрать аварийная служба 3035GE, выдаёт #Н/Д. И скобку подправил и... не пойму, как работает. Почему отнимаем
Код
-И(A2>=ЛА!G2;A2<=ЛА!H2)

Автор - DrMini
Дата добавления - 04.03.2023 в 18:40
cmivadwot Дата: Суббота, 04.03.2023, 19:15 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 458
Репутация: 86 ±
Замечаний: 0% ±

365
DrMini,
Код
=ВПР(B2;ЛА!A2:F6;ЕСЛИ(И(A2>=ЛА!G2;A2<=ЛА!H2);5;6);ЛОЖЬ)


Сообщение отредактировал cmivadwot - Суббота, 04.03.2023, 19:16
 
Ответить
СообщениеDrMini,
Код
=ВПР(B2;ЛА!A2:F6;ЕСЛИ(И(A2>=ЛА!G2;A2<=ЛА!H2);5;6);ЛОЖЬ)

Автор - cmivadwot
Дата добавления - 04.03.2023 в 19:15
cmivadwot Дата: Суббота, 04.03.2023, 19:19 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 458
Репутация: 86 ±
Замечаний: 0% ±

365
Не. не подошла.
Если выбрать аварийная служба 3035GE, выдаёт #Н/Д. И скобку подправил и... не пойму, как работает. Почему отнимаем

Код
=ВПР(B2;ЛА!A2:F6;6-И(A2>=ЛА!G2;A2<=ЛА!H2);ЛОЖЬ)
К сообщению приложен файл: 7747474747474.xlsx (13.6 Kb)


Сообщение отредактировал cmivadwot - Суббота, 04.03.2023, 19:21
 
Ответить
Сообщение
Не. не подошла.
Если выбрать аварийная служба 3035GE, выдаёт #Н/Д. И скобку подправил и... не пойму, как работает. Почему отнимаем

Код
=ВПР(B2;ЛА!A2:F6;6-И(A2>=ЛА!G2;A2<=ЛА!H2);ЛОЖЬ)

Автор - cmivadwot
Дата добавления - 04.03.2023 в 19:19
bmv98rus Дата: Суббота, 04.03.2023, 19:32 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4111
Репутация: 768 ±
Замечаний: 0% ±

Excel 2013/2016
не пойму, как работает. Почему отнимаем
при выполнении условия от 6 отнимается 1 соответвенно или 6 или 5й столбец.
Код
=VLOOKUP(B2;ЛА!A2:F6;6-AND(A2>=ЛА!G2;A2<=ЛА!H2);)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
не пойму, как работает. Почему отнимаем
при выполнении условия от 6 отнимается 1 соответвенно или 6 или 5й столбец.
Код
=VLOOKUP(B2;ЛА!A2:F6;6-AND(A2>=ЛА!G2;A2<=ЛА!H2);)

Автор - bmv98rus
Дата добавления - 04.03.2023 в 19:32
DrMini Дата: Суббота, 04.03.2023, 19:37 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
от 6 отнимается 1

Всё стало понятно. Ещё раз спасибо.
 
Ответить
Сообщение
от 6 отнимается 1

Всё стало понятно. Ещё раз спасибо.

Автор - DrMini
Дата добавления - 04.03.2023 в 19:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор данных по двум критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!