Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнив 3 столбца, вывести сумму значений - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Сравнив 3 столбца, вывести сумму значений
filllin9425 Дата: Воскресенье, 05.03.2023, 20:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Доброго всем времени суток! Помогите, пожалуйста, решить задачу с суммированием значений, сравнив 3 столбца. Заранее благодарен.
К сообщению приложен файл: ivan_petrov.xls (31.0 Kb)
 
Ответить
СообщениеДоброго всем времени суток! Помогите, пожалуйста, решить задачу с суммированием значений, сравнив 3 столбца. Заранее благодарен.

Автор - filllin9425
Дата добавления - 05.03.2023 в 20:14
DrMini Дата: Воскресенье, 05.03.2023, 20:37 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1679
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Так?
Код
=СУММПРОИЗВ((A1:A7="Петров")*(B1:B7="Иван");C1:C7)
 
Ответить
СообщениеТак?
Код
=СУММПРОИЗВ((A1:A7="Петров")*(B1:B7="Иван");C1:C7)

Автор - DrMini
Дата добавления - 05.03.2023 в 20:37
bigor Дата: Воскресенье, 05.03.2023, 20:55 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1119
Репутация: 212 ±
Замечаний: 0% ±

нет
Если офис не слишком старый, то можно так
Код
=SUMIFS(C1:C7;A1:A7;A3;B1:B7;B1)
 
Ответить
СообщениеЕсли офис не слишком старый, то можно так
Код
=SUMIFS(C1:C7;A1:A7;A3;B1:B7;B1)

Автор - bigor
Дата добавления - 05.03.2023 в 20:55
filllin9425 Дата: Понедельник, 06.03.2023, 20:11 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Спасибо большое.
Офис 10
А, если в ячейке с Иваном будут еще слова... Например "Иван 111" и "Иван 222", а нужно найти только "Иван", и не важно, какие цифры после. Это возможно?
К сообщению приложен файл: 7670459.xls (31.0 Kb)
 
Ответить
СообщениеСпасибо большое.
Офис 10
А, если в ячейке с Иваном будут еще слова... Например "Иван 111" и "Иван 222", а нужно найти только "Иван", и не важно, какие цифры после. Это возможно?

Автор - filllin9425
Дата добавления - 06.03.2023 в 20:11
bigor Дата: Понедельник, 06.03.2023, 20:25 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1119
Репутация: 212 ±
Замечаний: 0% ±

нет
Это возможно?

да
Код
=SUMPRODUCT((A1:A7="Петров")*(LEFT(B1:B7;4)="Иван");(C1:C7))


Сообщение отредактировал bigor - Понедельник, 06.03.2023, 20:26
 
Ответить
Сообщение
Это возможно?

да
Код
=SUMPRODUCT((A1:A7="Петров")*(LEFT(B1:B7;4)="Иван");(C1:C7))

Автор - bigor
Дата добавления - 06.03.2023 в 20:25
Pelena Дата: Понедельник, 06.03.2023, 21:04 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 19212
Репутация: 4427 ±
Замечаний: ±

Excel 365 & Mac Excel
или так
Код
=СУММЕСЛИМН(C1:C7;A1:A7;"Петров";B1:B7;"Иван*")


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщениеили так
Код
=СУММЕСЛИМН(C1:C7;A1:A7;"Петров";B1:B7;"Иван*")

Автор - Pelena
Дата добавления - 06.03.2023 в 21:04
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!