Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/заполнение в колонку сумму из трех колонок другого листа - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » заполнение в колонку сумму из трех колонок другого листа (Формулы/Formulas)
заполнение в колонку сумму из трех колонок другого листа
KupAlexxx Дата: Понедельник, 06.03.2023, 13:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

добрый день.
во вложении файл.
помогите если сможете.
в файле уже есть формулы которые подтягивают данные из других листов при двух условиях (столбец B и D)

нужно чтобы в в столбце C и E подтягивались также данные с соответствующего выбранного по условию листа, но сумма трех колонок соответствующих КВАРТАЛУ, т.е. если в выпадающем списке (C7) выбрать квартал , то по всей колонке должна поставиться сумма значений с соответствующего листа (B2), из колонок соответствующих кварталу месяцев.

я начал через ЕСЛИ в столбце C, но формула оказывается огромной (это учитывая что в файле для примера взяты 2 квартала а не 4)

есть ли вариант прописать как-то короче?
и чтобы формула протягивалась...
К сообщению приложен файл: 855.xlsb (15.2 Kb)
 
Ответить
Сообщениедобрый день.
во вложении файл.
помогите если сможете.
в файле уже есть формулы которые подтягивают данные из других листов при двух условиях (столбец B и D)

нужно чтобы в в столбце C и E подтягивались также данные с соответствующего выбранного по условию листа, но сумма трех колонок соответствующих КВАРТАЛУ, т.е. если в выпадающем списке (C7) выбрать квартал , то по всей колонке должна поставиться сумма значений с соответствующего листа (B2), из колонок соответствующих кварталу месяцев.

я начал через ЕСЛИ в столбце C, но формула оказывается огромной (это учитывая что в файле для примера взяты 2 квартала а не 4)

есть ли вариант прописать как-то короче?
и чтобы формула протягивалась...

Автор - KupAlexxx
Дата добавления - 06.03.2023 в 13:01
Nic70y Дата: Понедельник, 06.03.2023, 13:16 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8791
Репутация: 2293 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММ(ИНДЕКС(ДВССЫЛ("'"&B$2&"'!B:G");СТРОКА();(C$7-1)*3+1):ИНДЕКС(ДВССЫЛ("'"&B$2&"'!B:G");СТРОКА();(C$7-1)*3+3))
К сообщению приложен файл: 247.xlsb (15.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=СУММ(ИНДЕКС(ДВССЫЛ("'"&B$2&"'!B:G");СТРОКА();(C$7-1)*3+1):ИНДЕКС(ДВССЫЛ("'"&B$2&"'!B:G");СТРОКА();(C$7-1)*3+3))

Автор - Nic70y
Дата добавления - 06.03.2023 в 13:16
KupAlexxx Дата: Понедельник, 06.03.2023, 14:19 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, спасибо. все работает отлично !!!
 
Ответить
СообщениеNic70y, спасибо. все работает отлично !!!

Автор - KupAlexxx
Дата добавления - 06.03.2023 в 14:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » заполнение в колонку сумму из трех колонок другого листа (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!