Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Разбить ячейку по столбцам по конкретным параметрам (словам) - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разбить ячейку по столбцам по конкретным параметрам (словам) (Формулы/Formulas)
Разбить ячейку по столбцам по конкретным параметрам (словам)
kangovince Дата: Суббота, 18.03.2023, 11:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Добрый день. Файл во вложении. Задача следующая: у меня есть столбец, в нём идёт БРЕНД:АРТИКУЛ, далее идёт альт+ентер и в той же ячейке другой БРЕНД:Артикул и так далее.

В идеале - выдернуть только нужные бренды (Манн, Дональдсон, Флитгард итп), и поместить их в соответствующий столбец. Но если это не реально, то хотя бы разбить по "альт+энтер" - каждая строчка в ячейке в отдельный столбец.

Пытался сделать через кнтрл+е, но результат кривущий получается. Пытался сделать через разделение ячеек, но не очень понимаю, как разделить именно по аль+ентер внутри ячейки.

Буду очень, очень сильно благодарен за помощь!
К сообщению приложен файл: testovaya_zapis_po_stolbtsam.xlsx (8.4 Kb)
 
Ответить
СообщениеДобрый день. Файл во вложении. Задача следующая: у меня есть столбец, в нём идёт БРЕНД:АРТИКУЛ, далее идёт альт+ентер и в той же ячейке другой БРЕНД:Артикул и так далее.

В идеале - выдернуть только нужные бренды (Манн, Дональдсон, Флитгард итп), и поместить их в соответствующий столбец. Но если это не реально, то хотя бы разбить по "альт+энтер" - каждая строчка в ячейке в отдельный столбец.

Пытался сделать через кнтрл+е, но результат кривущий получается. Пытался сделать через разделение ячеек, но не очень понимаю, как разделить именно по аль+ентер внутри ячейки.

Буду очень, очень сильно благодарен за помощь!

Автор - kangovince
Дата добавления - 18.03.2023 в 11:12
i691198 Дата: Суббота, 18.03.2023, 11:55 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 204
Репутация: 83 ±
Замечаний: 0% ±

kangovince, Текст по столбцам -> с разделителями -> выбрать разделители - "пробел" и "другой", в окне для другого ввести Ctrl+j.


Сообщение отредактировал i691198 - Суббота, 18.03.2023, 11:56
 
Ответить
Сообщениеkangovince, Текст по столбцам -> с разделителями -> выбрать разделители - "пробел" и "другой", в окне для другого ввести Ctrl+j.

Автор - i691198
Дата добавления - 18.03.2023 в 11:55
msi2102 Дата: Суббота, 18.03.2023, 12:12 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 409
Репутация: 129 ±
Замечаний: 0% ±

Excel 2007
Так
[vba]
Код
=ЕСЛИОШИБКА(ФИЛЬТР.XML("<t><s>"&ПОДСТАВИТЬ($A2;СИМВОЛ(10);"</s><s>")&"</s></t>";"//s[contains(., '"&C$1&"')]");"")
[/vba]

или так
Код
=ЕСЛИОШИБКА(ПСТР($A2&СИМВОЛ(10);ПОИСК(H$1;$A2&СИМВОЛ(10));ПОИСК(СИМВОЛ(10);$A2&СИМВОЛ(10);ПОИСК(H$1;$A2&СИМВОЛ(10)))-ПОИСК(H$1;$A2&СИМВОЛ(10)));"")
К сообщению приложен файл: testovaya_zapis_po_stolbtsam_2.xlsx (9.5 Kb)


Сообщение отредактировал msi2102 - Суббота, 18.03.2023, 12:34
 
Ответить
СообщениеТак
[vba]
Код
=ЕСЛИОШИБКА(ФИЛЬТР.XML("<t><s>"&ПОДСТАВИТЬ($A2;СИМВОЛ(10);"</s><s>")&"</s></t>";"//s[contains(., '"&C$1&"')]");"")
[/vba]

или так
Код
=ЕСЛИОШИБКА(ПСТР($A2&СИМВОЛ(10);ПОИСК(H$1;$A2&СИМВОЛ(10));ПОИСК(СИМВОЛ(10);$A2&СИМВОЛ(10);ПОИСК(H$1;$A2&СИМВОЛ(10)))-ПОИСК(H$1;$A2&СИМВОЛ(10)));"")

Автор - msi2102
Дата добавления - 18.03.2023 в 12:12
kangovince Дата: Суббота, 18.03.2023, 13:02 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Так
=ЕСЛИОШИБКА(ФИЛЬТР.XML("<t><s>"&ПОДСТАВИТЬ($A2;СИМВОЛ(10);"</s><s>")&"</s></t>";"//s[contains(., '"&C$1&"')]");"")

или так

=ЕСЛИОШИБКА(ПСТР($A2&СИМВОЛ(10);ПОИСК(H$1;$A2&СИМВОЛ(10));ПОИСК(СИМВОЛ(10);$A2&СИМВОЛ(10);ПОИСК(H$1;$A2&СИМВОЛ(10)))-ПОИСК(H$1;$A2&СИМВОЛ(10)));"")
К сообщению приложен файл: testovaya_zapis_po_stolbtsam_2.xlsx (9.5 Kb)


Слушай, очень круто! Прям вообще! Подскажи, пожалуйста, это же ещё не ВБА, а просто работа с текущими возможностями экселя? Где вообще можно так подробно почитать про это? Очень хотел бы сам так научиться! Заранее благодарю)
 
Ответить
Сообщение
Так
=ЕСЛИОШИБКА(ФИЛЬТР.XML("<t><s>"&ПОДСТАВИТЬ($A2;СИМВОЛ(10);"</s><s>")&"</s></t>";"//s[contains(., '"&C$1&"')]");"")

или так

=ЕСЛИОШИБКА(ПСТР($A2&СИМВОЛ(10);ПОИСК(H$1;$A2&СИМВОЛ(10));ПОИСК(СИМВОЛ(10);$A2&СИМВОЛ(10);ПОИСК(H$1;$A2&СИМВОЛ(10)))-ПОИСК(H$1;$A2&СИМВОЛ(10)));"")
К сообщению приложен файл: testovaya_zapis_po_stolbtsam_2.xlsx (9.5 Kb)


Слушай, очень круто! Прям вообще! Подскажи, пожалуйста, это же ещё не ВБА, а просто работа с текущими возможностями экселя? Где вообще можно так подробно почитать про это? Очень хотел бы сам так научиться! Заранее благодарю)

Автор - kangovince
Дата добавления - 18.03.2023 в 13:02
Egyptian Дата: Суббота, 18.03.2023, 18:40 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 512
Репутация: 184 ±
Замечаний: 0% ±

Excel 2013/2016
Еще вариант формулами.

Только бренды:
Код
=IFERROR(LEFT(TRIM(MID(SUBSTITUTE($A2;CHAR(10);REPT(" ";35));SEARCH(O$1;SUBSTITUTE($A2;CHAR(10);REPT(" ";35)));35));LEN(O$1));"")

Бренды со значениями.
Код
=IFERROR(TRIM(MID(SUBSTITUTE($A2;CHAR(10);REPT(" ";35));SEARCH(C$1;SUBSTITUTE($A2;CHAR(10);REPT(" ";35)));35));"")

Только значения:
Код
=IFERROR(TRIM(MID(SUBSTITUTE($A2;CHAR(10);REPT(" ";35));1+SEARCH(I$1;SUBSTITUTE($A2;CHAR(10);REPT(" ";35)))+LEN(I$1);35));"")

Все варианты в файле.
К сообщению приложен файл: 8915067.xlsx (12.6 Kb)
 
Ответить
СообщениеЕще вариант формулами.

Только бренды:
Код
=IFERROR(LEFT(TRIM(MID(SUBSTITUTE($A2;CHAR(10);REPT(" ";35));SEARCH(O$1;SUBSTITUTE($A2;CHAR(10);REPT(" ";35)));35));LEN(O$1));"")

Бренды со значениями.
Код
=IFERROR(TRIM(MID(SUBSTITUTE($A2;CHAR(10);REPT(" ";35));SEARCH(C$1;SUBSTITUTE($A2;CHAR(10);REPT(" ";35)));35));"")

Только значения:
Код
=IFERROR(TRIM(MID(SUBSTITUTE($A2;CHAR(10);REPT(" ";35));1+SEARCH(I$1;SUBSTITUTE($A2;CHAR(10);REPT(" ";35)))+LEN(I$1);35));"")

Все варианты в файле.

Автор - Egyptian
Дата добавления - 18.03.2023 в 18:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разбить ячейку по столбцам по конкретным параметрам (словам) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!