Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет значений по сумме уникальных ячеек - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Подсчет значений по сумме уникальных ячеек
AZaytsev Дата: Вторник, 21.03.2023, 13:18 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!

Есть список с наименованием полезных ископаемых, которые даны списком через запятую. С помощью формулы:
Код
=ЕСЛИ(ЕОШИБКА(ЛЕВСИМВ(A6;НАЙТИ(",";A6)-1));" ";ЛЕВСИМВ(A6;НАЙТИ(",";A6)-1))

я отделил в новую ячейку первое наименование полезного ископаемого и перенес числовое значение из исходного списка, но в результате у меня появились дубликаты.

Вопрос: как удалить дубликаты в списке полезных ископаемых, а в уникальном значении показать сумму числовых значений? В дальнейшем эта схема будет использоваться для сводной таблицы

Спасибо!
К сообщению приложен файл: 2721704.xlsx (13.7 Kb)


alexeyzaytsev.ru

Сообщение отредактировал AZaytsev - Вторник, 21.03.2023, 13:21
 
Ответить
СообщениеДобрый день!

Есть список с наименованием полезных ископаемых, которые даны списком через запятую. С помощью формулы:
Код
=ЕСЛИ(ЕОШИБКА(ЛЕВСИМВ(A6;НАЙТИ(",";A6)-1));" ";ЛЕВСИМВ(A6;НАЙТИ(",";A6)-1))

я отделил в новую ячейку первое наименование полезного ископаемого и перенес числовое значение из исходного списка, но в результате у меня появились дубликаты.

Вопрос: как удалить дубликаты в списке полезных ископаемых, а в уникальном значении показать сумму числовых значений? В дальнейшем эта схема будет использоваться для сводной таблицы

Спасибо!

Автор - AZaytsev
Дата добавления - 21.03.2023 в 13:18
DrMini Дата: Вторник, 21.03.2023, 14:07 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1732
Репутация: 236 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
как удалить дубликаты в списке полезных ископаемых, а в уникальном значении показать сумму числовых значений?

Может типа такого (если правильно понял).
К сообщению приложен файл: 1245582.xlsx (18.0 Kb)


Сообщение отредактировал DrMini - Вторник, 21.03.2023, 14:08
 
Ответить
Сообщение
как удалить дубликаты в списке полезных ископаемых, а в уникальном значении показать сумму числовых значений?

Может типа такого (если правильно понял).

Автор - DrMini
Дата добавления - 21.03.2023 в 14:07
китин Дата: Вторник, 21.03.2023, 14:17 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 7020
Репутация: 1075 ±
Замечаний: 0% ±

Excel 2007;2010;2016
Немного исправил вашу формулу на эту.

Код
=ЕСЛИ(ЕОШИБКА(ЛЕВСИМВ(A6;НАЙТИ(",";A6)-1));$A6;ЛЕВСИМВ(A6;НАЙТИ(",";A6)-1))

подсчёт уникальных
Код
=ЕСЛИ(СЧЁТЕСЛИ($D$6:$D6;$D6)>1;0;СУММЕСЛИ($D$6:$D$100;$D6;$E$6:$E$100))

на Лист2 PQ всемогущий
К сообщению приложен файл: 9485874.xlsx (25.9 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеНемного исправил вашу формулу на эту.

Код
=ЕСЛИ(ЕОШИБКА(ЛЕВСИМВ(A6;НАЙТИ(",";A6)-1));$A6;ЛЕВСИМВ(A6;НАЙТИ(",";A6)-1))

подсчёт уникальных
Код
=ЕСЛИ(СЧЁТЕСЛИ($D$6:$D6;$D6)>1;0;СУММЕСЛИ($D$6:$D$100;$D6;$E$6:$E$100))

на Лист2 PQ всемогущий

Автор - китин
Дата добавления - 21.03.2023 в 14:17
bigor Дата: Вторник, 21.03.2023, 14:28 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1136
Репутация: 215 ±
Замечаний: 0% ±

нет
AZaytsev, для поиска первого элемента до запятой
Код
=TRIM(LEFT(SUBSTITUTE(A4;",";REPT(" ";200));200))

остальное не понял, уникальные и их подсчет проще сводной делать, чем формулами
 
Ответить
СообщениеAZaytsev, для поиска первого элемента до запятой
Код
=TRIM(LEFT(SUBSTITUTE(A4;",";REPT(" ";200));200))

остальное не понял, уникальные и их подсчет проще сводной делать, чем формулами

Автор - bigor
Дата добавления - 21.03.2023 в 14:28
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!