Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Добавить пробел и запятую в ячейку - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Добавить пробел и запятую в ячейку
Alekseew Дата: Пятница, 24.03.2023, 14:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Уважаемые подскажите пожалуйста как добавить пробел и запятую в ячейку.
Например
Было
10,11 2022.01.04
Стало
10, 11, 2022.01.04

Добавился пробел между 10, и 11
Появилась запятая после 11
Спасибо уважаемые! Очень жду помощи.


Сообщение отредактировал Alekseew - Пятница, 24.03.2023, 14:58
 
Ответить
СообщениеУважаемые подскажите пожалуйста как добавить пробел и запятую в ячейку.
Например
Было
10,11 2022.01.04
Стало
10, 11, 2022.01.04

Добавился пробел между 10, и 11
Появилась запятая после 11
Спасибо уважаемые! Очень жду помощи.

Автор - Alekseew
Дата добавления - 24.03.2023 в 14:57
Egyptian Дата: Пятница, 24.03.2023, 15:03 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 515
Репутация: 186 ±
Замечаний: 0% ±

Excel 2013/2016
Как-то так:
Код
=SUBSTITUTE(SUBSTITUTE(A1;",";", ");" ";", ";2)

Код
=REPLACE(REPLACE(A1;3;1;", ");7;1;", ")
 
Ответить
СообщениеКак-то так:
Код
=SUBSTITUTE(SUBSTITUTE(A1;",";", ");" ";", ";2)

Код
=REPLACE(REPLACE(A1;3;1;", ");7;1;", ")

Автор - Egyptian
Дата добавления - 24.03.2023 в 15:03
_Boroda_ Дата: Пятница, 24.03.2023, 15:07 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16675
Репутация: 6481 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ПОДСТАВИТЬ(A1;",";" "));" ";", ")

Может же быть вот такое - 10, 11 2022.01.05 ?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ПОДСТАВИТЬ(A1;",";" "));" ";", ")

Может же быть вот такое - 10, 11 2022.01.05 ?

Автор - _Boroda_
Дата добавления - 24.03.2023 в 15:07
Alekseew Дата: Пятница, 24.03.2023, 15:08 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Egyptian, ты лучший!
<3 просто знай это <3
 
Ответить
СообщениеEgyptian, ты лучший!
<3 просто знай это <3

Автор - Alekseew
Дата добавления - 24.03.2023 в 15:08
Alekseew Дата: Пятница, 24.03.2023, 15:10 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_, храни господь таких людей <3
Спасибо!
 
Ответить
Сообщение_Boroda_, храни господь таких людей <3
Спасибо!

Автор - Alekseew
Дата добавления - 24.03.2023 в 15:10
Nic70y Дата: Пятница, 24.03.2023, 15:12 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 8831
Репутация: 2300 ±
Замечаний: 0% ±

Excel 2010
Код
=ПОДСТАВИТЬ(ПОДСТАВИТЬ(A1;" ";",");",";", ")

ну и чтоб смешнее было)
Код
=ТЕКСТ(--ПОДСТАВИТЬ(A1;",";":");"чч, мм, ГГГГ.ММ.ДД")


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Пятница, 24.03.2023, 15:16
 
Ответить
Сообщение
Код
=ПОДСТАВИТЬ(ПОДСТАВИТЬ(A1;" ";",");",";", ")

ну и чтоб смешнее было)
Код
=ТЕКСТ(--ПОДСТАВИТЬ(A1;",";":");"чч, мм, ГГГГ.ММ.ДД")

Автор - Nic70y
Дата добавления - 24.03.2023 в 15:12
Alekseew Дата: Пятница, 24.03.2023, 18:58 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_, нет нет, все верно я написал
(10, 11, 2022.01.04)
Именно такой порядок, пробелы и запятые.
Прислали с министерство задание внести архивные данные за прошлые года. Более 70 000 ячеек с данными, но в форму они не вставлялись из за неправильного написания. Нужно было добавить запятую и пробел.
Все получилось. Просто отлично. А то кто из коллег уже начал вручную переносить.
Спасибо


Сообщение отредактировал Alekseew - Пятница, 24.03.2023, 19:00
 
Ответить
Сообщение_Boroda_, нет нет, все верно я написал
(10, 11, 2022.01.04)
Именно такой порядок, пробелы и запятые.
Прислали с министерство задание внести архивные данные за прошлые года. Более 70 000 ячеек с данными, но в форму они не вставлялись из за неправильного написания. Нужно было добавить запятую и пробел.
Все получилось. Просто отлично. А то кто из коллег уже начал вручную переносить.
Спасибо

Автор - Alekseew
Дата добавления - 24.03.2023 в 18:58
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!