Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула срзначеслимн с индеск и поискпоз - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула срзначеслимн с индеск и поискпоз (Формулы/Formulas)
Формула срзначеслимн с индеск и поискпоз
ultrafviolet Дата: Четверг, 30.03.2023, 15:51 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 40% ±

Нужно прописать формулу срзначеслимн по каждой точке в разрезе периода, в файле отправила упрощенный вариант задачи. но все равно у меня не получается решить
К сообщению приложен файл: srznacheslimn_indeks_poiskpoz.xlsx (9.2 Kb)
 
Ответить
СообщениеНужно прописать формулу срзначеслимн по каждой точке в разрезе периода, в файле отправила упрощенный вариант задачи. но все равно у меня не получается решить

Автор - ultrafviolet
Дата добавления - 30.03.2023 в 15:51
bigor Дата: Четверг, 30.03.2023, 16:00 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1110
Репутация: 212 ±
Замечаний: 0% ±

нет
ultrafviolet, правда не теми функциями, что у вас в названии темы:
Код
=SUMPRODUCT(($G$4:$G$16=$A3)*($H$3:$J$3=$B3)*$H$4:$J$16)/SUMPRODUCT(($G$4:$G$16=$A3)*($H$3:$J$3=$B3)*($H$4:$J$16)^0)
 
Ответить
Сообщениеultrafviolet, правда не теми функциями, что у вас в названии темы:
Код
=SUMPRODUCT(($G$4:$G$16=$A3)*($H$3:$J$3=$B3)*$H$4:$J$16)/SUMPRODUCT(($G$4:$G$16=$A3)*($H$3:$J$3=$B3)*($H$4:$J$16)^0)

Автор - bigor
Дата добавления - 30.03.2023 в 16:00
ultrafviolet Дата: Четверг, 30.03.2023, 16:12 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 40% ±

bigor, вставила формулу но мне выдает ошибку
К сообщению приложен файл: 4145646.png (188.6 Kb)
 
Ответить
Сообщениеbigor, вставила формулу но мне выдает ошибку

Автор - ultrafviolet
Дата добавления - 30.03.2023 в 16:12
elovkov Дата: Четверг, 30.03.2023, 16:28 | Сообщение № 4
Группа: Друзья
Ранг: Обитатель
Сообщений: 380
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
мне выдает ошибку

и у меня
может так?
Код
=СУММПРОИЗВ(($G$4:$G$16=$A3)*($H$3:$J$3=$B3)*$H$4:$J$16)/СЧЁТЕСЛИ($G$4:$G$16;$A3)

Ну и так как в исходной нет апреля и мая, на них будет ошибку выдавать, можно дополнить
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ(($G$4:$G$18=$A3)*($H$3:$J$3=$B3)*$H$4:$J$18)/СЧЁТЕСЛИ($G$4:$G$18;A3);"")


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Четверг, 30.03.2023, 16:41
 
Ответить
Сообщение
мне выдает ошибку

и у меня
может так?
Код
=СУММПРОИЗВ(($G$4:$G$16=$A3)*($H$3:$J$3=$B3)*$H$4:$J$16)/СЧЁТЕСЛИ($G$4:$G$16;$A3)

Ну и так как в исходной нет апреля и мая, на них будет ошибку выдавать, можно дополнить
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ(($G$4:$G$18=$A3)*($H$3:$J$3=$B3)*$H$4:$J$18)/СЧЁТЕСЛИ($G$4:$G$18;A3);"")

Автор - elovkov
Дата добавления - 30.03.2023 в 16:28
_Boroda_ Дата: Четверг, 30.03.2023, 16:53 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16675
Репутация: 6481 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=СРЗНАЧЕСЛИ(G:G;A3;ИНДЕКС(H:J;;ПОИСКПОЗ(B3;H$3:J$3;)))

Код
=СРЗНАЧЕСЛИ(G:G;A3;ИНДЕКС(H:J;;ПРАВБ(B3)))
К сообщению приложен файл: srznacheslimn_indeks_poiskpoz_.xlsx (9.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=СРЗНАЧЕСЛИ(G:G;A3;ИНДЕКС(H:J;;ПОИСКПОЗ(B3;H$3:J$3;)))

Код
=СРЗНАЧЕСЛИ(G:G;A3;ИНДЕКС(H:J;;ПРАВБ(B3)))

Автор - _Boroda_
Дата добавления - 30.03.2023 в 16:53
bigor Дата: Четверг, 30.03.2023, 16:55 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1110
Репутация: 212 ±
Замечаний: 0% ±

нет
но мне выдает ошибку
excel считает что 0^0 нечисло :(
поэтому если значения от 0 и выше, то можно так

Код
=СУММПРОИЗВ(($G$4:$G$16=$A3)*($H$3:$J$3=$B3)*$H$4:$J$16)/СУММПРОИЗВ(($G$4:$G$16=$A3)*($H$3:$J$3=$B3)*(($H$4:$J$16)+1)^0)
 
Ответить
Сообщение
но мне выдает ошибку
excel считает что 0^0 нечисло :(
поэтому если значения от 0 и выше, то можно так

Код
=СУММПРОИЗВ(($G$4:$G$16=$A3)*($H$3:$J$3=$B3)*$H$4:$J$16)/СУММПРОИЗВ(($G$4:$G$16=$A3)*($H$3:$J$3=$B3)*(($H$4:$J$16)+1)^0)

Автор - bigor
Дата добавления - 30.03.2023 в 16:55
_Boroda_ Дата: Четверг, 30.03.2023, 16:58 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16675
Репутация: 6481 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
bigor, а кусок
Код
*(($H$4:$J$16)+1)^0
вообще зачем там?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеbigor, а кусок
Код
*(($H$4:$J$16)+1)^0
вообще зачем там?

Автор - _Boroda_
Дата добавления - 30.03.2023 в 16:58
bigor Дата: Четверг, 30.03.2023, 17:01 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 1110
Репутация: 212 ±
Замечаний: 0% ±

нет
_Boroda_, блин, конец рабочего дня :) я им единицы получал. Да переработался :) он не нужен
 
Ответить
Сообщение_Boroda_, блин, конец рабочего дня :) я им единицы получал. Да переработался :) он не нужен

Автор - bigor
Дата добавления - 30.03.2023 в 17:01
ultrafviolet Дата: Четверг, 30.03.2023, 17:22 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 40% ±

bigor, спасибо огромное , теперь есть понимание куда дальше двигаться
 
Ответить
Сообщениеbigor, спасибо огромное , теперь есть понимание куда дальше двигаться

Автор - ultrafviolet
Дата добавления - 30.03.2023 в 17:22
bigor Дата: Четверг, 30.03.2023, 17:30 | Сообщение № 10
Группа: Проверенные
Ранг: Старожил
Сообщений: 1110
Репутация: 212 ±
Замечаний: 0% ±

нет
ultrafviolet, решения от _Boroda_, больше подходят под вашу тему :)
 
Ответить
Сообщениеultrafviolet, решения от _Boroda_, больше подходят под вашу тему :)

Автор - bigor
Дата добавления - 30.03.2023 в 17:30
ultrafviolet Дата: Четверг, 30.03.2023, 17:42 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 40% ±

_Boroda_, вот так я и представляла, но не совсем понимала как ее сделать, спасибо огромное
 
Ответить
Сообщение_Boroda_, вот так я и представляла, но не совсем понимала как ее сделать, спасибо огромное

Автор - ultrafviolet
Дата добавления - 30.03.2023 в 17:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула срзначеслимн с индеск и поискпоз (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!