Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбрать данные из таблицы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать данные из таблицы (Формулы/Formulas)
Выбрать данные из таблицы
Chelovekov Дата: Вторник, 11.04.2023, 06:37 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Здравствуйте, Уважаемые Форумчане. Помогите, решить проблему, есть две таблицы, нужно из одной, таблица данные, по определённому критерию, выбрать данные из другой, таблица результаты.
Пример прилагаю

Заранее благодарен.
К сообщению приложен файл: primerr.xlsx (14.2 Kb)
 
Ответить
СообщениеЗдравствуйте, Уважаемые Форумчане. Помогите, решить проблему, есть две таблицы, нужно из одной, таблица данные, по определённому критерию, выбрать данные из другой, таблица результаты.
Пример прилагаю

Заранее благодарен.

Автор - Chelovekov
Дата добавления - 11.04.2023 в 06:37
DrMini Дата: Вторник, 11.04.2023, 06:49 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
по определённому критерию

По какому критерию?
 
Ответить
Сообщение
по определённому критерию

По какому критерию?

Автор - DrMini
Дата добавления - 11.04.2023 в 06:49
Chelovekov Дата: Вторник, 11.04.2023, 06:52 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
По дате игры и названию команд
 
Ответить
СообщениеПо дате игры и названию команд

Автор - Chelovekov
Дата добавления - 11.04.2023 в 06:52
jakim Дата: Вторник, 11.04.2023, 06:54 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 313 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=INDEX(Результат!J2:J50;AGGREGATE(15;6;ROW($1:$100)/(D2=Результат!E2:E50)/(E2=Результат!F2:F50);1))
К сообщению приложен файл: 3726691.xlsx (13.9 Kb)
 
Ответить
Сообщение
Формула

Код
=INDEX(Результат!J2:J50;AGGREGATE(15;6;ROW($1:$100)/(D2=Результат!E2:E50)/(E2=Результат!F2:F50);1))

Автор - jakim
Дата добавления - 11.04.2023 в 06:54
jakim Дата: Вторник, 11.04.2023, 08:01 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 313 ±
Замечаний: 0% ±

Excel 2010
Добавил дату

Код
=INDEX(Результат!J2:J50;AGGREGATE(15;6;ROW($1:$100)/(D2=Результат!E2:E50)/(Данные!E2=Результат!F2:F50)/(INT(B2)=Результат!C2:C50);1))

У Вас на листе Результат дата в текстовом варианте.
К сообщению приложен файл: 8699539.xlsx (13.8 Kb)
 
Ответить
Сообщение
Добавил дату

Код
=INDEX(Результат!J2:J50;AGGREGATE(15;6;ROW($1:$100)/(D2=Результат!E2:E50)/(Данные!E2=Результат!F2:F50)/(INT(B2)=Результат!C2:C50);1))

У Вас на листе Результат дата в текстовом варианте.

Автор - jakim
Дата добавления - 11.04.2023 в 08:01
DrMini Дата: Вторник, 11.04.2023, 09:37 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1678
Репутация: 226 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Как варианты:
Код
=ИНДЕКС(Таблица1[Тотал];ПОИСКПОЗ(1;(Таблица1[Дата]=ТЕКСТ(B2;"ДД.ММ.ГГГГ"))*(Таблица1[К1]=D2)*(Таблица1[К2]=E2);0))

Код
=СУММПРОИЗВ((Таблица1[Дата]=ТЕКСТ(B2;"ДД.ММ.ГГГГ"))*(Таблица1[К1]=D2)*(Таблица1[К2]=E2)*(Таблица1[Тотал]))
К сообщению приложен файл: 0561191.xlsx (15.5 Kb)


Сообщение отредактировал DrMini - Вторник, 11.04.2023, 10:00
 
Ответить
СообщениеКак варианты:
Код
=ИНДЕКС(Таблица1[Тотал];ПОИСКПОЗ(1;(Таблица1[Дата]=ТЕКСТ(B2;"ДД.ММ.ГГГГ"))*(Таблица1[К1]=D2)*(Таблица1[К2]=E2);0))

Код
=СУММПРОИЗВ((Таблица1[Дата]=ТЕКСТ(B2;"ДД.ММ.ГГГГ"))*(Таблица1[К1]=D2)*(Таблица1[К2]=E2)*(Таблица1[Тотал]))

Автор - DrMini
Дата добавления - 11.04.2023 в 09:37
Chelovekov Дата: Вторник, 11.04.2023, 13:01 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 310
Репутация: 0 ±
Замечаний: 80% ±

Excel 2016
Всем спасибо !!!!
 
Ответить
СообщениеВсем спасибо !!!!

Автор - Chelovekov
Дата добавления - 11.04.2023 в 13:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать данные из таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!