Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет среднего значения с одинаковым диапазоном - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 2
  • 1
  • 2
  • »
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет среднего значения с одинаковым диапазоном (Формулы)
Расчет среднего значения с одинаковым диапазоном
Nenterio Дата: Пятница, 21.06.2013, 13:32 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день, столкнулся с проблемой и так и не смог решить. Есть массив данных (в файле прилагается отрывок), столбец А:А - именной (от 90 до 0 - 1 месяц), необходимо рассчитать среднее значение каждого месяца, проблема в том, что при попытке "протянуть" формулу по ячейкам от 1 до 12, выбирается произвольный диапазон значений, а нужен фиксированный (количество ячеек в одном месяце 37). Помогите позяя =)
К сообщению приложен файл: XSPS.xls(81.0 Kb)
 
Ответить
СообщениеДобрый день, столкнулся с проблемой и так и не смог решить. Есть массив данных (в файле прилагается отрывок), столбец А:А - именной (от 90 до 0 - 1 месяц), необходимо рассчитать среднее значение каждого месяца, проблема в том, что при попытке "протянуть" формулу по ячейкам от 1 до 12, выбирается произвольный диапазон значений, а нужен фиксированный (количество ячеек в одном месяце 37). Помогите позяя =)

Автор - Nenterio
Дата добавления - 21.06.2013 в 13:32
Pelena Дата: Пятница, 21.06.2013, 14:02 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16655
Репутация: 3600 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Вариант
Код
=СРЗНАЧ(СМЕЩ($B$1;(СТРОКА(A1)-1)*37;;37))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВариант
Код
=СРЗНАЧ(СМЕЩ($B$1;(СТРОКА(A1)-1)*37;;37))

Автор - Pelena
Дата добавления - 21.06.2013 в 14:02
Nenterio Дата: Пятница, 21.06.2013, 14:27 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Цитата (Pelena)
=СРЗНАЧ(СМЕЩ($B$1;(СТРОКА(A1)-1)*37;;37))


Спасибо, а можно ли значение "СТРОК А" указать как константа? потому как диапазон столбцов доходит до ЕО, и при "протяжке" меняется значение "СТРКОКА(А1)" на "СТРОКА(В1)"
К сообщению приложен файл: 8016454.xls(82.0 Kb)


Сообщение отредактировал Nenterio - Пятница, 21.06.2013, 14:31
 
Ответить
Сообщение
Цитата (Pelena)
=СРЗНАЧ(СМЕЩ($B$1;(СТРОКА(A1)-1)*37;;37))


Спасибо, а можно ли значение "СТРОК А" указать как константа? потому как диапазон столбцов доходит до ЕО, и при "протяжке" меняется значение "СТРКОКА(А1)" на "СТРОКА(В1)"

Автор - Nenterio
Дата добавления - 21.06.2013 в 14:27
Pelena Дата: Пятница, 21.06.2013, 14:31 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16655
Репутация: 3600 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
СТРОКА(А1) и СТРОКА(В1) в результате всё равно дают 1 - это номер строки.
Если надо вычислять среднее по разным столбцам, то менять нужно $B$1 на B$1


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеСТРОКА(А1) и СТРОКА(В1) в результате всё равно дают 1 - это номер строки.
Если надо вычислять среднее по разным столбцам, то менять нужно $B$1 на B$1

Автор - Pelena
Дата добавления - 21.06.2013 в 14:31
Nenterio Дата: Пятница, 21.06.2013, 14:34 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Огромное спасибо, всё заработало.
 
Ответить
СообщениеОгромное спасибо, всё заработало.

Автор - Nenterio
Дата добавления - 21.06.2013 в 14:34
Nenterio Дата: Пятница, 21.06.2013, 14:46 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Хех, рано я обрадовался... в момент, когда формула доходит до
Код
=СРЗНАЧ(СМЕЩ(t_1000_1950!B$1;(СТРОКА(A367)-1)*37;;37))
появляется ошибка деления на ноль(
 
Ответить
СообщениеХех, рано я обрадовался... в момент, когда формула доходит до
Код
=СРЗНАЧ(СМЕЩ(t_1000_1950!B$1;(СТРОКА(A367)-1)*37;;37))
появляется ошибка деления на ноль(

Автор - Nenterio
Дата добавления - 21.06.2013 в 14:46
AndreTM Дата: Пятница, 21.06.2013, 15:03 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1762
Репутация: 497 ±
Замечаний: 0% ±

2003 & 2010
Естественно - если у вас там пусто в ячейках - то и получите ошибку.
И как така СТРОКА(A367)? У вас же всего 12 месяцев?
Вы бы, уж если работаете с кучей данных - так все и демонстрируйте (или хотя бы рассказывайте точнее, где, что и в каких объёмах у вас находится).
Ну и если у вас среднее по 37 ячейкам (а не по имеющимся значениям), - то используйте что-то типа
Код
=СУММ(СМЕЩ($B$1;(СТРОКА(A1)-1)*37;;37))/37


Skype: andre.tm.007
Donate: Qiwi: 9517375010


Сообщение отредактировал AndreTM - Пятница, 21.06.2013, 15:07
 
Ответить
СообщениеЕстественно - если у вас там пусто в ячейках - то и получите ошибку.
И как така СТРОКА(A367)? У вас же всего 12 месяцев?
Вы бы, уж если работаете с кучей данных - так все и демонстрируйте (или хотя бы рассказывайте точнее, где, что и в каких объёмах у вас находится).
Ну и если у вас среднее по 37 ячейкам (а не по имеющимся значениям), - то используйте что-то типа
Код
=СУММ(СМЕЩ($B$1;(СТРОКА(A1)-1)*37;;37))/37

Автор - AndreTM
Дата добавления - 21.06.2013 в 15:03
Pelena Дата: Пятница, 21.06.2013, 15:04 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 16655
Репутация: 3600 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Цитата (Nenterio)
появляется ошибка деления на ноль

Данные закончились smile
Сколько у Вас строк с данными?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Цитата (Nenterio)
появляется ошибка деления на ноль

Данные закончились smile
Сколько у Вас строк с данными?

Автор - Pelena
Дата добавления - 21.06.2013 в 15:04
Nenterio Дата: Пятница, 21.06.2013, 15:15 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
13тысяч строк, не могу же я продемонстрировать) если файл заливается только 100 кб( а весит 17 метров)

Данные выглядят так:
массив данных измерений температуры) (каждые 37 строк - 1 день) и столбцы до столбца EO (градусы с шагом в 2,5 (от 0 до 357,5)

в общей сложности данные с 1950 года по наше время, вот и задача, расчитать средние показатели температуры на каждой широте за день/за месяц/за год


Сообщение отредактировал Nenterio - Пятница, 21.06.2013, 15:17
 
Ответить
Сообщение13тысяч строк, не могу же я продемонстрировать) если файл заливается только 100 кб( а весит 17 метров)

Данные выглядят так:
массив данных измерений температуры) (каждые 37 строк - 1 день) и столбцы до столбца EO (градусы с шагом в 2,5 (от 0 до 357,5)

в общей сложности данные с 1950 года по наше время, вот и задача, расчитать средние показатели температуры на каждой широте за день/за месяц/за год

Автор - Nenterio
Дата добавления - 21.06.2013 в 15:15
Pelena Дата: Пятница, 21.06.2013, 15:19 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 16655
Репутация: 3600 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
367*37=13579
Это больше 13 000


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение367*37=13579
Это больше 13 000

Автор - Pelena
Дата добавления - 21.06.2013 в 15:19
Nenterio Дата: Пятница, 21.06.2013, 15:29 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
а если точнее, это 13539, видимо я нашёл проблему, в строчках, где заканчивается месяц в столбце А две строчки занимает пометка о начале нового месяца, текст определяется как "0"видимо.
Возможно ли ввести пропуск пустых ячеек в формуле? ибо сдвигать данные в таком объёме дико не удобно


Сообщение отредактировал Nenterio - Пятница, 21.06.2013, 15:30
 
Ответить
Сообщениеа если точнее, это 13539, видимо я нашёл проблему, в строчках, где заканчивается месяц в столбце А две строчки занимает пометка о начале нового месяца, текст определяется как "0"видимо.
Возможно ли ввести пропуск пустых ячеек в формуле? ибо сдвигать данные в таком объёме дико не удобно

Автор - Nenterio
Дата добавления - 21.06.2013 в 15:29
Pelena Дата: Пятница, 21.06.2013, 15:31 | Сообщение № 12
Группа: Админы
Ранг: Местный житель
Сообщений: 16655
Репутация: 3600 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Пример?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПример?

Автор - Pelena
Дата добавления - 21.06.2013 в 15:31
Nenterio Дата: Пятница, 21.06.2013, 15:46 | Сообщение № 13
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Да, конечно, строки 6,7,8 повторяются в конце наждого месяца и обозначают новый
К сообщению приложен файл: example.xls(30.5 Kb)
 
Ответить
СообщениеДа, конечно, строки 6,7,8 повторяются в конце наждого месяца и обозначают новый

Автор - Nenterio
Дата добавления - 21.06.2013 в 15:46
Pelena Дата: Пятница, 21.06.2013, 17:38 | Сообщение № 14
Группа: Админы
Ранг: Местный житель
Сообщений: 16655
Репутация: 3600 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Если добавляется три доп. строки ПОСЛЕ каждого месяца, то формула будет
Код
=СРЗНАЧ(СМЕЩ($B$1;(СТРОКА(A1)-1)*40;;37))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕсли добавляется три доп. строки ПОСЛЕ каждого месяца, то формула будет
Код
=СРЗНАЧ(СМЕЩ($B$1;(СТРОКА(A1)-1)*40;;37))

Автор - Pelena
Дата добавления - 21.06.2013 в 17:38
vikttur Дата: Пятница, 21.06.2013, 18:40 | Сообщение № 15
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2926
Репутация: 525 ±
Замечаний: 0% ±

ИНДЕКС() забыли? smile
 
Ответить
СообщениеИНДЕКС() забыли? smile

Автор - vikttur
Дата добавления - 21.06.2013 в 18:40
Pelena Дата: Пятница, 21.06.2013, 18:45 | Сообщение № 16
Группа: Админы
Ранг: Местный житель
Сообщений: 16655
Репутация: 3600 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Цитата (vikttur)
ИНДЕКС() забыли?

Не то, чтобы забыли...
Но сходу не получилось sad


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Цитата (vikttur)
ИНДЕКС() забыли?

Не то, чтобы забыли...
Но сходу не получилось sad

Автор - Pelena
Дата добавления - 21.06.2013 в 18:45
vikttur Дата: Пятница, 21.06.2013, 19:25 | Сообщение № 17
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2926
Репутация: 525 ±
Замечаний: 0% ±

Среднее по одному столбцу?
Где-то так. Не проверял.
Код
=СРЗНАЧ(ИНДЕКС($B$1:$B$100;(СТРОКА(A1)-1)*40+1):ИНДЕКС($B$1:$B$100;(СТРОКА(A1)-1)*40+37))
 
Ответить
СообщениеСреднее по одному столбцу?
Где-то так. Не проверял.
Код
=СРЗНАЧ(ИНДЕКС($B$1:$B$100;(СТРОКА(A1)-1)*40+1):ИНДЕКС($B$1:$B$100;(СТРОКА(A1)-1)*40+37))

Автор - vikttur
Дата добавления - 21.06.2013 в 19:25
Pelena Дата: Пятница, 21.06.2013, 19:46 | Сообщение № 18
Группа: Админы
Ранг: Местный житель
Сообщений: 16655
Репутация: 3600 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Цитата (vikttur)
Не проверял

Проверила, всё правильно smile
Спасибо! Может, когда-нибудь и я этому научусь smile


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Цитата (vikttur)
Не проверял

Проверила, всё правильно smile
Спасибо! Может, когда-нибудь и я этому научусь smile

Автор - Pelena
Дата добавления - 21.06.2013 в 19:46
vikttur Дата: Пятница, 21.06.2013, 19:53 | Сообщение № 19
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2926
Репутация: 525 ±
Замечаний: 0% ±

Так вы же умеете!
Начало диапазона - одна ИНДЕКС(), конец - вторая.
 
Ответить
СообщениеТак вы же умеете!
Начало диапазона - одна ИНДЕКС(), конец - вторая.

Автор - vikttur
Дата добавления - 21.06.2013 в 19:53
Pelena Дата: Пятница, 21.06.2013, 20:00 | Сообщение № 20
Группа: Админы
Ранг: Местный житель
Сообщений: 16655
Репутация: 3600 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Ну, не понимаю я, как это работает sad
Там получается что-то вроде =СРЗНАЧ(-17,45:25,88)?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНу, не понимаю я, как это работает sad
Там получается что-то вроде =СРЗНАЧ(-17,45:25,88)?

Автор - Pelena
Дата добавления - 21.06.2013 в 20:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет среднего значения с одинаковым диапазоном (Формулы)
  • Страница 1 из 2
  • 1
  • 2
  • »
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!