Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Настроить ранжирование без пропуска мест - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Настроить ранжирование без пропуска мест
nbiryulina2012 Дата: Вторник, 25.04.2023, 08:40 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 20% ±

Привет)
Ниже приведена таблица тестирования, у меня не получается сделать так, чтобы места в графе "место" считалось автоматически и без пропусков в зависимости от набранных % в графе "%" в каждом отдельном упражнении.
Например:
Маша - 14
Катя - 12
Надя - 12
Оля - 11
Сделать так, чтобы Маша была на 1 месте, Надя и Катя на 2, Оля на 3.
К сообщению приложен файл: testirovanie.xlsx (19.3 Kb)
 
Ответить
СообщениеПривет)
Ниже приведена таблица тестирования, у меня не получается сделать так, чтобы места в графе "место" считалось автоматически и без пропусков в зависимости от набранных % в графе "%" в каждом отдельном упражнении.
Например:
Маша - 14
Катя - 12
Надя - 12
Оля - 11
Сделать так, чтобы Маша была на 1 месте, Надя и Катя на 2, Оля на 3.

Автор - nbiryulina2012
Дата добавления - 25.04.2023 в 08:40
Nic70y Дата: Вторник, 25.04.2023, 11:17 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8801
Репутация: 2295 ±
Замечаний: 0% ±

Excel 2010
"поиграемся" с %
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(ЦЕЛОЕ(D4/B4*100);E$3:E3;));ЦЕЛОЕ(D4/B4*100);""&ЦЕЛОЕ(D4/B4*100))
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(ОКРУГЛ(D4/B4*100;);E$3:E3;));ОКРУГЛ(D4/B4*100;);""&ОКРУГЛ(D4/B4*100;))
чтоб проще копипастить
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(ОКРУГЛ(D4/$B4*100;);E$3:E3;));ОКРУГЛ(D4/$B4*100;);""&ОКРУГЛ(D4/$B4*100;))
К сообщению приложен файл: 117.xlsx (21.2 Kb)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Вторник, 25.04.2023, 11:44
 
Ответить
Сообщение"поиграемся" с %
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(ЦЕЛОЕ(D4/B4*100);E$3:E3;));ЦЕЛОЕ(D4/B4*100);""&ЦЕЛОЕ(D4/B4*100))
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(ОКРУГЛ(D4/B4*100;);E$3:E3;));ОКРУГЛ(D4/B4*100;);""&ОКРУГЛ(D4/B4*100;))
чтоб проще копипастить
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(ОКРУГЛ(D4/$B4*100;);E$3:E3;));ОКРУГЛ(D4/$B4*100;);""&ОКРУГЛ(D4/$B4*100;))

Автор - Nic70y
Дата добавления - 25.04.2023 в 11:17
elovkov Дата: Вторник, 25.04.2023, 12:02 | Сообщение № 3
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Nic70y, чисто интересно, что произошло? ЕНД выдает истину, что ПОИСКПОЗ Н/Д и тогда записывается процент, зачем ""&? И Почему формула работает??? Не понял вообще)))


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеNic70y, чисто интересно, что произошло? ЕНД выдает истину, что ПОИСКПОЗ Н/Д и тогда записывается процент, зачем ""&? И Почему формула работает??? Не понял вообще)))

Автор - elovkov
Дата добавления - 25.04.2023 в 12:02
Nic70y Дата: Вторник, 25.04.2023, 12:09 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 8801
Репутация: 2295 ±
Замечаний: 0% ±

Excel 2010
elovkov, если мы не находим ОКРУГЛ(D4/B4*100;) выше строки, значит он встречается впервые, следовательно запишем его,
если мы находим выше, значит записываем ""&ОКРУГЛ(D4/$B4*100;) - т.е текст, а не число.
РАНГ игнорит текст в диапазоне, ссылаясь только на числа = повторов нет.
в
Код
=РАНГ(--E4;E$4:E$17)
бинарным отрицанием переводим текст в число и формула работаем


ЮMoney 41001841029809
 
Ответить
Сообщениеelovkov, если мы не находим ОКРУГЛ(D4/B4*100;) выше строки, значит он встречается впервые, следовательно запишем его,
если мы находим выше, значит записываем ""&ОКРУГЛ(D4/$B4*100;) - т.е текст, а не число.
РАНГ игнорит текст в диапазоне, ссылаясь только на числа = повторов нет.
в
Код
=РАНГ(--E4;E$4:E$17)
бинарным отрицанием переводим текст в число и формула работаем

Автор - Nic70y
Дата добавления - 25.04.2023 в 12:09
elovkov Дата: Вторник, 25.04.2023, 12:34 | Сообщение № 5
Группа: Друзья
Ранг: Обитатель
Сообщений: 381
Репутация: 51 ±
Замечаний: 0% ±

Excel 2013
Хитро
Я вот этот момент не разглядел сначала
Код
E$3:E3

Не понял что растягивается диапазон
Тоесть получается раз игнорит, то место не теряется, а так как в число перевели - все равно засчитывает.. интересно


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица
 
Ответить
СообщениеХитро
Я вот этот момент не разглядел сначала
Код
E$3:E3

Не понял что растягивается диапазон
Тоесть получается раз игнорит, то место не теряется, а так как в число перевели - все равно засчитывает.. интересно

Автор - elovkov
Дата добавления - 25.04.2023 в 12:34
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!