Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подставить значения по нескольким параметрам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Подставить значения по нескольким параметрам
ultrafviolet Дата: Четверг, 27.04.2023, 17:08 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 40% ±

Здравствуйте, нужно подставить значения в таблицу справа из левой части листа, левую часть менять нельзя. В левой части цветом выделены значения которые нужно подставить в таблицу справа
К сообщению приложен файл: podstanovka.xlsx (20.4 Kb)
 
Ответить
СообщениеЗдравствуйте, нужно подставить значения в таблицу справа из левой части листа, левую часть менять нельзя. В левой части цветом выделены значения которые нужно подставить в таблицу справа

Автор - ultrafviolet
Дата добавления - 27.04.2023 в 17:08
Serge_007 Дата: Четверг, 27.04.2023, 17:12 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Здравствуйте

Так надо?
Код
=ГПР(Q$1;$D$7:$G$15;ПОИСКПОЗ("всего";$A$7:$A$15;);)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Так надо?
Код
=ГПР(Q$1;$D$7:$G$15;ПОИСКПОЗ("всего";$A$7:$A$15;);)

Автор - Serge_007
Дата добавления - 27.04.2023 в 17:12
ultrafviolet Дата: Четверг, 27.04.2023, 17:16 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 40% ±

Serge_007, нет , так получается только первую точку считает, а надо по каждой точке в табличке справа (А1,АМР), и по периоду
 
Ответить
СообщениеSerge_007, нет , так получается только первую точку считает, а надо по каждой точке в табличке справа (А1,АМР), и по периоду

Автор - ultrafviolet
Дата добавления - 27.04.2023 в 17:16
Serge_007 Дата: Четверг, 27.04.2023, 17:21 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Тогда так:
Код
=ГПР(Q$1;$D$7:$F$999;ПОИСКПОЗ($T2;$D$1:$D$999;)+3;)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеТогда так:
Код
=ГПР(Q$1;$D$7:$F$999;ПОИСКПОЗ($T2;$D$1:$D$999;)+3;)

Автор - Serge_007
Дата добавления - 27.04.2023 в 17:21
ultrafviolet Дата: Четверг, 27.04.2023, 17:39 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 40% ±

Serge_007, а как еще и по периоду находить? я так и сяк пробую не выходит, вот справа в таблице где мы ищем нал/карта/онлайн стоит период и в таблице справа период , вот как еще и но этому условию искать? :'(
 
Ответить
СообщениеSerge_007, а как еще и по периоду находить? я так и сяк пробую не выходит, вот справа в таблице где мы ищем нал/карта/онлайн стоит период и в таблице справа период , вот как еще и но этому условию искать? :'(

Автор - ultrafviolet
Дата добавления - 27.04.2023 в 17:39
Serge_007 Дата: Четверг, 27.04.2023, 17:51 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
как еще и по периоду находить?
В файле - у всех ноябрь


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
как еще и по периоду находить?
В файле - у всех ноябрь

Автор - Serge_007
Дата добавления - 27.04.2023 в 17:51
ultrafviolet Дата: Четверг, 27.04.2023, 17:55 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 40% ±

Serge_007, ну вот если дальше месяца продолжатся
К сообщению приложен файл: 2758987.xlsx (27.2 Kb)
 
Ответить
СообщениеSerge_007, ну вот если дальше месяца продолжатся

Автор - ultrafviolet
Дата добавления - 27.04.2023 в 17:55
msi2102 Дата: Четверг, 27.04.2023, 18:02 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 413
Репутация: 129 ±
Замечаний: 0% ±

Excel 2007
Попробуйте так (массивная):
дата
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$K$185;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($B$1:$B185;{"Заказы"};));СТРОКА($1:$185));СТРОКА()-1)+1;2);"")

наличные
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$K$185;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($A$1:$A$185;{"Всего"};));СТРОКА($1:$185));СТРОКА()-1);4);"")

карта
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$K$185;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($A$1:$A$185;{"Всего"};));СТРОКА($1:$185));СТРОКА()-1);5);"")

онлайн
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$K$185;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($A$1:$A$185;{"Всего"};));СТРОКА($1:$185));СТРОКА()-1);6);"")

подразделение
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$K$185;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($D$1:$D$185;{"Выручка"};));СТРОКА($1:$185));СТРОКА()-1)+1;4);"")
К сообщению приложен файл: 2667139.xlsx (22.3 Kb)


Сообщение отредактировал msi2102 - Четверг, 27.04.2023, 18:03
 
Ответить
СообщениеПопробуйте так (массивная):
дата
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$K$185;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($B$1:$B185;{"Заказы"};));СТРОКА($1:$185));СТРОКА()-1)+1;2);"")

наличные
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$K$185;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($A$1:$A$185;{"Всего"};));СТРОКА($1:$185));СТРОКА()-1);4);"")

карта
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$K$185;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($A$1:$A$185;{"Всего"};));СТРОКА($1:$185));СТРОКА()-1);5);"")

онлайн
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$K$185;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($A$1:$A$185;{"Всего"};));СТРОКА($1:$185));СТРОКА()-1);6);"")

подразделение
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$K$185;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($D$1:$D$185;{"Выручка"};));СТРОКА($1:$185));СТРОКА()-1)+1;4);"")

Автор - msi2102
Дата добавления - 27.04.2023 в 18:02
ultrafviolet Дата: Пятница, 28.04.2023, 09:12 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 40% ±

msi2102, спасибо :o hands
 
Ответить
Сообщениеmsi2102, спасибо :o hands

Автор - ultrafviolet
Дата добавления - 28.04.2023 в 09:12
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!