Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск данных одновременно в двух таблицах - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск данных одновременно в двух таблицах (Формулы/Formulas)
Поиск данных одновременно в двух таблицах
KuvshinovaAE Дата: Воскресенье, 30.04.2023, 11:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, товарищи! Необходимо разгадать ребус)) Есть вот такая форм.:
Код
=ВПР(A2;ДВССЫЛ("'"&ИНДЕКС($E$2:$E$5;ПОИСКПОЗ(ИСТИНА;СЧЁТЕСЛИ(ДВССЫЛ("'"&$E$2:$E$5&"'!$CG:$CG");A2)>0;0))&"'!A:B");1;0)
, она должна проверять значения из двух таблиц, находящихся в разных файлах. Необходимо понять почему формула не работает (раньше работала, со слов автора) и как вообще она должна работать. Во вложении файл с задачей и два файла для поиска. От чего оттолкнуться в поисках решения? Зачем формула заключена в фигурные скобки? Эта формула не только ищет необходимое значение в таблицах, но и проверяет наличие повторяющихся ячеек в двух таблицах? И можно ли решить задачу иным способом?
К сообщению приложен файл: vneplanovye_zakupki_2022.xlsx (53.7 Kb) · plan_zakupki_tmc_2022.xlsx (54.0 Kb) · formula.xlsx (9.5 Kb)


Сообщение отредактировал KuvshinovaAE - Воскресенье, 30.04.2023, 11:09
 
Ответить
СообщениеДобрый день, товарищи! Необходимо разгадать ребус)) Есть вот такая форм.:
Код
=ВПР(A2;ДВССЫЛ("'"&ИНДЕКС($E$2:$E$5;ПОИСКПОЗ(ИСТИНА;СЧЁТЕСЛИ(ДВССЫЛ("'"&$E$2:$E$5&"'!$CG:$CG");A2)>0;0))&"'!A:B");1;0)
, она должна проверять значения из двух таблиц, находящихся в разных файлах. Необходимо понять почему формула не работает (раньше работала, со слов автора) и как вообще она должна работать. Во вложении файл с задачей и два файла для поиска. От чего оттолкнуться в поисках решения? Зачем формула заключена в фигурные скобки? Эта формула не только ищет необходимое значение в таблицах, но и проверяет наличие повторяющихся ячеек в двух таблицах? И можно ли решить задачу иным способом?

Автор - KuvshinovaAE
Дата добавления - 30.04.2023 в 11:04
Pelena Дата: Воскресенье, 30.04.2023, 13:13 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 19179
Репутация: 4418 ±
Замечаний: ±

Excel 365 & Mac Excel
Здравствуйте.
Что Вы хотите получить в столбце В?
Данная формула пытается найти значение из А2 в столбце А в файле для поиска, а там его нет.
Изложите общую цель задачи, не опираясь на представленную формулу. Или нарисуйте вручную в файле желаемый результат


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Что Вы хотите получить в столбце В?
Данная формула пытается найти значение из А2 в столбце А в файле для поиска, а там его нет.
Изложите общую цель задачи, не опираясь на представленную формулу. Или нарисуйте вручную в файле желаемый результат

Автор - Pelena
Дата добавления - 30.04.2023 в 13:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск данных одновременно в двух таблицах (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!