Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/суммировать числа из столбца B, на основании столбца A - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » суммировать числа из столбца B, на основании столбца A (Формулы/Formulas)
суммировать числа из столбца B, на основании столбца A
stalber Дата: Вторник, 02.05.2023, 15:02 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 370
Репутация: 7 ±
Замечаний: 40% ±

Excel 2007
Здравствуйте, подскажите пожалуйста формулу.
Нужно суммировать числа из столбца B, только те у которых на той же строке в столбце A число меньше 6 и больше 0
Если это важно для составления формулы, то числа из столбца A всегда идут по убыванию сверху вниз
К сообщению приложен файл: vopros02052023.xlsx (9.2 Kb)
 
Ответить
СообщениеЗдравствуйте, подскажите пожалуйста формулу.
Нужно суммировать числа из столбца B, только те у которых на той же строке в столбце A число меньше 6 и больше 0
Если это важно для составления формулы, то числа из столбца A всегда идут по убыванию сверху вниз

Автор - stalber
Дата добавления - 02.05.2023 в 15:02
alexa1965 Дата: Вторник, 02.05.2023, 15:17 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 343
Репутация: 55 ±
Замечаний: 0% ±

2003> 2019 >2016
Наверно так
Код
=СУММЕСЛИМН(B1:B29;A1:A29;">0";A1:A29;"<6")


Главное не быть балабастиком
 
Ответить
СообщениеНаверно так
Код
=СУММЕСЛИМН(B1:B29;A1:A29;">0";A1:A29;"<6")

Автор - alexa1965
Дата добавления - 02.05.2023 в 15:17
Serge_007 Дата: Вторник, 02.05.2023, 15:18 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Здравствуйте

Код
=СУММПРОИЗВ((A1:A29>0)*(6>A1:A29)*B1:B29)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=СУММПРОИЗВ((A1:A29>0)*(6>A1:A29)*B1:B29)

Автор - Serge_007
Дата добавления - 02.05.2023 в 15:18
scriptapplications Дата: Вторник, 02.05.2023, 15:41 | Сообщение № 4
Группа: Проверенные
Ранг: Участник
Сообщений: 68
Репутация: 12 ±
Замечаний: 0% ±

stalber, можно с помощью формулы массива
Код
=СУММ(ЕСЛИ((A1:A29>0)+(A1:A29<6)=2;B1:B29;0))
 
Ответить
Сообщениеstalber, можно с помощью формулы массива
Код
=СУММ(ЕСЛИ((A1:A29>0)+(A1:A29<6)=2;B1:B29;0))

Автор - scriptapplications
Дата добавления - 02.05.2023 в 15:41
Serge_007 Дата: Вторник, 02.05.2023, 15:42 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
scriptapplications, функция
Код
ЕСЛИ()
в Вашей формуле избыточна, достаточно использовать такую формулу массива:
Код
=СУММ((A1:A29>0)*(6>A1:A29)*B1:B29)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщениеscriptapplications, функция
Код
ЕСЛИ()
в Вашей формуле избыточна, достаточно использовать такую формулу массива:
Код
=СУММ((A1:A29>0)*(6>A1:A29)*B1:B29)

Автор - Serge_007
Дата добавления - 02.05.2023 в 15:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » суммировать числа из столбца B, на основании столбца A (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!